SUSE: 2022:1743-1 bci/nodejs Security Update | LinuxSecurity.com
SUSE Container Update Advisory: bci/nodejs
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2022:1743-1
Container Tags        : bci/node:12 , bci/node:12-16.126 , bci/nodejs:12 , bci/nodejs:12-16.126
Container Release     : 16.126
Severity              : important
Type                  : security
References            : 1164384 1199235 CVE-2019-20454 CVE-2022-1587 
-----------------------------------------------------------------

The container bci/nodejs was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:2649-1
Released:    Wed Aug  3 15:06:21 2022
Summary:     Security update for pcre2
Type:        security
Severity:    important
References:  1164384,1199235,CVE-2019-20454,CVE-2022-1587
This update for pcre2 fixes the following issues:

- CVE-2019-20454: Fixed out-of-bounds read in JIT mode when \X is used in non-UTF mode (bsc#1164384).
- CVE-2022-1587: Fixed out-of-bounds read due to bug in recursions (bsc#1199235).


The following package changes have been done:

- libpcre2-8-0-10.31-150000.3.12.1 updated
- container:sles15-image-15.0.0-17.20.9 updated

SUSE: 2022:1743-1 bci/nodejs Security Update

August 4, 2022
The container bci/nodejs was updated

Summary

Advisory ID: SUSE-SU-2022:2649-1 Released: Wed Aug 3 15:06:21 2022 Summary: Security update for pcre2 Type: security Severity: important

References

References : 1164384 1199235 CVE-2019-20454 CVE-2022-1587

1164384,1199235,CVE-2019-20454,CVE-2022-1587

This update for pcre2 fixes the following issues:

- CVE-2019-20454: Fixed out-of-bounds read in JIT mode when \X is used in non-UTF mode (bsc#1164384).

- CVE-2022-1587: Fixed out-of-bounds read due to bug in recursions (bsc#1199235).

The following package changes have been done:

- libpcre2-8-0-10.31-150000.3.12.1 updated

- container:sles15-image-15.0.0-17.20.9 updated

Severity
Container Advisory ID : SUSE-CU-2022:1743-1
Container Tags : bci/node:12 , bci/node:12-16.126 , bci/nodejs:12 , bci/nodejs:12-16.126
Container Release : 16.126
Severity : important
Type : security

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.