SUSE: 2022:2181-1 moderate: openssl

Advisories


   SUSE Security Update: Security update for openssl
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2181-1
Rating:             moderate
References:         #1200550 
Cross-References:   CVE-2022-2068
CVSS scores:
                    CVE-2022-2068 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for openssl fixes the following issues:

   - CVE-2022-2068: Fixed more shell code injection issues in c_rehash.
     (bsc#1200550)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2181=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2181=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2181=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2181=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2181=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2181=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (noarch):

      openssl-1_0_0-doc-1.0.2p-3.56.1

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.56.1
      libopenssl1_0_0-1.0.2p-3.56.1
      libopenssl1_0_0-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1
      openssl-1_0_0-1.0.2p-3.56.1
      openssl-1_0_0-debuginfo-1.0.2p-3.56.1
      openssl-1_0_0-debugsource-1.0.2p-3.56.1

   - SUSE OpenStack Cloud 9 (noarch):

      openssl-1_0_0-doc-1.0.2p-3.56.1

   - SUSE OpenStack Cloud 9 (x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.56.1
      libopenssl1_0_0-1.0.2p-3.56.1
      libopenssl1_0_0-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1
      openssl-1_0_0-1.0.2p-3.56.1
      openssl-1_0_0-debuginfo-1.0.2p-3.56.1
      openssl-1_0_0-debugsource-1.0.2p-3.56.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.56.1
      openssl-1_0_0-debuginfo-1.0.2p-3.56.1
      openssl-1_0_0-debugsource-1.0.2p-3.56.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (s390x x86_64):

      libopenssl-1_0_0-devel-32bit-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.56.1
      libopenssl1_0_0-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-1.0.2p-3.56.1
      openssl-1_0_0-1.0.2p-3.56.1
      openssl-1_0_0-debuginfo-1.0.2p-3.56.1
      openssl-1_0_0-debugsource-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (noarch):

      openssl-1_0_0-doc-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64):

      libopenssl1_0_0-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.56.1
      libopenssl1_0_0-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-1.0.2p-3.56.1
      openssl-1_0_0-1.0.2p-3.56.1
      openssl-1_0_0-debuginfo-1.0.2p-3.56.1
      openssl-1_0_0-debugsource-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64):

      libopenssl1_0_0-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server 12-SP5 (noarch):

      openssl-1_0_0-doc-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.56.1
      libopenssl1_0_0-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-1.0.2p-3.56.1
      openssl-1_0_0-1.0.2p-3.56.1
      openssl-1_0_0-debuginfo-1.0.2p-3.56.1
      openssl-1_0_0-debugsource-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (s390x x86_64):

      libopenssl1_0_0-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (noarch):

      openssl-1_0_0-doc-1.0.2p-3.56.1


References:

   https://www.suse.com/security/cve/CVE-2022-2068.html
   https://bugzilla.suse.com/1200550

SUSE: 2022:2181-1 moderate: openssl

June 24, 2022
An update that fixes one vulnerability is now available

Summary

This update for openssl fixes the following issues: - CVE-2022-2068: Fixed more shell code injection issues in c_rehash. (bsc#1200550) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2181=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2181=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2181=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2181=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2181=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2181=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (noarch): openssl-1_0_0-doc-1.0.2p-3.56.1 - SUSE OpenStack Cloud Crowbar 9 (x86_64): libopenssl-1_0_0-devel-1.0.2p-3.56.1 libopenssl1_0_0-1.0.2p-3.56.1 libopenssl1_0_0-32bit-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1 libopenssl1_0_0-hmac-1.0.2p-3.56.1 libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1 openssl-1_0_0-1.0.2p-3.56.1 openssl-1_0_0-debuginfo-1.0.2p-3.56.1 openssl-1_0_0-debugsource-1.0.2p-3.56.1 - SUSE OpenStack Cloud 9 (noarch): openssl-1_0_0-doc-1.0.2p-3.56.1 - SUSE OpenStack Cloud 9 (x86_64): libopenssl-1_0_0-devel-1.0.2p-3.56.1 libopenssl1_0_0-1.0.2p-3.56.1 libopenssl1_0_0-32bit-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1 libopenssl1_0_0-hmac-1.0.2p-3.56.1 libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1 openssl-1_0_0-1.0.2p-3.56.1 openssl-1_0_0-debuginfo-1.0.2p-3.56.1 openssl-1_0_0-debugsource-1.0.2p-3.56.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): libopenssl-1_0_0-devel-1.0.2p-3.56.1 openssl-1_0_0-debuginfo-1.0.2p-3.56.1 openssl-1_0_0-debugsource-1.0.2p-3.56.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (s390x x86_64): libopenssl-1_0_0-devel-32bit-1.0.2p-3.56.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): libopenssl-1_0_0-devel-1.0.2p-3.56.1 libopenssl1_0_0-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-1.0.2p-3.56.1 libopenssl1_0_0-hmac-1.0.2p-3.56.1 openssl-1_0_0-1.0.2p-3.56.1 openssl-1_0_0-debuginfo-1.0.2p-3.56.1 openssl-1_0_0-debugsource-1.0.2p-3.56.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (noarch): openssl-1_0_0-doc-1.0.2p-3.56.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64): libopenssl1_0_0-32bit-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1 libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): libopenssl-1_0_0-devel-1.0.2p-3.56.1 libopenssl1_0_0-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-1.0.2p-3.56.1 libopenssl1_0_0-hmac-1.0.2p-3.56.1 openssl-1_0_0-1.0.2p-3.56.1 openssl-1_0_0-debuginfo-1.0.2p-3.56.1 openssl-1_0_0-debugsource-1.0.2p-3.56.1 - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64): libopenssl1_0_0-32bit-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1 libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1 - SUSE Linux Enterprise Server 12-SP5 (noarch): openssl-1_0_0-doc-1.0.2p-3.56.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): libopenssl-1_0_0-devel-1.0.2p-3.56.1 libopenssl1_0_0-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-1.0.2p-3.56.1 libopenssl1_0_0-hmac-1.0.2p-3.56.1 openssl-1_0_0-1.0.2p-3.56.1 openssl-1_0_0-debuginfo-1.0.2p-3.56.1 openssl-1_0_0-debugsource-1.0.2p-3.56.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (s390x x86_64): libopenssl1_0_0-32bit-1.0.2p-3.56.1 libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.56.1 libopenssl1_0_0-hmac-32bit-1.0.2p-3.56.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (noarch): openssl-1_0_0-doc-1.0.2p-3.56.1

References

#1200550

Cross- CVE-2022-2068

CVSS scores:

CVE-2022-2068 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-2068.html

https://bugzilla.suse.com/1200550

Severity
Announcement ID: SUSE-SU-2022:2181-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.