SUSE: 2022:2395-1 important: virglrenderer | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for virglrenderer
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2395-1
Rating:             important
References:         #1195389 
Cross-References:   CVE-2022-0135
CVSS scores:
                    CVE-2022-0135 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Server Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for virglrenderer fixes the following issues:

   - CVE-2022-0135: Fix OOB in read_transfer_data. (bsc#1195389)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2395=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-2395=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      libvirglrenderer1-0.9.1-150400.3.3.1
      libvirglrenderer1-debuginfo-0.9.1-150400.3.3.1
      virglrenderer-debuginfo-0.9.1-150400.3.3.1
      virglrenderer-debugsource-0.9.1-150400.3.3.1
      virglrenderer-devel-0.9.1-150400.3.3.1
      virglrenderer-test-server-0.9.1-150400.3.3.1
      virglrenderer-test-server-debuginfo-0.9.1-150400.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      libvirglrenderer1-0.9.1-150400.3.3.1
      libvirglrenderer1-debuginfo-0.9.1-150400.3.3.1
      virglrenderer-debuginfo-0.9.1-150400.3.3.1
      virglrenderer-debugsource-0.9.1-150400.3.3.1
      virglrenderer-devel-0.9.1-150400.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-0135.html
   https://bugzilla.suse.com/1195389

SUSE: 2022:2395-1 important: virglrenderer

July 14, 2022
An update that fixes one vulnerability is now available

Summary

This update for virglrenderer fixes the following issues: - CVE-2022-0135: Fix OOB in read_transfer_data. (bsc#1195389) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2395=1 - SUSE Linux Enterprise Module for Server Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-2395=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): libvirglrenderer1-0.9.1-150400.3.3.1 libvirglrenderer1-debuginfo-0.9.1-150400.3.3.1 virglrenderer-debuginfo-0.9.1-150400.3.3.1 virglrenderer-debugsource-0.9.1-150400.3.3.1 virglrenderer-devel-0.9.1-150400.3.3.1 virglrenderer-test-server-0.9.1-150400.3.3.1 virglrenderer-test-server-debuginfo-0.9.1-150400.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64): libvirglrenderer1-0.9.1-150400.3.3.1 libvirglrenderer1-debuginfo-0.9.1-150400.3.3.1 virglrenderer-debuginfo-0.9.1-150400.3.3.1 virglrenderer-debugsource-0.9.1-150400.3.3.1 virglrenderer-devel-0.9.1-150400.3.3.1

References

#1195389

Cross- CVE-2022-0135

CVSS scores:

CVE-2022-0135 (SUSE): 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Server Applications 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-0135.html

https://bugzilla.suse.com/1195389

Severity
Announcement ID: SUSE-SU-2022:2395-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.