SUSE: 2022:2527-1 important: python-M2Crypto | LinuxSecurity.com

   SUSE Security Update: Security update for python-M2Crypto
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2527-1
Rating:             important
References:         #1178829 
Cross-References:   CVE-2020-25657
CVSS scores:
                    CVE-2020-25657 (NVD) : 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2020-25657 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 12
                    SUSE Linux Enterprise Module for Public Cloud 12
                    SUSE Linux Enterprise Server 12
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12
                    SUSE Linux Enterprise Server for SAP Applications 12-SP3
                    SUSE Linux Enterprise Server for SAP Applications 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for python-M2Crypto fixes the following issues:

   - CVE-2020-25657: Fixed Bleichenbacher timing attacks in the RSA
     decryption API (bsc#1178829).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2527=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2527=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2527=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2527=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2527=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2527=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2527=1

   - SUSE Linux Enterprise Module for Public Cloud 12:

      zypper in -t patch SUSE-SLE-Module-Public-Cloud-Unrestricted-12-2022-2527=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      python-M2Crypto-0.29.0-23.8.1
      python-M2Crypto-debuginfo-0.29.0-23.8.1
      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1
      python3-M2Crypto-debuginfo-0.29.0-23.8.1

   - SUSE OpenStack Cloud 9 (x86_64):

      python-M2Crypto-0.29.0-23.8.1
      python-M2Crypto-debuginfo-0.29.0-23.8.1
      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1
      python3-M2Crypto-debuginfo-0.29.0-23.8.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      python-M2Crypto-0.29.0-23.8.1
      python-M2Crypto-debuginfo-0.29.0-23.8.1
      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1
      python3-M2Crypto-debuginfo-0.29.0-23.8.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      python-M2Crypto-0.29.0-23.8.1
      python-M2Crypto-debuginfo-0.29.0-23.8.1
      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1
      python3-M2Crypto-debuginfo-0.29.0-23.8.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      python-M2Crypto-0.29.0-23.8.1
      python-M2Crypto-debuginfo-0.29.0-23.8.1
      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1
      python3-M2Crypto-debuginfo-0.29.0-23.8.1

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      python-M2Crypto-0.29.0-23.8.1
      python-M2Crypto-debuginfo-0.29.0-23.8.1
      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      python-M2Crypto-0.29.0-23.8.1
      python-M2Crypto-debuginfo-0.29.0-23.8.1
      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1

   - SUSE Linux Enterprise Module for Public Cloud 12 (aarch64 ppc64le s390x x86_64):

      python-M2Crypto-debugsource-0.29.0-23.8.1
      python3-M2Crypto-0.29.0-23.8.1
      python3-M2Crypto-debuginfo-0.29.0-23.8.1


References:

   https://www.suse.com/security/cve/CVE-2020-25657.html
   https://bugzilla.suse.com/1178829

SUSE: 2022:2527-1 important: python-M2Crypto

July 22, 2022
An update that fixes one vulnerability is now available

Summary

This update for python-M2Crypto fixes the following issues: - CVE-2020-25657: Fixed Bleichenbacher timing attacks in the RSA decryption API (bsc#1178829). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2527=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2527=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2527=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2527=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2527=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2527=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2527=1 - SUSE Linux Enterprise Module for Public Cloud 12: zypper in -t patch SUSE-SLE-Module-Public-Cloud-Unrestricted-12-2022-2527=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): python-M2Crypto-0.29.0-23.8.1 python-M2Crypto-debuginfo-0.29.0-23.8.1 python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 python3-M2Crypto-debuginfo-0.29.0-23.8.1 - SUSE OpenStack Cloud 9 (x86_64): python-M2Crypto-0.29.0-23.8.1 python-M2Crypto-debuginfo-0.29.0-23.8.1 python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 python3-M2Crypto-debuginfo-0.29.0-23.8.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): python-M2Crypto-0.29.0-23.8.1 python-M2Crypto-debuginfo-0.29.0-23.8.1 python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 python3-M2Crypto-debuginfo-0.29.0-23.8.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): python-M2Crypto-0.29.0-23.8.1 python-M2Crypto-debuginfo-0.29.0-23.8.1 python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 python3-M2Crypto-debuginfo-0.29.0-23.8.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): python-M2Crypto-0.29.0-23.8.1 python-M2Crypto-debuginfo-0.29.0-23.8.1 python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 python3-M2Crypto-debuginfo-0.29.0-23.8.1 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): python-M2Crypto-0.29.0-23.8.1 python-M2Crypto-debuginfo-0.29.0-23.8.1 python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): python-M2Crypto-0.29.0-23.8.1 python-M2Crypto-debuginfo-0.29.0-23.8.1 python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 - SUSE Linux Enterprise Module for Public Cloud 12 (aarch64 ppc64le s390x x86_64): python-M2Crypto-debugsource-0.29.0-23.8.1 python3-M2Crypto-0.29.0-23.8.1 python3-M2Crypto-debuginfo-0.29.0-23.8.1

References

#1178829

Cross- CVE-2020-25657

CVSS scores:

CVE-2020-25657 (NVD) : 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

CVE-2020-25657 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

SUSE Linux Enterprise High Performance Computing 12

SUSE Linux Enterprise Module for Public Cloud 12

SUSE Linux Enterprise Server 12

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12

SUSE Linux Enterprise Server for SAP Applications 12-SP3

SUSE Linux Enterprise Server for SAP Applications 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2020-25657.html

https://bugzilla.suse.com/1178829

Severity
Announcement ID: SUSE-SU-2022:2527-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.