SUSE: 2022:2537-1 important: git | LinuxSecurity.com

   SUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2537-1
Rating:             important
References:         #1200119 #1201431 
Cross-References:   CVE-2022-29187
CVSS scores:
                    CVE-2022-29187 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-29187 (SUSE): 7.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    HPE Helion Openstack 8
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE OpenStack Cloud 8
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for git fixes the following issues:

   - CVE-2022-29187: Incomplete fix for CVE-2022-24765: potential command
     injection via git worktree (bsc#1201431).
   - Allow to opt-out from the check added in the security fix for
     CVE-2022-24765 (bsc#1200119)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2537=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2537=1

   - SUSE OpenStack Cloud 8:

      zypper in -t patch SUSE-OpenStack-Cloud-8-2022-2537=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2537=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2537=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2537=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2537=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2537=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2537=1

   - HPE Helion Openstack 8:

      zypper in -t patch HPE-Helion-OpenStack-8-2022-2537=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      git-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - SUSE OpenStack Cloud 9 (x86_64):

      git-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - SUSE OpenStack Cloud 8 (x86_64):

      git-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      git-2.26.2-27.57.1
      git-arch-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-svn-debuginfo-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (noarch):

      git-doc-2.26.2-27.57.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      git-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      git-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      git-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      git-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (noarch):

      git-doc-2.26.2-27.57.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      git-2.26.2-27.57.1
      git-core-2.26.2-27.57.1
      git-core-debuginfo-2.26.2-27.57.1
      git-cvs-2.26.2-27.57.1
      git-daemon-2.26.2-27.57.1
      git-daemon-debuginfo-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1
      git-email-2.26.2-27.57.1
      git-gui-2.26.2-27.57.1
      git-svn-2.26.2-27.57.1
      git-web-2.26.2-27.57.1
      gitk-2.26.2-27.57.1

   - HPE Helion Openstack 8 (x86_64):

      git-2.26.2-27.57.1
      git-debugsource-2.26.2-27.57.1


References:

   https://www.suse.com/security/cve/CVE-2022-29187.html
   https://bugzilla.suse.com/1200119
   https://bugzilla.suse.com/1201431

SUSE: 2022:2537-1 important: git

July 22, 2022
An update that solves one vulnerability and has one errata is now available

Summary

This update for git fixes the following issues: - CVE-2022-29187: Incomplete fix for CVE-2022-24765: potential command injection via git worktree (bsc#1201431). - Allow to opt-out from the check added in the security fix for CVE-2022-24765 (bsc#1200119) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2537=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2537=1 - SUSE OpenStack Cloud 8: zypper in -t patch SUSE-OpenStack-Cloud-8-2022-2537=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2537=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2537=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2537=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2537=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2537=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2537=1 - HPE Helion Openstack 8: zypper in -t patch HPE-Helion-OpenStack-8-2022-2537=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): git-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - SUSE OpenStack Cloud 9 (x86_64): git-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - SUSE OpenStack Cloud 8 (x86_64): git-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): git-2.26.2-27.57.1 git-arch-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-svn-debuginfo-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (noarch): git-doc-2.26.2-27.57.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): git-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): git-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): git-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): git-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - SUSE Linux Enterprise Server 12-SP2-BCL (noarch): git-doc-2.26.2-27.57.1 - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): git-2.26.2-27.57.1 git-core-2.26.2-27.57.1 git-core-debuginfo-2.26.2-27.57.1 git-cvs-2.26.2-27.57.1 git-daemon-2.26.2-27.57.1 git-daemon-debuginfo-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1 git-email-2.26.2-27.57.1 git-gui-2.26.2-27.57.1 git-svn-2.26.2-27.57.1 git-web-2.26.2-27.57.1 gitk-2.26.2-27.57.1 - HPE Helion Openstack 8 (x86_64): git-2.26.2-27.57.1 git-debugsource-2.26.2-27.57.1

References

#1200119 #1201431

Cross- CVE-2022-29187

CVSS scores:

CVE-2022-29187 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-29187 (SUSE): 7.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:

HPE Helion Openstack 8

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE OpenStack Cloud 8

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-29187.html

https://bugzilla.suse.com/1200119

https://bugzilla.suse.com/1201431

Severity
Announcement ID: SUSE-SU-2022:2537-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.