SUSE: 2022:2551-1 important: nodejs16 | LinuxSecurity.com

   SUSE Security Update: Security update for nodejs16
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2551-1
Rating:             important
References:         #1192489 #1201325 #1201326 #1201327 #1201328 
                    
Cross-References:   CVE-2022-32212 CVE-2022-32213 CVE-2022-32214
                    CVE-2022-32215
CVSS scores:
                    CVE-2022-32212 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-32212 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-32213 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
                    CVE-2022-32213 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H
                    CVE-2022-32214 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
                    CVE-2022-32214 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
                    CVE-2022-32215 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
                    CVE-2022-32215 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise Module for Web Scripting 15-SP3
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Storage 7.1
                    SUSE Manager Proxy 4.2
                    SUSE Manager Retail Branch Server 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves four vulnerabilities and has one
   errata is now available.

Description:

   This update for nodejs16 fixes the following issues:

   - CVE-2022-32212: Fixed DNS rebinding in --inspect via invalid IP
     addresses (bsc#1201328).
   - CVE-2022-32213: Fixed HTTP request smuggling due to flawed parsing of
     Transfer-Encoding (bsc#1201325).
   - CVE-2022-32214: Fixed HTTP request smuggling due to improper delimiting
     of header fields (bsc#1201326).
   - CVE-2022-32215: Fixed HTTP request smuggling due to incorrect parsing of
     multi-line Transfer-Encoding (bsc#1201327).

   The following non-security bug was fixed:

   - Add buildtime version check to determine if we need patched
     openssl Requires: or already in upstream. (bsc#1192489)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-2551=1

   - SUSE Linux Enterprise Module for Web Scripting 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP3-2022-2551=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      nodejs16-16.16.0-150300.7.6.2
      nodejs16-debuginfo-16.16.0-150300.7.6.2
      nodejs16-debugsource-16.16.0-150300.7.6.2
      nodejs16-devel-16.16.0-150300.7.6.2
      npm16-16.16.0-150300.7.6.2

   - openSUSE Leap 15.3 (noarch):

      nodejs16-docs-16.16.0-150300.7.6.2

   - SUSE Linux Enterprise Module for Web Scripting 15-SP3 (aarch64 ppc64le s390x x86_64):

      nodejs16-16.16.0-150300.7.6.2
      nodejs16-debuginfo-16.16.0-150300.7.6.2
      nodejs16-debugsource-16.16.0-150300.7.6.2
      nodejs16-devel-16.16.0-150300.7.6.2
      npm16-16.16.0-150300.7.6.2

   - SUSE Linux Enterprise Module for Web Scripting 15-SP3 (noarch):

      nodejs16-docs-16.16.0-150300.7.6.2


References:

   https://www.suse.com/security/cve/CVE-2022-32212.html
   https://www.suse.com/security/cve/CVE-2022-32213.html
   https://www.suse.com/security/cve/CVE-2022-32214.html
   https://www.suse.com/security/cve/CVE-2022-32215.html
   https://bugzilla.suse.com/1192489
   https://bugzilla.suse.com/1201325
   https://bugzilla.suse.com/1201326
   https://bugzilla.suse.com/1201327
   https://bugzilla.suse.com/1201328

SUSE: 2022:2551-1 important: nodejs16

July 26, 2022
An update that solves four vulnerabilities and has one errata is now available

Summary

This update for nodejs16 fixes the following issues: - CVE-2022-32212: Fixed DNS rebinding in --inspect via invalid IP addresses (bsc#1201328). - CVE-2022-32213: Fixed HTTP request smuggling due to flawed parsing of Transfer-Encoding (bsc#1201325). - CVE-2022-32214: Fixed HTTP request smuggling due to improper delimiting of header fields (bsc#1201326). - CVE-2022-32215: Fixed HTTP request smuggling due to incorrect parsing of multi-line Transfer-Encoding (bsc#1201327). The following non-security bug was fixed: - Add buildtime version check to determine if we need patched openssl Requires: or already in upstream. (bsc#1192489) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-2551=1 - SUSE Linux Enterprise Module for Web Scripting 15-SP3: zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP3-2022-2551=1 Package List: - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): nodejs16-16.16.0-150300.7.6.2 nodejs16-debuginfo-16.16.0-150300.7.6.2 nodejs16-debugsource-16.16.0-150300.7.6.2 nodejs16-devel-16.16.0-150300.7.6.2 npm16-16.16.0-150300.7.6.2 - openSUSE Leap 15.3 (noarch): nodejs16-docs-16.16.0-150300.7.6.2 - SUSE Linux Enterprise Module for Web Scripting 15-SP3 (aarch64 ppc64le s390x x86_64): nodejs16-16.16.0-150300.7.6.2 nodejs16-debuginfo-16.16.0-150300.7.6.2 nodejs16-debugsource-16.16.0-150300.7.6.2 nodejs16-devel-16.16.0-150300.7.6.2 npm16-16.16.0-150300.7.6.2 - SUSE Linux Enterprise Module for Web Scripting 15-SP3 (noarch): nodejs16-docs-16.16.0-150300.7.6.2

References

#1192489 #1201325 #1201326 #1201327 #1201328

Cross- CVE-2022-32212 CVE-2022-32213 CVE-2022-32214

CVE-2022-32215

CVSS scores:

CVE-2022-32212 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-32212 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-32213 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

CVE-2022-32213 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H

CVE-2022-32214 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

CVE-2022-32214 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

CVE-2022-32215 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

CVE-2022-32215 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise Module for Web Scripting 15-SP3

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Storage 7.1

SUSE Manager Proxy 4.2

SUSE Manager Retail Branch Server 4.2

SUSE Manager Server 4.2

openSUSE Leap 15.3

https://www.suse.com/security/cve/CVE-2022-32212.html

https://www.suse.com/security/cve/CVE-2022-32213.html

https://www.suse.com/security/cve/CVE-2022-32214.html

https://www.suse.com/security/cve/CVE-2022-32215.html

https://bugzilla.suse.com/1192489

https://bugzilla.suse.com/1201325

https://bugzilla.suse.com/1201326

https://bugzilla.suse.com/1201327

https://bugzilla.suse.com/1201328

Severity
Announcement ID: SUSE-SU-2022:2551-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.