SUSE: 2022:2566-1 important: pcre2 | LinuxSecurity.com

   SUSE Security Update: Security update for pcre2
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2566-1
Rating:             important
References:         #1199235 
Cross-References:   CVE-2022-1587
CVSS scores:
                    CVE-2022-1587 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
                    CVE-2022-1587 (SUSE): 8.6 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Basesystem 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for pcre2 fixes the following issues:

   - CVE-2022-1587: Fixed out-of-bounds read due to bug in recursions
     (bsc#1199235).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2566=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2566=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      libpcre2-16-0-10.39-150400.4.6.1
      libpcre2-16-0-debuginfo-10.39-150400.4.6.1
      libpcre2-32-0-10.39-150400.4.6.1
      libpcre2-32-0-debuginfo-10.39-150400.4.6.1
      libpcre2-8-0-10.39-150400.4.6.1
      libpcre2-8-0-debuginfo-10.39-150400.4.6.1
      libpcre2-posix2-10.39-150400.4.6.1
      libpcre2-posix2-debuginfo-10.39-150400.4.6.1
      pcre2-debugsource-10.39-150400.4.6.1
      pcre2-devel-10.39-150400.4.6.1
      pcre2-devel-static-10.39-150400.4.6.1
      pcre2-tools-10.39-150400.4.6.1
      pcre2-tools-debuginfo-10.39-150400.4.6.1

   - openSUSE Leap 15.4 (noarch):

      pcre2-doc-10.39-150400.4.6.1

   - openSUSE Leap 15.4 (x86_64):

      libpcre2-16-0-32bit-10.39-150400.4.6.1
      libpcre2-16-0-32bit-debuginfo-10.39-150400.4.6.1
      libpcre2-32-0-32bit-10.39-150400.4.6.1
      libpcre2-32-0-32bit-debuginfo-10.39-150400.4.6.1
      libpcre2-8-0-32bit-10.39-150400.4.6.1
      libpcre2-8-0-32bit-debuginfo-10.39-150400.4.6.1
      libpcre2-posix2-32bit-10.39-150400.4.6.1
      libpcre2-posix2-32bit-debuginfo-10.39-150400.4.6.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

      libpcre2-16-0-10.39-150400.4.6.1
      libpcre2-16-0-debuginfo-10.39-150400.4.6.1
      libpcre2-32-0-10.39-150400.4.6.1
      libpcre2-32-0-debuginfo-10.39-150400.4.6.1
      libpcre2-8-0-10.39-150400.4.6.1
      libpcre2-8-0-debuginfo-10.39-150400.4.6.1
      libpcre2-posix2-10.39-150400.4.6.1
      libpcre2-posix2-debuginfo-10.39-150400.4.6.1
      pcre2-debugsource-10.39-150400.4.6.1
      pcre2-devel-10.39-150400.4.6.1


References:

   https://www.suse.com/security/cve/CVE-2022-1587.html
   https://bugzilla.suse.com/1199235

SUSE: 2022:2566-1 important: pcre2

July 27, 2022
An update that fixes one vulnerability is now available

Summary

This update for pcre2 fixes the following issues: - CVE-2022-1587: Fixed out-of-bounds read due to bug in recursions (bsc#1199235). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2566=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2566=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): libpcre2-16-0-10.39-150400.4.6.1 libpcre2-16-0-debuginfo-10.39-150400.4.6.1 libpcre2-32-0-10.39-150400.4.6.1 libpcre2-32-0-debuginfo-10.39-150400.4.6.1 libpcre2-8-0-10.39-150400.4.6.1 libpcre2-8-0-debuginfo-10.39-150400.4.6.1 libpcre2-posix2-10.39-150400.4.6.1 libpcre2-posix2-debuginfo-10.39-150400.4.6.1 pcre2-debugsource-10.39-150400.4.6.1 pcre2-devel-10.39-150400.4.6.1 pcre2-devel-static-10.39-150400.4.6.1 pcre2-tools-10.39-150400.4.6.1 pcre2-tools-debuginfo-10.39-150400.4.6.1 - openSUSE Leap 15.4 (noarch): pcre2-doc-10.39-150400.4.6.1 - openSUSE Leap 15.4 (x86_64): libpcre2-16-0-32bit-10.39-150400.4.6.1 libpcre2-16-0-32bit-debuginfo-10.39-150400.4.6.1 libpcre2-32-0-32bit-10.39-150400.4.6.1 libpcre2-32-0-32bit-debuginfo-10.39-150400.4.6.1 libpcre2-8-0-32bit-10.39-150400.4.6.1 libpcre2-8-0-32bit-debuginfo-10.39-150400.4.6.1 libpcre2-posix2-32bit-10.39-150400.4.6.1 libpcre2-posix2-32bit-debuginfo-10.39-150400.4.6.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64): libpcre2-16-0-10.39-150400.4.6.1 libpcre2-16-0-debuginfo-10.39-150400.4.6.1 libpcre2-32-0-10.39-150400.4.6.1 libpcre2-32-0-debuginfo-10.39-150400.4.6.1 libpcre2-8-0-10.39-150400.4.6.1 libpcre2-8-0-debuginfo-10.39-150400.4.6.1 libpcre2-posix2-10.39-150400.4.6.1 libpcre2-posix2-debuginfo-10.39-150400.4.6.1 pcre2-debugsource-10.39-150400.4.6.1 pcre2-devel-10.39-150400.4.6.1

References

#1199235

Cross- CVE-2022-1587

CVSS scores:

CVE-2022-1587 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

CVE-2022-1587 (SUSE): 8.6 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Basesystem 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-1587.html

https://bugzilla.suse.com/1199235

Severity
Announcement ID: SUSE-SU-2022:2566-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.