SUSE: 2022:2581-1 moderate: libguestfs | LinuxSecurity.com

   SUSE Security Update: Security update for libguestfs
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2581-1
Rating:             moderate
References:         #1201064 
Cross-References:   CVE-2022-2211
CVSS scores:
                    CVE-2022-2211 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2022-2211 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Development Tools 15-SP4
                    SUSE Linux Enterprise Module for Server Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libguestfs fixes the following issues:

   - CVE-2022-2211: Fixed a buffer overflow in get_keys (bsc#1201064).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2581=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-2581=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-2581=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      guestfs-data-1.44.2-150400.3.3.1
      guestfs-tools-1.44.2-150400.3.3.1
      guestfs-tools-debuginfo-1.44.2-150400.3.3.1
      guestfs-winsupport-1.44.2-150400.3.3.1
      guestfsd-1.44.2-150400.3.3.1
      guestfsd-debuginfo-1.44.2-150400.3.3.1
      libguestfs-debugsource-1.44.2-150400.3.3.1
      libguestfs-devel-1.44.2-150400.3.3.1
      libguestfs-test-1.44.2-150400.3.3.1
      libguestfs0-1.44.2-150400.3.3.1
      libguestfs0-debuginfo-1.44.2-150400.3.3.1
      lua-libguestfs-1.44.2-150400.3.3.1
      lua-libguestfs-debuginfo-1.44.2-150400.3.3.1
      ocaml-libguestfs-1.44.2-150400.3.3.1
      ocaml-libguestfs-debuginfo-1.44.2-150400.3.3.1
      ocaml-libguestfs-devel-1.44.2-150400.3.3.1
      perl-Sys-Guestfs-1.44.2-150400.3.3.1
      perl-Sys-Guestfs-debuginfo-1.44.2-150400.3.3.1
      python3-libguestfs-1.44.2-150400.3.3.1
      python3-libguestfs-debuginfo-1.44.2-150400.3.3.1
      rubygem-libguestfs-1.44.2-150400.3.3.1
      rubygem-libguestfs-debuginfo-1.44.2-150400.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      guestfs-data-1.44.2-150400.3.3.1
      guestfs-tools-1.44.2-150400.3.3.1
      guestfs-tools-debuginfo-1.44.2-150400.3.3.1
      guestfs-winsupport-1.44.2-150400.3.3.1
      guestfsd-1.44.2-150400.3.3.1
      guestfsd-debuginfo-1.44.2-150400.3.3.1
      libguestfs-debugsource-1.44.2-150400.3.3.1
      libguestfs-devel-1.44.2-150400.3.3.1
      libguestfs0-1.44.2-150400.3.3.1
      libguestfs0-debuginfo-1.44.2-150400.3.3.1
      perl-Sys-Guestfs-1.44.2-150400.3.3.1
      perl-Sys-Guestfs-debuginfo-1.44.2-150400.3.3.1
      python3-libguestfs-1.44.2-150400.3.3.1
      python3-libguestfs-debuginfo-1.44.2-150400.3.3.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

      libguestfs-debugsource-1.44.2-150400.3.3.1
      ocaml-libguestfs-devel-1.44.2-150400.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-2211.html
   https://bugzilla.suse.com/1201064

SUSE: 2022:2581-1 moderate: libguestfs

July 28, 2022
An update that fixes one vulnerability is now available

Summary

This update for libguestfs fixes the following issues: - CVE-2022-2211: Fixed a buffer overflow in get_keys (bsc#1201064). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2581=1 - SUSE Linux Enterprise Module for Server Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-2581=1 - SUSE Linux Enterprise Module for Development Tools 15-SP4: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-2581=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): guestfs-data-1.44.2-150400.3.3.1 guestfs-tools-1.44.2-150400.3.3.1 guestfs-tools-debuginfo-1.44.2-150400.3.3.1 guestfs-winsupport-1.44.2-150400.3.3.1 guestfsd-1.44.2-150400.3.3.1 guestfsd-debuginfo-1.44.2-150400.3.3.1 libguestfs-debugsource-1.44.2-150400.3.3.1 libguestfs-devel-1.44.2-150400.3.3.1 libguestfs-test-1.44.2-150400.3.3.1 libguestfs0-1.44.2-150400.3.3.1 libguestfs0-debuginfo-1.44.2-150400.3.3.1 lua-libguestfs-1.44.2-150400.3.3.1 lua-libguestfs-debuginfo-1.44.2-150400.3.3.1 ocaml-libguestfs-1.44.2-150400.3.3.1 ocaml-libguestfs-debuginfo-1.44.2-150400.3.3.1 ocaml-libguestfs-devel-1.44.2-150400.3.3.1 perl-Sys-Guestfs-1.44.2-150400.3.3.1 perl-Sys-Guestfs-debuginfo-1.44.2-150400.3.3.1 python3-libguestfs-1.44.2-150400.3.3.1 python3-libguestfs-debuginfo-1.44.2-150400.3.3.1 rubygem-libguestfs-1.44.2-150400.3.3.1 rubygem-libguestfs-debuginfo-1.44.2-150400.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64): guestfs-data-1.44.2-150400.3.3.1 guestfs-tools-1.44.2-150400.3.3.1 guestfs-tools-debuginfo-1.44.2-150400.3.3.1 guestfs-winsupport-1.44.2-150400.3.3.1 guestfsd-1.44.2-150400.3.3.1 guestfsd-debuginfo-1.44.2-150400.3.3.1 libguestfs-debugsource-1.44.2-150400.3.3.1 libguestfs-devel-1.44.2-150400.3.3.1 libguestfs0-1.44.2-150400.3.3.1 libguestfs0-debuginfo-1.44.2-150400.3.3.1 perl-Sys-Guestfs-1.44.2-150400.3.3.1 perl-Sys-Guestfs-debuginfo-1.44.2-150400.3.3.1 python3-libguestfs-1.44.2-150400.3.3.1 python3-libguestfs-debuginfo-1.44.2-150400.3.3.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64): libguestfs-debugsource-1.44.2-150400.3.3.1 ocaml-libguestfs-devel-1.44.2-150400.3.3.1

References

#1201064

Cross- CVE-2022-2211

CVSS scores:

CVE-2022-2211 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

CVE-2022-2211 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Development Tools 15-SP4

SUSE Linux Enterprise Module for Server Applications 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-2211.html

https://bugzilla.suse.com/1201064

Severity
Announcement ID: SUSE-SU-2022:2581-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.