SUSE: 2022:2681-1 wavpack

Advisories


   SUSE Security Update: Security update for wavpack
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2681-1
Rating:             low
References:         #1201716 
Cross-References:   CVE-2022-2476
CVSS scores:
                    CVE-2022-2476 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2022-2476 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise Module for Basesystem 15-SP4
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP3
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Linux Enterprise Storage 7.1
                    SUSE Manager Proxy 4.2
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.2
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.2
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for wavpack fixes the following issues:

   - CVE-2022-2476: Fixed a Null pointer dereference in wvunpack
     (bsc#1201716).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2681=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-2681=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2681=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-2681=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2681=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-2681=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      libwavpack1-5.4.0-150000.4.15.1
      libwavpack1-debuginfo-5.4.0-150000.4.15.1
      wavpack-5.4.0-150000.4.15.1
      wavpack-debuginfo-5.4.0-150000.4.15.1
      wavpack-debugsource-5.4.0-150000.4.15.1
      wavpack-devel-5.4.0-150000.4.15.1

   - openSUSE Leap 15.4 (x86_64):

      libwavpack1-32bit-5.4.0-150000.4.15.1
      libwavpack1-32bit-debuginfo-5.4.0-150000.4.15.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libwavpack1-5.4.0-150000.4.15.1
      libwavpack1-debuginfo-5.4.0-150000.4.15.1
      wavpack-5.4.0-150000.4.15.1
      wavpack-debuginfo-5.4.0-150000.4.15.1
      wavpack-debugsource-5.4.0-150000.4.15.1
      wavpack-devel-5.4.0-150000.4.15.1

   - openSUSE Leap 15.3 (x86_64):

      libwavpack1-32bit-5.4.0-150000.4.15.1
      libwavpack1-32bit-debuginfo-5.4.0-150000.4.15.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      wavpack-5.4.0-150000.4.15.1
      wavpack-debuginfo-5.4.0-150000.4.15.1
      wavpack-debugsource-5.4.0-150000.4.15.1
      wavpack-devel-5.4.0-150000.4.15.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      wavpack-5.4.0-150000.4.15.1
      wavpack-debuginfo-5.4.0-150000.4.15.1
      wavpack-debugsource-5.4.0-150000.4.15.1
      wavpack-devel-5.4.0-150000.4.15.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

      libwavpack1-5.4.0-150000.4.15.1
      libwavpack1-debuginfo-5.4.0-150000.4.15.1
      wavpack-debuginfo-5.4.0-150000.4.15.1
      wavpack-debugsource-5.4.0-150000.4.15.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

      libwavpack1-5.4.0-150000.4.15.1
      libwavpack1-debuginfo-5.4.0-150000.4.15.1
      wavpack-debuginfo-5.4.0-150000.4.15.1
      wavpack-debugsource-5.4.0-150000.4.15.1


References:

   https://www.suse.com/security/cve/CVE-2022-2476.html
   https://bugzilla.suse.com/1201716

SUSE: 2022:2681-1 wavpack

August 5, 2022
An update that fixes one vulnerability is now available

Summary

This update for wavpack fixes the following issues: - CVE-2022-2476: Fixed a Null pointer dereference in wvunpack (bsc#1201716). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2681=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-2681=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2681=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP3: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-2681=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2681=1 - SUSE Linux Enterprise Module for Basesystem 15-SP3: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-2681=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): libwavpack1-5.4.0-150000.4.15.1 libwavpack1-debuginfo-5.4.0-150000.4.15.1 wavpack-5.4.0-150000.4.15.1 wavpack-debuginfo-5.4.0-150000.4.15.1 wavpack-debugsource-5.4.0-150000.4.15.1 wavpack-devel-5.4.0-150000.4.15.1 - openSUSE Leap 15.4 (x86_64): libwavpack1-32bit-5.4.0-150000.4.15.1 libwavpack1-32bit-debuginfo-5.4.0-150000.4.15.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libwavpack1-5.4.0-150000.4.15.1 libwavpack1-debuginfo-5.4.0-150000.4.15.1 wavpack-5.4.0-150000.4.15.1 wavpack-debuginfo-5.4.0-150000.4.15.1 wavpack-debugsource-5.4.0-150000.4.15.1 wavpack-devel-5.4.0-150000.4.15.1 - openSUSE Leap 15.3 (x86_64): libwavpack1-32bit-5.4.0-150000.4.15.1 libwavpack1-32bit-debuginfo-5.4.0-150000.4.15.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64): wavpack-5.4.0-150000.4.15.1 wavpack-debuginfo-5.4.0-150000.4.15.1 wavpack-debugsource-5.4.0-150000.4.15.1 wavpack-devel-5.4.0-150000.4.15.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (aarch64 ppc64le s390x x86_64): wavpack-5.4.0-150000.4.15.1 wavpack-debuginfo-5.4.0-150000.4.15.1 wavpack-debugsource-5.4.0-150000.4.15.1 wavpack-devel-5.4.0-150000.4.15.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64): libwavpack1-5.4.0-150000.4.15.1 libwavpack1-debuginfo-5.4.0-150000.4.15.1 wavpack-debuginfo-5.4.0-150000.4.15.1 wavpack-debugsource-5.4.0-150000.4.15.1 - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64): libwavpack1-5.4.0-150000.4.15.1 libwavpack1-debuginfo-5.4.0-150000.4.15.1 wavpack-debuginfo-5.4.0-150000.4.15.1 wavpack-debugsource-5.4.0-150000.4.15.1

References

#1201716

Cross- CVE-2022-2476

CVSS scores:

CVE-2022-2476 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

CVE-2022-2476 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Affected Products:

SUSE Linux Enterprise Desktop 15-SP3

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Basesystem 15-SP3

SUSE Linux Enterprise Module for Basesystem 15-SP4

SUSE Linux Enterprise Module for Desktop Applications 15-SP3

SUSE Linux Enterprise Module for Desktop Applications 15-SP4

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Linux Enterprise Storage 7.1

SUSE Manager Proxy 4.2

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.2

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.2

SUSE Manager Server 4.3

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-2476.html

https://bugzilla.suse.com/1201716

Severity
Announcement ID: SUSE-SU-2022:2681-1
Rating: low

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.