SUSE: 2022:2846-1 important: zlib | LinuxSecurity.com

   SUSE Security Update: Security update for zlib
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2846-1
Rating:             important
References:         #1202175 
Cross-References:   CVE-2022-37434
CVSS scores:
                    CVE-2022-37434 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-37434 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for zlib fixes the following issues:

   - CVE-2022-37434: Fixed heap-based buffer over-read or buffer overflow via
     large gzip header extra field (bsc#1202175).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2846=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2846=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2846=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2846=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      libz1-1.2.11-3.9.1
      libz1-32bit-1.2.11-3.9.1
      libz1-debuginfo-1.2.11-3.9.1
      libz1-debuginfo-32bit-1.2.11-3.9.1
      zlib-debugsource-1.2.11-3.9.1
      zlib-devel-1.2.11-3.9.1
      zlib-devel-32bit-1.2.11-3.9.1
      zlib-devel-static-1.2.11-3.9.1
      zlib-devel-static-32bit-1.2.11-3.9.1

   - SUSE OpenStack Cloud 9 (x86_64):

      libz1-1.2.11-3.9.1
      libz1-32bit-1.2.11-3.9.1
      libz1-debuginfo-1.2.11-3.9.1
      libz1-debuginfo-32bit-1.2.11-3.9.1
      zlib-debugsource-1.2.11-3.9.1
      zlib-devel-1.2.11-3.9.1
      zlib-devel-32bit-1.2.11-3.9.1
      zlib-devel-static-1.2.11-3.9.1
      zlib-devel-static-32bit-1.2.11-3.9.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      libz1-1.2.11-3.9.1
      libz1-debuginfo-1.2.11-3.9.1
      zlib-debugsource-1.2.11-3.9.1
      zlib-devel-1.2.11-3.9.1
      zlib-devel-static-1.2.11-3.9.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64):

      libz1-32bit-1.2.11-3.9.1
      libz1-debuginfo-32bit-1.2.11-3.9.1
      zlib-devel-32bit-1.2.11-3.9.1
      zlib-devel-static-32bit-1.2.11-3.9.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      libz1-1.2.11-3.9.1
      libz1-debuginfo-1.2.11-3.9.1
      zlib-debugsource-1.2.11-3.9.1
      zlib-devel-1.2.11-3.9.1
      zlib-devel-static-1.2.11-3.9.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (s390x x86_64):

      libz1-32bit-1.2.11-3.9.1
      libz1-debuginfo-32bit-1.2.11-3.9.1
      zlib-devel-32bit-1.2.11-3.9.1
      zlib-devel-static-32bit-1.2.11-3.9.1


References:

   https://www.suse.com/security/cve/CVE-2022-37434.html
   https://bugzilla.suse.com/1202175

SUSE: 2022:2846-1 important: zlib

August 18, 2022
An update that fixes one vulnerability is now available

Summary

This update for zlib fixes the following issues: - CVE-2022-37434: Fixed heap-based buffer over-read or buffer overflow via large gzip header extra field (bsc#1202175). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2846=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2846=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2846=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2846=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): libz1-1.2.11-3.9.1 libz1-32bit-1.2.11-3.9.1 libz1-debuginfo-1.2.11-3.9.1 libz1-debuginfo-32bit-1.2.11-3.9.1 zlib-debugsource-1.2.11-3.9.1 zlib-devel-1.2.11-3.9.1 zlib-devel-32bit-1.2.11-3.9.1 zlib-devel-static-1.2.11-3.9.1 zlib-devel-static-32bit-1.2.11-3.9.1 - SUSE OpenStack Cloud 9 (x86_64): libz1-1.2.11-3.9.1 libz1-32bit-1.2.11-3.9.1 libz1-debuginfo-1.2.11-3.9.1 libz1-debuginfo-32bit-1.2.11-3.9.1 zlib-debugsource-1.2.11-3.9.1 zlib-devel-1.2.11-3.9.1 zlib-devel-32bit-1.2.11-3.9.1 zlib-devel-static-1.2.11-3.9.1 zlib-devel-static-32bit-1.2.11-3.9.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): libz1-1.2.11-3.9.1 libz1-debuginfo-1.2.11-3.9.1 zlib-debugsource-1.2.11-3.9.1 zlib-devel-1.2.11-3.9.1 zlib-devel-static-1.2.11-3.9.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64): libz1-32bit-1.2.11-3.9.1 libz1-debuginfo-32bit-1.2.11-3.9.1 zlib-devel-32bit-1.2.11-3.9.1 zlib-devel-static-32bit-1.2.11-3.9.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): libz1-1.2.11-3.9.1 libz1-debuginfo-1.2.11-3.9.1 zlib-debugsource-1.2.11-3.9.1 zlib-devel-1.2.11-3.9.1 zlib-devel-static-1.2.11-3.9.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (s390x x86_64): libz1-32bit-1.2.11-3.9.1 libz1-debuginfo-32bit-1.2.11-3.9.1 zlib-devel-32bit-1.2.11-3.9.1 zlib-devel-static-32bit-1.2.11-3.9.1

References

#1202175

Cross- CVE-2022-37434

CVSS scores:

CVE-2022-37434 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-37434 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-37434.html

https://bugzilla.suse.com/1202175

Severity
Announcement ID: SUSE-SU-2022:2846-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.