SUSE: 2022:2880-1 bci/nodejs Security Update | LinuxSecurity.com
SUSE Container Update Advisory: bci/nodejs
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2022:2880-1
Container Tags        : bci/node:12 , bci/node:12-17.45 , bci/nodejs:12 , bci/nodejs:12-17.45
Container Release     : 17.45
Severity              : important
Type                  : security
References            : 1180995 1192439 1203046 1204708 CVE-2022-43680 
-----------------------------------------------------------------

The container bci/nodejs was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-RU-2022:3901-1
Released:    Tue Nov  8 10:50:06 2022
Summary:     Recommended update for openssl-1_1
Type:        recommended
Severity:    moderate
References:  1180995,1203046
This update for openssl-1_1 fixes the following issues:

- Default to RFC7919 groups when generating ECDH parameters using 'genpkey' or 'dhparam' in FIPS mode (bsc#1180995)
- Fix memory leaks (bsc#1203046)

-----------------------------------------------------------------
Advisory ID: SUSE-RU-2022:3904-1
Released:    Tue Nov  8 10:52:13 2022
Summary:     Recommended update for openssh
Type:        recommended
Severity:    moderate
References:  1192439
This update for openssh fixes the following issue:

- Prevent empty messages from being sent. (bsc#1192439)

-----------------------------------------------------------------
Advisory ID: SUSE-RU-2022:3910-1
Released:    Tue Nov  8 13:05:04 2022
Summary:     Recommended update for pam
Type:        recommended
Severity:    moderate
References:  
This update for pam fixes the following issue:

- Update pam_motd to the most current version. (PED-1712)

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:3912-1
Released:    Tue Nov  8 13:38:11 2022
Summary:     Security update for expat
Type:        security
Severity:    important
References:  1204708,CVE-2022-43680
This update for expat fixes the following issues:

  - CVE-2022-43680: Fixed use-after free caused by overeager destruction of a shared DTD in XML_ExternalEntityParserCreate (bsc#1204708).


The following package changes have been done:

- libexpat1-2.2.5-150000.3.25.1 updated
- libopenssl1_1-hmac-1.1.1d-150200.11.54.1 updated
- libopenssl1_1-1.1.1d-150200.11.54.1 updated
- openssh-clients-8.4p1-150300.3.12.2 updated
- openssh-common-8.4p1-150300.3.12.2 updated
- openssh-fips-8.4p1-150300.3.12.2 updated
- openssl-1_1-1.1.1d-150200.11.54.1 updated
- pam-1.3.0-150000.6.61.1 updated
- container:sles15-image-15.0.0-17.20.64 updated

SUSE: 2022:2880-1 bci/nodejs Security Update

November 9, 2022
The container bci/nodejs was updated

Summary

Advisory ID: SUSE-RU-2022:3901-1 Released: Tue Nov 8 10:50:06 2022 Summary: Recommended update for openssl-1_1 Type: recommended Severity: moderate Advisory ID: SUSE-RU-2022:3904-1 Released: Tue Nov 8 10:52:13 2022 Summary: Recommended update for openssh Type: recommended Severity: moderate Advisory ID: SUSE-RU-2022:3910-1 Released: Tue Nov 8 13:05:04 2022 Summary: Recommended update for pam Type: recommended Severity: moderate Advisory ID: SUSE-SU-2022:3912-1 Released: Tue Nov 8 13:38:11 2022 Summary: Security update for expat Type: security Severity: important

References

References : 1180995 1192439 1203046 1204708 CVE-2022-43680

1180995,1203046

This update for openssl-1_1 fixes the following issues:

- Default to RFC7919 groups when generating ECDH parameters using 'genpkey' or 'dhparam' in FIPS mode (bsc#1180995)

- Fix memory leaks (bsc#1203046)

1192439

This update for openssh fixes the following issue:

- Prevent empty messages from being sent. (bsc#1192439)

This update for pam fixes the following issue:

- Update pam_motd to the most current version. (PED-1712)

1204708,CVE-2022-43680

This update for expat fixes the following issues:

- CVE-2022-43680: Fixed use-after free caused by overeager destruction of a shared DTD in XML_ExternalEntityParserCreate (bsc#1204708).

The following package changes have been done:

- libexpat1-2.2.5-150000.3.25.1 updated

- libopenssl1_1-hmac-1.1.1d-150200.11.54.1 updated

- libopenssl1_1-1.1.1d-150200.11.54.1 updated

- openssh-clients-8.4p1-150300.3.12.2 updated

- openssh-common-8.4p1-150300.3.12.2 updated

- openssh-fips-8.4p1-150300.3.12.2 updated

- openssl-1_1-1.1.1d-150200.11.54.1 updated

- pam-1.3.0-150000.6.61.1 updated

- container:sles15-image-15.0.0-17.20.64 updated

Severity
Container Advisory ID : SUSE-CU-2022:2880-1
Container Tags : bci/node:12 , bci/node:12-17.45 , bci/nodejs:12 , bci/nodejs:12-17.45
Container Release : 17.45
Severity : important
Type : security

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.