SUSE: 2022:2915-1 important: webkit2gtk3 | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2915-1
Rating:             important
References:         #1201980 
Cross-References:   CVE-2022-32792 CVE-2022-32816
CVSS scores:
                    CVE-2022-32792 (SUSE): 8.3 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
                    CVE-2022-32816 (SUSE): 5.3 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for webkit2gtk3 fixes the following issues:

   - Update to version 2.36.5 (bsc#1201980):
     - Add support for PAC proxy in the WebDriver implementation.
     - Fix video playback when loaded through custom URIs, this fixes video
       playback in the Yelp documentation browser.
     - Fix WebKitWebView::context-menu when using GTK4.
     - Fix LTO builds with GCC.
     - Fix several crashes and rendering issues.

   - Security fixes:
     - CVE-2022-32792: Fixed processing maliciously crafted web content may
       lead to arbitrary code execution.
     - CVE-2022-32816: Fixed visiting a website that frames malicious content
       may lead to UI spoofing.


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2915=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2915=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2915=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2915=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2915=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2915=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2915=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2915=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      libjavascriptcoregtk-4_0-18-2.36.5-2.107.2
      libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2
      typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2

   - SUSE OpenStack Cloud Crowbar 9 (noarch):

      libwebkit2gtk3-lang-2.36.5-2.107.2

   - SUSE OpenStack Cloud 9 (noarch):

      libwebkit2gtk3-lang-2.36.5-2.107.2

   - SUSE OpenStack Cloud 9 (x86_64):

      libjavascriptcoregtk-4_0-18-2.36.5-2.107.2
      libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2
      typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2
      webkit2gtk3-devel-2.36.5-2.107.2

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      libjavascriptcoregtk-4_0-18-2.36.5-2.107.2
      libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2
      typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2

   - SUSE Linux Enterprise Server for SAP 12-SP4 (noarch):

      libwebkit2gtk3-lang-2.36.5-2.107.2

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      libjavascriptcoregtk-4_0-18-2.36.5-2.107.2
      libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2
      typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2

   - SUSE Linux Enterprise Server 12-SP5 (noarch):

      libwebkit2gtk3-lang-2.36.5-2.107.2

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      libjavascriptcoregtk-4_0-18-2.36.5-2.107.2
      libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2
      typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2

   - SUSE Linux Enterprise Server 12-SP4-LTSS (noarch):

      libwebkit2gtk3-lang-2.36.5-2.107.2

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      libjavascriptcoregtk-4_0-18-2.36.5-2.107.2
      libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2
      typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2-4_0-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      libjavascriptcoregtk-4_0-18-2.36.5-2.107.2
      libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-2.36.5-2.107.2
      libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2
      typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2-4_0-2.36.5-2.107.2
      typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2
      webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2
      webkit2gtk3-debugsource-2.36.5-2.107.2
      webkit2gtk3-devel-2.36.5-2.107.2

   - SUSE Linux Enterprise Server 12-SP2-BCL (noarch):

      libwebkit2gtk3-lang-2.36.5-2.107.2


References:

   https://www.suse.com/security/cve/CVE-2022-32792.html
   https://www.suse.com/security/cve/CVE-2022-32816.html
   https://bugzilla.suse.com/1201980

SUSE: 2022:2915-1 important: webkit2gtk3

August 26, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for webkit2gtk3 fixes the following issues: - Update to version 2.36.5 (bsc#1201980): - Add support for PAC proxy in the WebDriver implementation. - Fix video playback when loaded through custom URIs, this fixes video playback in the Yelp documentation browser. - Fix WebKitWebView::context-menu when using GTK4. - Fix LTO builds with GCC. - Fix several crashes and rendering issues. - Security fixes: - CVE-2022-32792: Fixed processing maliciously crafted web content may lead to arbitrary code execution. - CVE-2022-32816: Fixed visiting a website that frames malicious content may lead to UI spoofing. Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2915=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2915=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2915=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2915=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2915=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2915=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2915=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2915=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): libjavascriptcoregtk-4_0-18-2.36.5-2.107.2 libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2 libwebkit2gtk-4_0-37-2.36.5-2.107.2 libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2 typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 - SUSE OpenStack Cloud Crowbar 9 (noarch): libwebkit2gtk3-lang-2.36.5-2.107.2 - SUSE OpenStack Cloud 9 (noarch): libwebkit2gtk3-lang-2.36.5-2.107.2 - SUSE OpenStack Cloud 9 (x86_64): libjavascriptcoregtk-4_0-18-2.36.5-2.107.2 libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2 libwebkit2gtk-4_0-37-2.36.5-2.107.2 libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2 typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 webkit2gtk3-devel-2.36.5-2.107.2 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): libjavascriptcoregtk-4_0-18-2.36.5-2.107.2 libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2 libwebkit2gtk-4_0-37-2.36.5-2.107.2 libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2 typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 - SUSE Linux Enterprise Server for SAP 12-SP4 (noarch): libwebkit2gtk3-lang-2.36.5-2.107.2 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.36.5-2.107.2 libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2 libwebkit2gtk-4_0-37-2.36.5-2.107.2 libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2 typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 - SUSE Linux Enterprise Server 12-SP5 (noarch): libwebkit2gtk3-lang-2.36.5-2.107.2 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.36.5-2.107.2 libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2 libwebkit2gtk-4_0-37-2.36.5-2.107.2 libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2 typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 - SUSE Linux Enterprise Server 12-SP4-LTSS (noarch): libwebkit2gtk3-lang-2.36.5-2.107.2 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): libjavascriptcoregtk-4_0-18-2.36.5-2.107.2 libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2 libwebkit2gtk-4_0-37-2.36.5-2.107.2 libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2 typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2-4_0-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): libjavascriptcoregtk-4_0-18-2.36.5-2.107.2 libjavascriptcoregtk-4_0-18-debuginfo-2.36.5-2.107.2 libwebkit2gtk-4_0-37-2.36.5-2.107.2 libwebkit2gtk-4_0-37-debuginfo-2.36.5-2.107.2 typelib-1_0-JavaScriptCore-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2-4_0-2.36.5-2.107.2 typelib-1_0-WebKit2WebExtension-4_0-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-2.36.5-2.107.2 webkit2gtk-4_0-injected-bundles-debuginfo-2.36.5-2.107.2 webkit2gtk3-debugsource-2.36.5-2.107.2 webkit2gtk3-devel-2.36.5-2.107.2 - SUSE Linux Enterprise Server 12-SP2-BCL (noarch): libwebkit2gtk3-lang-2.36.5-2.107.2

References

#1201980

Cross- CVE-2022-32792 CVE-2022-32816

CVSS scores:

CVE-2022-32792 (SUSE): 8.3 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

CVE-2022-32816 (SUSE): 5.3 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Affected Products:

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-32792.html

https://www.suse.com/security/cve/CVE-2022-32816.html

https://bugzilla.suse.com/1201980

Severity
Announcement ID: SUSE-SU-2022:2915-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.