SUSE: 2022:2922-1 important: libyang | LinuxSecurity.com

   SUSE Security Update: Security update for libyang
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2922-1
Rating:             important
References:         #1186377 
Cross-References:   CVE-2021-28905
CVSS scores:
                    CVE-2021-28905 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-28905 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Server Applications 15-SP3
                    SUSE Linux Enterprise Module for Server Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Linux Enterprise Storage 7.1
                    SUSE Manager Proxy 4.2
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.2
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.2
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libyang fixes the following issues:

   - CVE-2021-28905: Fixed a reachable assertion which could be exploited by
     an attacker to cause a denial of service (bsc#1186377).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2922=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-2922=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-2922=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-2922=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      libyang-cpp-devel-1.0.184-150300.3.3.1
      libyang-cpp1-1.0.184-150300.3.3.1
      libyang-cpp1-debuginfo-1.0.184-150300.3.3.1
      libyang-debuginfo-1.0.184-150300.3.3.1
      libyang-debugsource-1.0.184-150300.3.3.1
      libyang-devel-1.0.184-150300.3.3.1
      libyang-extentions-1.0.184-150300.3.3.1
      libyang-extentions-debuginfo-1.0.184-150300.3.3.1
      libyang1-1.0.184-150300.3.3.1
      libyang1-debuginfo-1.0.184-150300.3.3.1
      python3-yang-1.0.184-150300.3.3.1
      python3-yang-debuginfo-1.0.184-150300.3.3.1
      yang-tools-1.0.184-150300.3.3.1
      yang-tools-debuginfo-1.0.184-150300.3.3.1

   - openSUSE Leap 15.4 (noarch):

      libyang-doc-1.0.184-150300.3.3.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libyang-cpp-devel-1.0.184-150300.3.3.1
      libyang-cpp1-1.0.184-150300.3.3.1
      libyang-cpp1-debuginfo-1.0.184-150300.3.3.1
      libyang-debuginfo-1.0.184-150300.3.3.1
      libyang-debugsource-1.0.184-150300.3.3.1
      libyang-devel-1.0.184-150300.3.3.1
      libyang-extentions-1.0.184-150300.3.3.1
      libyang-extentions-debuginfo-1.0.184-150300.3.3.1
      libyang1-1.0.184-150300.3.3.1
      libyang1-debuginfo-1.0.184-150300.3.3.1
      python3-yang-1.0.184-150300.3.3.1
      python3-yang-debuginfo-1.0.184-150300.3.3.1
      yang-tools-1.0.184-150300.3.3.1
      yang-tools-debuginfo-1.0.184-150300.3.3.1

   - openSUSE Leap 15.3 (noarch):

      libyang-doc-1.0.184-150300.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      libyang-debuginfo-1.0.184-150300.3.3.1
      libyang-debugsource-1.0.184-150300.3.3.1
      libyang-extentions-1.0.184-150300.3.3.1
      libyang-extentions-debuginfo-1.0.184-150300.3.3.1
      libyang1-1.0.184-150300.3.3.1
      libyang1-debuginfo-1.0.184-150300.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      libyang-debuginfo-1.0.184-150300.3.3.1
      libyang-debugsource-1.0.184-150300.3.3.1
      libyang-extentions-1.0.184-150300.3.3.1
      libyang-extentions-debuginfo-1.0.184-150300.3.3.1
      libyang1-1.0.184-150300.3.3.1
      libyang1-debuginfo-1.0.184-150300.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-28905.html
   https://bugzilla.suse.com/1186377

SUSE: 2022:2922-1 important: libyang

August 26, 2022
An update that fixes one vulnerability is now available

Summary

This update for libyang fixes the following issues: - CVE-2021-28905: Fixed a reachable assertion which could be exploited by an attacker to cause a denial of service (bsc#1186377). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2922=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-2922=1 - SUSE Linux Enterprise Module for Server Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-2922=1 - SUSE Linux Enterprise Module for Server Applications 15-SP3: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-2922=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): libyang-cpp-devel-1.0.184-150300.3.3.1 libyang-cpp1-1.0.184-150300.3.3.1 libyang-cpp1-debuginfo-1.0.184-150300.3.3.1 libyang-debuginfo-1.0.184-150300.3.3.1 libyang-debugsource-1.0.184-150300.3.3.1 libyang-devel-1.0.184-150300.3.3.1 libyang-extentions-1.0.184-150300.3.3.1 libyang-extentions-debuginfo-1.0.184-150300.3.3.1 libyang1-1.0.184-150300.3.3.1 libyang1-debuginfo-1.0.184-150300.3.3.1 python3-yang-1.0.184-150300.3.3.1 python3-yang-debuginfo-1.0.184-150300.3.3.1 yang-tools-1.0.184-150300.3.3.1 yang-tools-debuginfo-1.0.184-150300.3.3.1 - openSUSE Leap 15.4 (noarch): libyang-doc-1.0.184-150300.3.3.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libyang-cpp-devel-1.0.184-150300.3.3.1 libyang-cpp1-1.0.184-150300.3.3.1 libyang-cpp1-debuginfo-1.0.184-150300.3.3.1 libyang-debuginfo-1.0.184-150300.3.3.1 libyang-debugsource-1.0.184-150300.3.3.1 libyang-devel-1.0.184-150300.3.3.1 libyang-extentions-1.0.184-150300.3.3.1 libyang-extentions-debuginfo-1.0.184-150300.3.3.1 libyang1-1.0.184-150300.3.3.1 libyang1-debuginfo-1.0.184-150300.3.3.1 python3-yang-1.0.184-150300.3.3.1 python3-yang-debuginfo-1.0.184-150300.3.3.1 yang-tools-1.0.184-150300.3.3.1 yang-tools-debuginfo-1.0.184-150300.3.3.1 - openSUSE Leap 15.3 (noarch): libyang-doc-1.0.184-150300.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64): libyang-debuginfo-1.0.184-150300.3.3.1 libyang-debugsource-1.0.184-150300.3.3.1 libyang-extentions-1.0.184-150300.3.3.1 libyang-extentions-debuginfo-1.0.184-150300.3.3.1 libyang1-1.0.184-150300.3.3.1 libyang1-debuginfo-1.0.184-150300.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64): libyang-debuginfo-1.0.184-150300.3.3.1 libyang-debugsource-1.0.184-150300.3.3.1 libyang-extentions-1.0.184-150300.3.3.1 libyang-extentions-debuginfo-1.0.184-150300.3.3.1 libyang1-1.0.184-150300.3.3.1 libyang1-debuginfo-1.0.184-150300.3.3.1

References

#1186377

Cross- CVE-2021-28905

CVSS scores:

CVE-2021-28905 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2021-28905 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Server Applications 15-SP3

SUSE Linux Enterprise Module for Server Applications 15-SP4

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Linux Enterprise Storage 7.1

SUSE Manager Proxy 4.2

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.2

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.2

SUSE Manager Server 4.3

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2021-28905.html

https://bugzilla.suse.com/1186377

Severity
Announcement ID: SUSE-SU-2022:2922-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.