SUSE: 2022:2938-1 suse/sles12sp4 Security Update | LinuxSecurity.com
SUSE Container Update Advisory: suse/sles12sp4
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2022:2938-1
Container Tags        : suse/sles12sp4:26.529 , suse/sles12sp4:latest
Container Release     : 26.529
Severity              : moderate
Type                  : security
References            : 1183543 1183545 1183632 1183659 1185299 1193625 1196852 996280
                        CVE-2015-8985 CVE-2021-20266 CVE-2021-20271 CVE-2021-3421 
-----------------------------------------------------------------

The container suse/sles12sp4 was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:3939-1
Released:    Thu Nov 10 14:32:05 2022
Summary:     Security update for rpm
Type:        security
Severity:    moderate
References:  1183543,1183545,1183632,1183659,1185299,996280,CVE-2021-20266,CVE-2021-20271,CVE-2021-3421
This update for rpm fixes the following issues:

- Fixed PGP parsing bugs (bsc#1185299).
- Fixed various format handling bugs (bsc#996280).
- CVE-2021-3421: Fixed vulnerability where unsigned headers could be injected into the rpm database (bsc#1183543). 
- CVE-2021-20271: Fixed vulnerability where a corrupted rpm could corrupt the rpm database (bsc#1183545).
- CVE-2021-20266: Fixed missing bounds check in hdrblobInit (bsc#1183632).

Bugfixes:

- Fixed deadlock when multiple rpm processes tried to acquire the database lock (bsc#1183659).

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:3942-1
Released:    Thu Nov 10 15:58:47 2022
Summary:     Security update for glibc
Type:        security
Severity:    moderate
References:  1193625,1196852,CVE-2015-8985
This update for glibc fixes the following issues:

- CVE-2015-8985: Fixed assertion failure in pop_fail_stack when executing
  a malformed regexp (bsc#1193625)

- x86: fix stack alignment in pthread_cond_[timed]wait (bsc#1196852)
- Recognize ppc64p7 arch to build for power7


The following package changes have been done:

- base-container-licenses-3.0-1.326 updated
- container-suseconnect-2.0.0-1.211 updated
- glibc-2.22-114.22.1 updated
- rpm-4.11.2-16.26.1 updated

SUSE: 2022:2938-1 suse/sles12sp4 Security Update

November 11, 2022
The container suse/sles12sp4 was updated

Summary

Advisory ID: SUSE-SU-2022:3939-1 Released: Thu Nov 10 14:32:05 2022 Summary: Security update for rpm Type: security Severity: moderate Advisory ID: SUSE-SU-2022:3942-1 Released: Thu Nov 10 15:58:47 2022 Summary: Security update for glibc Type: security Severity: moderate

References

References : 1183543 1183545 1183632 1183659 1185299 1193625 1196852 996280

CVE-2015-8985 CVE-2021-20266 CVE-2021-20271 CVE-2021-3421

1183543,1183545,1183632,1183659,1185299,996280,CVE-2021-20266,CVE-2021-20271,CVE-2021-3421

This update for rpm fixes the following issues:

- Fixed PGP parsing bugs (bsc#1185299).

- Fixed various format handling bugs (bsc#996280).

- CVE-2021-3421: Fixed vulnerability where unsigned headers could be injected into the rpm database (bsc#1183543).

- CVE-2021-20271: Fixed vulnerability where a corrupted rpm could corrupt the rpm database (bsc#1183545).

- CVE-2021-20266: Fixed missing bounds check in hdrblobInit (bsc#1183632).

Bugfixes:

- Fixed deadlock when multiple rpm processes tried to acquire the database lock (bsc#1183659).

1193625,1196852,CVE-2015-8985

This update for glibc fixes the following issues:

- CVE-2015-8985: Fixed assertion failure in pop_fail_stack when executing

a malformed regexp (bsc#1193625)

- x86: fix stack alignment in pthread_cond_[timed]wait (bsc#1196852)

- Recognize ppc64p7 arch to build for power7

The following package changes have been done:

- base-container-licenses-3.0-1.326 updated

- container-suseconnect-2.0.0-1.211 updated

- glibc-2.22-114.22.1 updated

- rpm-4.11.2-16.26.1 updated

Severity
Container Advisory ID : SUSE-CU-2022:2938-1
Container Tags : suse/sles12sp4:26.529 , suse/sles12sp4:latest
Container Release : 26.529
Severity : moderate
Type : security

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.