SUSE: 2022:2993-1 important: freerdp | LinuxSecurity.com

   SUSE Security Update: Security update for freerdp
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2993-1
Rating:             important
References:         #1191895 
Cross-References:   CVE-2021-41159 CVE-2021-41160
CVSS scores:
                    CVE-2021-41159 (NVD) : 5.8 CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N
                    CVE-2021-41159 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-41160 (NVD) : 5.3 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N
                    CVE-2021-41160 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Linux Enterprise Workstation Extension 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for freerdp fixes the following issues:

   - Fixed two input validation issues (bsc#1191895):
     - CVE-2021-41159: Fixed an improper validation of client input for
       gateway connections.
     - CVE-2021-41160: Fixed improper region checks that could lead to memory
       corruption.


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2993=1

   - SUSE Linux Enterprise Workstation Extension 15-SP4:

      zypper in -t patch SUSE-SLE-Product-WE-15-SP4-2022-2993=1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-2993=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      freerdp-2.4.0-150400.3.6.1
      freerdp-debuginfo-2.4.0-150400.3.6.1
      freerdp-debugsource-2.4.0-150400.3.6.1
      freerdp-devel-2.4.0-150400.3.6.1
      freerdp-proxy-2.4.0-150400.3.6.1
      freerdp-proxy-debuginfo-2.4.0-150400.3.6.1
      freerdp-server-2.4.0-150400.3.6.1
      freerdp-server-debuginfo-2.4.0-150400.3.6.1
      freerdp-wayland-2.4.0-150400.3.6.1
      freerdp-wayland-debuginfo-2.4.0-150400.3.6.1
      libfreerdp2-2.4.0-150400.3.6.1
      libfreerdp2-debuginfo-2.4.0-150400.3.6.1
      libuwac0-0-2.4.0-150400.3.6.1
      libuwac0-0-debuginfo-2.4.0-150400.3.6.1
      libwinpr2-2.4.0-150400.3.6.1
      libwinpr2-debuginfo-2.4.0-150400.3.6.1
      uwac0-0-devel-2.4.0-150400.3.6.1
      winpr2-devel-2.4.0-150400.3.6.1

   - SUSE Linux Enterprise Workstation Extension 15-SP4 (x86_64):

      freerdp-2.4.0-150400.3.6.1
      freerdp-debuginfo-2.4.0-150400.3.6.1
      freerdp-debugsource-2.4.0-150400.3.6.1
      freerdp-devel-2.4.0-150400.3.6.1
      freerdp-proxy-2.4.0-150400.3.6.1
      freerdp-proxy-debuginfo-2.4.0-150400.3.6.1
      libfreerdp2-2.4.0-150400.3.6.1
      libfreerdp2-debuginfo-2.4.0-150400.3.6.1
      libwinpr2-2.4.0-150400.3.6.1
      libwinpr2-debuginfo-2.4.0-150400.3.6.1
      winpr2-devel-2.4.0-150400.3.6.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4 (aarch64 ppc64le s390x):

      freerdp-2.4.0-150400.3.6.1
      freerdp-debuginfo-2.4.0-150400.3.6.1
      freerdp-debugsource-2.4.0-150400.3.6.1
      freerdp-devel-2.4.0-150400.3.6.1
      freerdp-proxy-2.4.0-150400.3.6.1
      freerdp-proxy-debuginfo-2.4.0-150400.3.6.1
      libfreerdp2-2.4.0-150400.3.6.1
      libfreerdp2-debuginfo-2.4.0-150400.3.6.1
      libwinpr2-2.4.0-150400.3.6.1
      libwinpr2-debuginfo-2.4.0-150400.3.6.1
      winpr2-devel-2.4.0-150400.3.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-41159.html
   https://www.suse.com/security/cve/CVE-2021-41160.html
   https://bugzilla.suse.com/1191895

SUSE: 2022:2993-1 important: freerdp

September 2, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for freerdp fixes the following issues: - Fixed two input validation issues (bsc#1191895): - CVE-2021-41159: Fixed an improper validation of client input for gateway connections. - CVE-2021-41160: Fixed improper region checks that could lead to memory corruption. Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2993=1 - SUSE Linux Enterprise Workstation Extension 15-SP4: zypper in -t patch SUSE-SLE-Product-WE-15-SP4-2022-2993=1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4: zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2022-2993=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): freerdp-2.4.0-150400.3.6.1 freerdp-debuginfo-2.4.0-150400.3.6.1 freerdp-debugsource-2.4.0-150400.3.6.1 freerdp-devel-2.4.0-150400.3.6.1 freerdp-proxy-2.4.0-150400.3.6.1 freerdp-proxy-debuginfo-2.4.0-150400.3.6.1 freerdp-server-2.4.0-150400.3.6.1 freerdp-server-debuginfo-2.4.0-150400.3.6.1 freerdp-wayland-2.4.0-150400.3.6.1 freerdp-wayland-debuginfo-2.4.0-150400.3.6.1 libfreerdp2-2.4.0-150400.3.6.1 libfreerdp2-debuginfo-2.4.0-150400.3.6.1 libuwac0-0-2.4.0-150400.3.6.1 libuwac0-0-debuginfo-2.4.0-150400.3.6.1 libwinpr2-2.4.0-150400.3.6.1 libwinpr2-debuginfo-2.4.0-150400.3.6.1 uwac0-0-devel-2.4.0-150400.3.6.1 winpr2-devel-2.4.0-150400.3.6.1 - SUSE Linux Enterprise Workstation Extension 15-SP4 (x86_64): freerdp-2.4.0-150400.3.6.1 freerdp-debuginfo-2.4.0-150400.3.6.1 freerdp-debugsource-2.4.0-150400.3.6.1 freerdp-devel-2.4.0-150400.3.6.1 freerdp-proxy-2.4.0-150400.3.6.1 freerdp-proxy-debuginfo-2.4.0-150400.3.6.1 libfreerdp2-2.4.0-150400.3.6.1 libfreerdp2-debuginfo-2.4.0-150400.3.6.1 libwinpr2-2.4.0-150400.3.6.1 libwinpr2-debuginfo-2.4.0-150400.3.6.1 winpr2-devel-2.4.0-150400.3.6.1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4 (aarch64 ppc64le s390x): freerdp-2.4.0-150400.3.6.1 freerdp-debuginfo-2.4.0-150400.3.6.1 freerdp-debugsource-2.4.0-150400.3.6.1 freerdp-devel-2.4.0-150400.3.6.1 freerdp-proxy-2.4.0-150400.3.6.1 freerdp-proxy-debuginfo-2.4.0-150400.3.6.1 libfreerdp2-2.4.0-150400.3.6.1 libfreerdp2-debuginfo-2.4.0-150400.3.6.1 libwinpr2-2.4.0-150400.3.6.1 libwinpr2-debuginfo-2.4.0-150400.3.6.1 winpr2-devel-2.4.0-150400.3.6.1

References

#1191895

Cross- CVE-2021-41159 CVE-2021-41160

CVSS scores:

CVE-2021-41159 (NVD) : 5.8 CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N

CVE-2021-41159 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2021-41160 (NVD) : 5.3 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N

CVE-2021-41160 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Linux Enterprise Workstation Extension 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2021-41159.html

https://www.suse.com/security/cve/CVE-2021-41160.html

https://bugzilla.suse.com/1191895

Severity
Announcement ID: SUSE-SU-2022:2993-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.