SUSE: 2022:2997-1 important: python-pyxdg | LinuxSecurity.com

   SUSE Security Update: Security update for python-pyxdg
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2997-1
Rating:             important
References:         #1137627 
Cross-References:   CVE-2019-12761
CVSS scores:
                    CVE-2019-12761 (NVD) : 7.5 CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2019-12761 (SUSE): 7.3 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Affected Products:
                    SUSE CaaS Platform 4.0
                    SUSE Enterprise Storage 6
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server for SAP 15-SP1
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for python-pyxdg fixes the following issues:

   - CVE-2019-12761: Fixed a code injection issue in Category elements of a
     Menu XML (bsc#1137627).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-2997=1

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-2997=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-2997=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-2997=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-2997=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-2997=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-2997=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-2997=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-2997=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2022-2997=1

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE Linux Enterprise Server for SAP 15-SP1 (noarch):

      python2-pyxdg-0.25-150000.3.3.1
      python3-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      python2-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (noarch):

      python2-pyxdg-0.25-150000.3.3.1
      python3-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (noarch):

      python2-pyxdg-0.25-150000.3.3.1
      python3-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      python2-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch):

      python2-pyxdg-0.25-150000.3.3.1
      python3-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch):

      python2-pyxdg-0.25-150000.3.3.1
      python3-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      python2-pyxdg-0.25-150000.3.3.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      python2-pyxdg-0.25-150000.3.3.1

   - SUSE Enterprise Storage 6 (noarch):

      python2-pyxdg-0.25-150000.3.3.1
      python3-pyxdg-0.25-150000.3.3.1

   - SUSE CaaS Platform 4.0 (noarch):

      python2-pyxdg-0.25-150000.3.3.1
      python3-pyxdg-0.25-150000.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2019-12761.html
   https://bugzilla.suse.com/1137627

SUSE: 2022:2997-1 important: python-pyxdg

September 2, 2022
An update that fixes one vulnerability is now available

Summary

This update for python-pyxdg fixes the following issues: - CVE-2019-12761: Fixed a code injection issue in Category elements of a Menu XML (bsc#1137627). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Server for SAP 15-SP1: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-2997=1 - SUSE Linux Enterprise Server for SAP 15: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-2997=1 - SUSE Linux Enterprise Server 15-SP1-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-2997=1 - SUSE Linux Enterprise Server 15-SP1-BCL: zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-2997=1 - SUSE Linux Enterprise Server 15-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-2022-2997=1 - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-2997=1 - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-2997=1 - SUSE Linux Enterprise High Performance Computing 15-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-2022-2997=1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-2022-2997=1 - SUSE Enterprise Storage 6: zypper in -t patch SUSE-Storage-6-2022-2997=1 - SUSE CaaS Platform 4.0: To install this update, use the SUSE CaaS Platform 'skuba' tool. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way. Package List: - SUSE Linux Enterprise Server for SAP 15-SP1 (noarch): python2-pyxdg-0.25-150000.3.3.1 python3-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise Server for SAP 15 (noarch): python2-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise Server 15-SP1-LTSS (noarch): python2-pyxdg-0.25-150000.3.3.1 python3-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise Server 15-SP1-BCL (noarch): python2-pyxdg-0.25-150000.3.3.1 python3-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise Server 15-LTSS (noarch): python2-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch): python2-pyxdg-0.25-150000.3.3.1 python3-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch): python2-pyxdg-0.25-150000.3.3.1 python3-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch): python2-pyxdg-0.25-150000.3.3.1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch): python2-pyxdg-0.25-150000.3.3.1 - SUSE Enterprise Storage 6 (noarch): python2-pyxdg-0.25-150000.3.3.1 python3-pyxdg-0.25-150000.3.3.1 - SUSE CaaS Platform 4.0 (noarch): python2-pyxdg-0.25-150000.3.3.1 python3-pyxdg-0.25-150000.3.3.1

References

#1137627

Cross- CVE-2019-12761

CVSS scores:

CVE-2019-12761 (NVD) : 7.5 CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2019-12761 (SUSE): 7.3 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Affected Products:

SUSE CaaS Platform 4.0

SUSE Enterprise Storage 6

SUSE Linux Enterprise High Performance Computing 15-ESPOS

SUSE Linux Enterprise High Performance Computing 15-LTSS

SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS

SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS

SUSE Linux Enterprise Server 15-LTSS

SUSE Linux Enterprise Server 15-SP1-BCL

SUSE Linux Enterprise Server 15-SP1-LTSS

SUSE Linux Enterprise Server for SAP 15

SUSE Linux Enterprise Server for SAP 15-SP1

https://www.suse.com/security/cve/CVE-2019-12761.html

https://bugzilla.suse.com/1137627

Severity
Announcement ID: SUSE-SU-2022:2997-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.