SUSE: 2022:2998-1 moderate: ImageMagick | LinuxSecurity.com

   SUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2998-1
Rating:             moderate
References:         #1199350 #1202250 
Cross-References:   CVE-2022-2719 CVE-2022-28463
CVSS scores:
                    CVE-2022-2719 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2022-2719 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2022-28463 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-28463 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP4
                    SUSE Linux Enterprise Module for Development Tools 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for ImageMagick fixes the following issues:

   - CVE-2022-2719: Fixed a reachable assertion that could lead to denial
     of service via a crafted file (bsc#1202250).
   - CVE-2022-28463: Fixed a buffer overflow that could be triggered by a
     crafted input file (bsc#1199350).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2998=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-2998=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2998=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      ImageMagick-7.1.0.9-150400.6.6.1
      ImageMagick-config-7-SUSE-7.1.0.9-150400.6.6.1
      ImageMagick-config-7-upstream-7.1.0.9-150400.6.6.1
      ImageMagick-debuginfo-7.1.0.9-150400.6.6.1
      ImageMagick-debugsource-7.1.0.9-150400.6.6.1
      ImageMagick-devel-7.1.0.9-150400.6.6.1
      ImageMagick-extra-7.1.0.9-150400.6.6.1
      ImageMagick-extra-debuginfo-7.1.0.9-150400.6.6.1
      libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.6.1
      libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.6.1
      libMagick++-devel-7.1.0.9-150400.6.6.1
      libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.6.1
      libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1
      libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.6.1
      libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1
      perl-PerlMagick-7.1.0.9-150400.6.6.1
      perl-PerlMagick-debuginfo-7.1.0.9-150400.6.6.1

   - openSUSE Leap 15.4 (x86_64):

      ImageMagick-devel-32bit-7.1.0.9-150400.6.6.1
      libMagick++-7_Q16HDRI5-32bit-7.1.0.9-150400.6.6.1
      libMagick++-7_Q16HDRI5-32bit-debuginfo-7.1.0.9-150400.6.6.1
      libMagick++-devel-32bit-7.1.0.9-150400.6.6.1
      libMagickCore-7_Q16HDRI10-32bit-7.1.0.9-150400.6.6.1
      libMagickCore-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.6.1
      libMagickWand-7_Q16HDRI10-32bit-7.1.0.9-150400.6.6.1
      libMagickWand-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.6.1

   - openSUSE Leap 15.4 (noarch):

      ImageMagick-doc-7.1.0.9-150400.6.6.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

      ImageMagick-debuginfo-7.1.0.9-150400.6.6.1
      ImageMagick-debugsource-7.1.0.9-150400.6.6.1
      perl-PerlMagick-7.1.0.9-150400.6.6.1
      perl-PerlMagick-debuginfo-7.1.0.9-150400.6.6.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      ImageMagick-7.1.0.9-150400.6.6.1
      ImageMagick-config-7-SUSE-7.1.0.9-150400.6.6.1
      ImageMagick-config-7-upstream-7.1.0.9-150400.6.6.1
      ImageMagick-debuginfo-7.1.0.9-150400.6.6.1
      ImageMagick-debugsource-7.1.0.9-150400.6.6.1
      ImageMagick-devel-7.1.0.9-150400.6.6.1
      libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.6.1
      libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.6.1
      libMagick++-devel-7.1.0.9-150400.6.6.1
      libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.6.1
      libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1
      libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.6.1
      libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1


References:

   https://www.suse.com/security/cve/CVE-2022-2719.html
   https://www.suse.com/security/cve/CVE-2022-28463.html
   https://bugzilla.suse.com/1199350
   https://bugzilla.suse.com/1202250

SUSE: 2022:2998-1 moderate: ImageMagick

September 2, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for ImageMagick fixes the following issues: - CVE-2022-2719: Fixed a reachable assertion that could lead to denial of service via a crafted file (bsc#1202250). - CVE-2022-28463: Fixed a buffer overflow that could be triggered by a crafted input file (bsc#1199350). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2998=1 - SUSE Linux Enterprise Module for Development Tools 15-SP4: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-2998=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2998=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): ImageMagick-7.1.0.9-150400.6.6.1 ImageMagick-config-7-SUSE-7.1.0.9-150400.6.6.1 ImageMagick-config-7-upstream-7.1.0.9-150400.6.6.1 ImageMagick-debuginfo-7.1.0.9-150400.6.6.1 ImageMagick-debugsource-7.1.0.9-150400.6.6.1 ImageMagick-devel-7.1.0.9-150400.6.6.1 ImageMagick-extra-7.1.0.9-150400.6.6.1 ImageMagick-extra-debuginfo-7.1.0.9-150400.6.6.1 libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.6.1 libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.6.1 libMagick++-devel-7.1.0.9-150400.6.6.1 libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.6.1 libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1 libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.6.1 libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1 perl-PerlMagick-7.1.0.9-150400.6.6.1 perl-PerlMagick-debuginfo-7.1.0.9-150400.6.6.1 - openSUSE Leap 15.4 (x86_64): ImageMagick-devel-32bit-7.1.0.9-150400.6.6.1 libMagick++-7_Q16HDRI5-32bit-7.1.0.9-150400.6.6.1 libMagick++-7_Q16HDRI5-32bit-debuginfo-7.1.0.9-150400.6.6.1 libMagick++-devel-32bit-7.1.0.9-150400.6.6.1 libMagickCore-7_Q16HDRI10-32bit-7.1.0.9-150400.6.6.1 libMagickCore-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.6.1 libMagickWand-7_Q16HDRI10-32bit-7.1.0.9-150400.6.6.1 libMagickWand-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.6.1 - openSUSE Leap 15.4 (noarch): ImageMagick-doc-7.1.0.9-150400.6.6.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64): ImageMagick-debuginfo-7.1.0.9-150400.6.6.1 ImageMagick-debugsource-7.1.0.9-150400.6.6.1 perl-PerlMagick-7.1.0.9-150400.6.6.1 perl-PerlMagick-debuginfo-7.1.0.9-150400.6.6.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64): ImageMagick-7.1.0.9-150400.6.6.1 ImageMagick-config-7-SUSE-7.1.0.9-150400.6.6.1 ImageMagick-config-7-upstream-7.1.0.9-150400.6.6.1 ImageMagick-debuginfo-7.1.0.9-150400.6.6.1 ImageMagick-debugsource-7.1.0.9-150400.6.6.1 ImageMagick-devel-7.1.0.9-150400.6.6.1 libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.6.1 libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.6.1 libMagick++-devel-7.1.0.9-150400.6.6.1 libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.6.1 libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1 libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.6.1 libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.6.1

References

#1199350 #1202250

Cross- CVE-2022-2719 CVE-2022-28463

CVSS scores:

CVE-2022-2719 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

CVE-2022-2719 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

CVE-2022-28463 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-28463 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Desktop Applications 15-SP4

SUSE Linux Enterprise Module for Development Tools 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-2719.html

https://www.suse.com/security/cve/CVE-2022-28463.html

https://bugzilla.suse.com/1199350

https://bugzilla.suse.com/1202250

Severity
Announcement ID: SUSE-SU-2022:2998-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.