SUSE: 2022:3016-1 important: libgda | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for libgda
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3016-1
Rating:             important
References:         #1189849 
Cross-References:   CVE-2021-39359
CVSS scores:
                    CVE-2021-39359 (NVD) : 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2021-39359 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE Linux Enterprise Desktop 12-SP5
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE Linux Enterprise Workstation Extension 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libgda fixes the following issues:

   - CVE-2021-39359: Enabled TLS certificate verification (bsc#1189849).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3016=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3016=1

   - SUSE Linux Enterprise Workstation Extension 12-SP5:

      zypper in -t patch SUSE-SLE-WE-12-SP5-2022-3016=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3016=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3016=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3016=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3016=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3016=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3016=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      libgda-5_0-4-5.2.4-9.3.1
      libgda-5_0-4-debuginfo-5.2.4-9.3.1
      libgda-5_0-mysql-5.2.4-9.3.1
      libgda-5_0-mysql-debuginfo-5.2.4-9.3.1
      libgda-5_0-postgres-5.2.4-9.3.1
      libgda-5_0-postgres-debuginfo-5.2.4-9.3.1
      libgda-5_0-sqlite-5.2.4-9.3.1
      libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      libgda-ui-5_0-4-5.2.4-9.3.1
      libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1

   - SUSE OpenStack Cloud 9 (x86_64):

      libgda-5_0-4-5.2.4-9.3.1
      libgda-5_0-4-debuginfo-5.2.4-9.3.1
      libgda-5_0-mysql-5.2.4-9.3.1
      libgda-5_0-mysql-debuginfo-5.2.4-9.3.1
      libgda-5_0-postgres-5.2.4-9.3.1
      libgda-5_0-postgres-debuginfo-5.2.4-9.3.1
      libgda-5_0-sqlite-5.2.4-9.3.1
      libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      libgda-ui-5_0-4-5.2.4-9.3.1
      libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1

   - SUSE Linux Enterprise Workstation Extension 12-SP5 (noarch):

      libgda-5_0-4-lang-5.2.4-9.3.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      libgda-5_0-devel-5.2.4-9.3.1
      libgda-5_0-devel-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      typelib-1_0-Gda-5_0-5.2.4-9.3.1
      typelib-1_0-Gdaui-5_0-5.2.4-9.3.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      libgda-5_0-4-5.2.4-9.3.1
      libgda-5_0-4-debuginfo-5.2.4-9.3.1
      libgda-5_0-mysql-5.2.4-9.3.1
      libgda-5_0-mysql-debuginfo-5.2.4-9.3.1
      libgda-5_0-postgres-5.2.4-9.3.1
      libgda-5_0-postgres-debuginfo-5.2.4-9.3.1
      libgda-5_0-sqlite-5.2.4-9.3.1
      libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      libgda-ui-5_0-4-5.2.4-9.3.1
      libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      libgda-5_0-4-5.2.4-9.3.1
      libgda-5_0-4-debuginfo-5.2.4-9.3.1
      libgda-5_0-mysql-5.2.4-9.3.1
      libgda-5_0-mysql-debuginfo-5.2.4-9.3.1
      libgda-5_0-postgres-5.2.4-9.3.1
      libgda-5_0-postgres-debuginfo-5.2.4-9.3.1
      libgda-5_0-sqlite-5.2.4-9.3.1
      libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      libgda-ui-5_0-4-5.2.4-9.3.1
      libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      libgda-5_0-4-5.2.4-9.3.1
      libgda-5_0-4-debuginfo-5.2.4-9.3.1
      libgda-5_0-mysql-5.2.4-9.3.1
      libgda-5_0-mysql-debuginfo-5.2.4-9.3.1
      libgda-5_0-postgres-5.2.4-9.3.1
      libgda-5_0-postgres-debuginfo-5.2.4-9.3.1
      libgda-5_0-sqlite-5.2.4-9.3.1
      libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      libgda-ui-5_0-4-5.2.4-9.3.1
      libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      libgda-5_0-4-5.2.4-9.3.1
      libgda-5_0-4-debuginfo-5.2.4-9.3.1
      libgda-5_0-mysql-5.2.4-9.3.1
      libgda-5_0-mysql-debuginfo-5.2.4-9.3.1
      libgda-5_0-postgres-5.2.4-9.3.1
      libgda-5_0-postgres-debuginfo-5.2.4-9.3.1
      libgda-5_0-sqlite-5.2.4-9.3.1
      libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      libgda-ui-5_0-4-5.2.4-9.3.1
      libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      libgda-5_0-4-5.2.4-9.3.1
      libgda-5_0-4-debuginfo-5.2.4-9.3.1
      libgda-5_0-mysql-5.2.4-9.3.1
      libgda-5_0-mysql-debuginfo-5.2.4-9.3.1
      libgda-5_0-postgres-5.2.4-9.3.1
      libgda-5_0-postgres-debuginfo-5.2.4-9.3.1
      libgda-5_0-sqlite-5.2.4-9.3.1
      libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1
      libgda-debugsource-5.2.4-9.3.1
      libgda-ui-5_0-4-5.2.4-9.3.1
      libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-39359.html
   https://bugzilla.suse.com/1189849

SUSE: 2022:3016-1 important: libgda

September 5, 2022
An update that fixes one vulnerability is now available

Summary

This update for libgda fixes the following issues: - CVE-2021-39359: Enabled TLS certificate verification (bsc#1189849). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3016=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3016=1 - SUSE Linux Enterprise Workstation Extension 12-SP5: zypper in -t patch SUSE-SLE-WE-12-SP5-2022-3016=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3016=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3016=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3016=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3016=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3016=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3016=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): libgda-5_0-4-5.2.4-9.3.1 libgda-5_0-4-debuginfo-5.2.4-9.3.1 libgda-5_0-mysql-5.2.4-9.3.1 libgda-5_0-mysql-debuginfo-5.2.4-9.3.1 libgda-5_0-postgres-5.2.4-9.3.1 libgda-5_0-postgres-debuginfo-5.2.4-9.3.1 libgda-5_0-sqlite-5.2.4-9.3.1 libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 libgda-ui-5_0-4-5.2.4-9.3.1 libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1 - SUSE OpenStack Cloud 9 (x86_64): libgda-5_0-4-5.2.4-9.3.1 libgda-5_0-4-debuginfo-5.2.4-9.3.1 libgda-5_0-mysql-5.2.4-9.3.1 libgda-5_0-mysql-debuginfo-5.2.4-9.3.1 libgda-5_0-postgres-5.2.4-9.3.1 libgda-5_0-postgres-debuginfo-5.2.4-9.3.1 libgda-5_0-sqlite-5.2.4-9.3.1 libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 libgda-ui-5_0-4-5.2.4-9.3.1 libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1 - SUSE Linux Enterprise Workstation Extension 12-SP5 (noarch): libgda-5_0-4-lang-5.2.4-9.3.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): libgda-5_0-devel-5.2.4-9.3.1 libgda-5_0-devel-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 typelib-1_0-Gda-5_0-5.2.4-9.3.1 typelib-1_0-Gdaui-5_0-5.2.4-9.3.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): libgda-5_0-4-5.2.4-9.3.1 libgda-5_0-4-debuginfo-5.2.4-9.3.1 libgda-5_0-mysql-5.2.4-9.3.1 libgda-5_0-mysql-debuginfo-5.2.4-9.3.1 libgda-5_0-postgres-5.2.4-9.3.1 libgda-5_0-postgres-debuginfo-5.2.4-9.3.1 libgda-5_0-sqlite-5.2.4-9.3.1 libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 libgda-ui-5_0-4-5.2.4-9.3.1 libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): libgda-5_0-4-5.2.4-9.3.1 libgda-5_0-4-debuginfo-5.2.4-9.3.1 libgda-5_0-mysql-5.2.4-9.3.1 libgda-5_0-mysql-debuginfo-5.2.4-9.3.1 libgda-5_0-postgres-5.2.4-9.3.1 libgda-5_0-postgres-debuginfo-5.2.4-9.3.1 libgda-5_0-sqlite-5.2.4-9.3.1 libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 libgda-ui-5_0-4-5.2.4-9.3.1 libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): libgda-5_0-4-5.2.4-9.3.1 libgda-5_0-4-debuginfo-5.2.4-9.3.1 libgda-5_0-mysql-5.2.4-9.3.1 libgda-5_0-mysql-debuginfo-5.2.4-9.3.1 libgda-5_0-postgres-5.2.4-9.3.1 libgda-5_0-postgres-debuginfo-5.2.4-9.3.1 libgda-5_0-sqlite-5.2.4-9.3.1 libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 libgda-ui-5_0-4-5.2.4-9.3.1 libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): libgda-5_0-4-5.2.4-9.3.1 libgda-5_0-4-debuginfo-5.2.4-9.3.1 libgda-5_0-mysql-5.2.4-9.3.1 libgda-5_0-mysql-debuginfo-5.2.4-9.3.1 libgda-5_0-postgres-5.2.4-9.3.1 libgda-5_0-postgres-debuginfo-5.2.4-9.3.1 libgda-5_0-sqlite-5.2.4-9.3.1 libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 libgda-ui-5_0-4-5.2.4-9.3.1 libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1 - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): libgda-5_0-4-5.2.4-9.3.1 libgda-5_0-4-debuginfo-5.2.4-9.3.1 libgda-5_0-mysql-5.2.4-9.3.1 libgda-5_0-mysql-debuginfo-5.2.4-9.3.1 libgda-5_0-postgres-5.2.4-9.3.1 libgda-5_0-postgres-debuginfo-5.2.4-9.3.1 libgda-5_0-sqlite-5.2.4-9.3.1 libgda-5_0-sqlite-debuginfo-5.2.4-9.3.1 libgda-debugsource-5.2.4-9.3.1 libgda-ui-5_0-4-5.2.4-9.3.1 libgda-ui-5_0-4-debuginfo-5.2.4-9.3.1

References

#1189849

Cross- CVE-2021-39359

CVSS scores:

CVE-2021-39359 (NVD) : 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

CVE-2021-39359 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

SUSE Linux Enterprise Desktop 12-SP5

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE Linux Enterprise Workstation Extension 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2021-39359.html

https://bugzilla.suse.com/1189849

Severity
Announcement ID: SUSE-SU-2022:3016-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.