SUSE: 2022:3094-1 important: libostree | LinuxSecurity.com

   SUSE Security Update: Security update for libostree
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3094-1
Rating:             important
References:         #1201770 
Cross-References:   CVE-2014-9862
CVSS scores:
                    CVE-2014-9862 (NVD) : 7.8 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2014-9862 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Basesystem 15-SP4
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libostree fixes the following issues:

   - CVE-2014-9862: Fixed a memory corruption issue that could be triggered
     when diffing binary files (bsc#1201770).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-3094=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-3094=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-3094=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      libostree-1-1-2021.6-150400.3.3.1
      libostree-1-1-debuginfo-2021.6-150400.3.3.1
      libostree-2021.6-150400.3.3.1
      libostree-debuginfo-2021.6-150400.3.3.1
      libostree-debugsource-2021.6-150400.3.3.1
      libostree-devel-2021.6-150400.3.3.1
      typelib-1_0-OSTree-1_0-2021.6-150400.3.3.1

   - openSUSE Leap 15.4 (aarch64 ppc64le x86_64):

      libostree-grub2-2021.6-150400.3.3.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      libostree-2021.6-150400.3.3.1
      libostree-debuginfo-2021.6-150400.3.3.1
      libostree-debugsource-2021.6-150400.3.3.1
      libostree-devel-2021.6-150400.3.3.1
      typelib-1_0-OSTree-1_0-2021.6-150400.3.3.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

      libostree-1-1-2021.6-150400.3.3.1
      libostree-1-1-debuginfo-2021.6-150400.3.3.1
      libostree-debuginfo-2021.6-150400.3.3.1
      libostree-debugsource-2021.6-150400.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2014-9862.html
   https://bugzilla.suse.com/1201770

SUSE: 2022:3094-1 important: libostree

September 6, 2022
An update that fixes one vulnerability is now available

Summary

This update for libostree fixes the following issues: - CVE-2014-9862: Fixed a memory corruption issue that could be triggered when diffing binary files (bsc#1201770). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-3094=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-3094=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-3094=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): libostree-1-1-2021.6-150400.3.3.1 libostree-1-1-debuginfo-2021.6-150400.3.3.1 libostree-2021.6-150400.3.3.1 libostree-debuginfo-2021.6-150400.3.3.1 libostree-debugsource-2021.6-150400.3.3.1 libostree-devel-2021.6-150400.3.3.1 typelib-1_0-OSTree-1_0-2021.6-150400.3.3.1 - openSUSE Leap 15.4 (aarch64 ppc64le x86_64): libostree-grub2-2021.6-150400.3.3.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64): libostree-2021.6-150400.3.3.1 libostree-debuginfo-2021.6-150400.3.3.1 libostree-debugsource-2021.6-150400.3.3.1 libostree-devel-2021.6-150400.3.3.1 typelib-1_0-OSTree-1_0-2021.6-150400.3.3.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64): libostree-1-1-2021.6-150400.3.3.1 libostree-1-1-debuginfo-2021.6-150400.3.3.1 libostree-debuginfo-2021.6-150400.3.3.1 libostree-debugsource-2021.6-150400.3.3.1

References

#1201770

Cross- CVE-2014-9862

CVSS scores:

CVE-2014-9862 (NVD) : 7.8 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2014-9862 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Basesystem 15-SP4

SUSE Linux Enterprise Module for Desktop Applications 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2014-9862.html

https://bugzilla.suse.com/1201770

Severity
Announcement ID: SUSE-SU-2022:3094-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.