SUSE: 2022:3107-1 moderate: gimp | LinuxSecurity.com

   SUSE Security Update: Security update for gimp
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3107-1
Rating:             moderate
References:         #1201192 
Cross-References:   CVE-2022-32990
CVSS scores:
                    CVE-2022-32990 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2022-32990 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Storage 7.1
                    SUSE Linux Enterprise Workstation Extension 15-SP3
                    SUSE Manager Proxy 4.2
                    SUSE Manager Retail Branch Server 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for gimp fixes the following issues:

   - CVE-2022-32990: Fixed an unhandled exception which may lead to denial
     of service (bsc#1201192).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-3107=1

   - SUSE Linux Enterprise Workstation Extension 15-SP3:

      zypper in -t patch SUSE-SLE-Product-WE-15-SP3-2022-3107=1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-3107=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      gimp-2.10.12-150300.9.6.1
      gimp-debuginfo-2.10.12-150300.9.6.1
      gimp-debugsource-2.10.12-150300.9.6.1
      gimp-devel-2.10.12-150300.9.6.1
      gimp-devel-debuginfo-2.10.12-150300.9.6.1
      gimp-plugin-aa-2.10.12-150300.9.6.1
      gimp-plugin-aa-debuginfo-2.10.12-150300.9.6.1
      libgimp-2_0-0-2.10.12-150300.9.6.1
      libgimp-2_0-0-debuginfo-2.10.12-150300.9.6.1
      libgimpui-2_0-0-2.10.12-150300.9.6.1
      libgimpui-2_0-0-debuginfo-2.10.12-150300.9.6.1

   - openSUSE Leap 15.3 (x86_64):

      libgimp-2_0-0-32bit-2.10.12-150300.9.6.1
      libgimp-2_0-0-32bit-debuginfo-2.10.12-150300.9.6.1
      libgimpui-2_0-0-32bit-2.10.12-150300.9.6.1
      libgimpui-2_0-0-32bit-debuginfo-2.10.12-150300.9.6.1

   - openSUSE Leap 15.3 (noarch):

      gimp-lang-2.10.12-150300.9.6.1

   - SUSE Linux Enterprise Workstation Extension 15-SP3 (noarch):

      gimp-lang-2.10.12-150300.9.6.1

   - SUSE Linux Enterprise Workstation Extension 15-SP3 (x86_64):

      gimp-2.10.12-150300.9.6.1
      gimp-debuginfo-2.10.12-150300.9.6.1
      gimp-debugsource-2.10.12-150300.9.6.1
      gimp-devel-2.10.12-150300.9.6.1
      gimp-devel-debuginfo-2.10.12-150300.9.6.1
      libgimp-2_0-0-2.10.12-150300.9.6.1
      libgimp-2_0-0-debuginfo-2.10.12-150300.9.6.1
      libgimpui-2_0-0-2.10.12-150300.9.6.1
      libgimpui-2_0-0-debuginfo-2.10.12-150300.9.6.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (aarch64 ppc64le s390x):

      gimp-debuginfo-2.10.12-150300.9.6.1
      gimp-debugsource-2.10.12-150300.9.6.1
      libgimp-2_0-0-2.10.12-150300.9.6.1
      libgimp-2_0-0-debuginfo-2.10.12-150300.9.6.1
      libgimpui-2_0-0-2.10.12-150300.9.6.1
      libgimpui-2_0-0-debuginfo-2.10.12-150300.9.6.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (aarch64):

      gimp-2.10.12-150300.9.6.1
      gimp-devel-2.10.12-150300.9.6.1
      gimp-devel-debuginfo-2.10.12-150300.9.6.1
      gimp-plugin-aa-2.10.12-150300.9.6.1
      gimp-plugin-aa-debuginfo-2.10.12-150300.9.6.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (noarch):

      gimp-lang-2.10.12-150300.9.6.1


References:

   https://www.suse.com/security/cve/CVE-2022-32990.html
   https://bugzilla.suse.com/1201192

SUSE: 2022:3107-1 moderate: gimp

September 6, 2022
An update that fixes one vulnerability is now available

Summary

This update for gimp fixes the following issues: - CVE-2022-32990: Fixed an unhandled exception which may lead to denial of service (bsc#1201192). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-3107=1 - SUSE Linux Enterprise Workstation Extension 15-SP3: zypper in -t patch SUSE-SLE-Product-WE-15-SP3-2022-3107=1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3: zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-3107=1 Package List: - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): gimp-2.10.12-150300.9.6.1 gimp-debuginfo-2.10.12-150300.9.6.1 gimp-debugsource-2.10.12-150300.9.6.1 gimp-devel-2.10.12-150300.9.6.1 gimp-devel-debuginfo-2.10.12-150300.9.6.1 gimp-plugin-aa-2.10.12-150300.9.6.1 gimp-plugin-aa-debuginfo-2.10.12-150300.9.6.1 libgimp-2_0-0-2.10.12-150300.9.6.1 libgimp-2_0-0-debuginfo-2.10.12-150300.9.6.1 libgimpui-2_0-0-2.10.12-150300.9.6.1 libgimpui-2_0-0-debuginfo-2.10.12-150300.9.6.1 - openSUSE Leap 15.3 (x86_64): libgimp-2_0-0-32bit-2.10.12-150300.9.6.1 libgimp-2_0-0-32bit-debuginfo-2.10.12-150300.9.6.1 libgimpui-2_0-0-32bit-2.10.12-150300.9.6.1 libgimpui-2_0-0-32bit-debuginfo-2.10.12-150300.9.6.1 - openSUSE Leap 15.3 (noarch): gimp-lang-2.10.12-150300.9.6.1 - SUSE Linux Enterprise Workstation Extension 15-SP3 (noarch): gimp-lang-2.10.12-150300.9.6.1 - SUSE Linux Enterprise Workstation Extension 15-SP3 (x86_64): gimp-2.10.12-150300.9.6.1 gimp-debuginfo-2.10.12-150300.9.6.1 gimp-debugsource-2.10.12-150300.9.6.1 gimp-devel-2.10.12-150300.9.6.1 gimp-devel-debuginfo-2.10.12-150300.9.6.1 libgimp-2_0-0-2.10.12-150300.9.6.1 libgimp-2_0-0-debuginfo-2.10.12-150300.9.6.1 libgimpui-2_0-0-2.10.12-150300.9.6.1 libgimpui-2_0-0-debuginfo-2.10.12-150300.9.6.1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (aarch64 ppc64le s390x): gimp-debuginfo-2.10.12-150300.9.6.1 gimp-debugsource-2.10.12-150300.9.6.1 libgimp-2_0-0-2.10.12-150300.9.6.1 libgimp-2_0-0-debuginfo-2.10.12-150300.9.6.1 libgimpui-2_0-0-2.10.12-150300.9.6.1 libgimpui-2_0-0-debuginfo-2.10.12-150300.9.6.1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (aarch64): gimp-2.10.12-150300.9.6.1 gimp-devel-2.10.12-150300.9.6.1 gimp-devel-debuginfo-2.10.12-150300.9.6.1 gimp-plugin-aa-2.10.12-150300.9.6.1 gimp-plugin-aa-debuginfo-2.10.12-150300.9.6.1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (noarch): gimp-lang-2.10.12-150300.9.6.1

References

#1201192

Cross- CVE-2022-32990

CVSS scores:

CVE-2022-32990 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

CVE-2022-32990 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Storage 7.1

SUSE Linux Enterprise Workstation Extension 15-SP3

SUSE Manager Proxy 4.2

SUSE Manager Retail Branch Server 4.2

SUSE Manager Server 4.2

openSUSE Leap 15.3

https://www.suse.com/security/cve/CVE-2022-32990.html

https://bugzilla.suse.com/1201192

Severity
Announcement ID: SUSE-SU-2022:3107-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.