SUSE: 2022:3718-1 important: bluez | LinuxSecurity.com

   SUSE Security Update: Security update for bluez
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3718-1
Rating:             important
References:         #1013885 #1193237 
Cross-References:   CVE-2016-9803 CVE-2019-8921
CVSS scores:
                    CVE-2016-9803 (NVD) : 5.3 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2016-9803 (SUSE): 2.5 CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2019-8921 (NVD) : 6.5 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2019-8921 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE Linux Enterprise Desktop 12-SP5
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE Linux Enterprise Workstation Extension 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for bluez fixes the following issues:

     - CVE-2019-8921: Fixed heap-based buffer overflow via crafted request
       (bsc#1193237).
     - CVE-2016-9803: Fixed memory leak (bsc#1013885).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3718=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3718=1

   - SUSE Linux Enterprise Workstation Extension 12-SP5:

      zypper in -t patch SUSE-SLE-WE-12-SP5-2022-3718=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3718=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3718=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3718=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3718=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3718=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3718=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      bluez-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      libbluetooth3-5.13-5.31.1
      libbluetooth3-debuginfo-5.13-5.31.1

   - SUSE OpenStack Cloud 9 (x86_64):

      bluez-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      libbluetooth3-5.13-5.31.1
      libbluetooth3-debuginfo-5.13-5.31.1

   - SUSE Linux Enterprise Workstation Extension 12-SP5 (x86_64):

      bluez-cups-5.13-5.31.1
      bluez-cups-debuginfo-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      bluez-devel-5.13-5.31.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      bluez-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      libbluetooth3-5.13-5.31.1
      libbluetooth3-debuginfo-5.13-5.31.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      bluez-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      libbluetooth3-5.13-5.31.1
      libbluetooth3-debuginfo-5.13-5.31.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      bluez-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      libbluetooth3-5.13-5.31.1
      libbluetooth3-debuginfo-5.13-5.31.1

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      bluez-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      libbluetooth3-5.13-5.31.1
      libbluetooth3-debuginfo-5.13-5.31.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      bluez-5.13-5.31.1
      bluez-debuginfo-5.13-5.31.1
      bluez-debugsource-5.13-5.31.1
      libbluetooth3-5.13-5.31.1
      libbluetooth3-debuginfo-5.13-5.31.1


References:

   https://www.suse.com/security/cve/CVE-2016-9803.html
   https://www.suse.com/security/cve/CVE-2019-8921.html
   https://bugzilla.suse.com/1013885
   https://bugzilla.suse.com/1193237

SUSE: 2022:3718-1 important: bluez

October 25, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for bluez fixes the following issues: - CVE-2019-8921: Fixed heap-based buffer overflow via crafted request (bsc#1193237). - CVE-2016-9803: Fixed memory leak (bsc#1013885). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3718=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3718=1 - SUSE Linux Enterprise Workstation Extension 12-SP5: zypper in -t patch SUSE-SLE-WE-12-SP5-2022-3718=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3718=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3718=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3718=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3718=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3718=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3718=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): bluez-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 libbluetooth3-5.13-5.31.1 libbluetooth3-debuginfo-5.13-5.31.1 - SUSE OpenStack Cloud 9 (x86_64): bluez-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 libbluetooth3-5.13-5.31.1 libbluetooth3-debuginfo-5.13-5.31.1 - SUSE Linux Enterprise Workstation Extension 12-SP5 (x86_64): bluez-cups-5.13-5.31.1 bluez-cups-debuginfo-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 bluez-devel-5.13-5.31.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): bluez-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 libbluetooth3-5.13-5.31.1 libbluetooth3-debuginfo-5.13-5.31.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): bluez-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 libbluetooth3-5.13-5.31.1 libbluetooth3-debuginfo-5.13-5.31.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): bluez-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 libbluetooth3-5.13-5.31.1 libbluetooth3-debuginfo-5.13-5.31.1 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): bluez-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 libbluetooth3-5.13-5.31.1 libbluetooth3-debuginfo-5.13-5.31.1 - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): bluez-5.13-5.31.1 bluez-debuginfo-5.13-5.31.1 bluez-debugsource-5.13-5.31.1 libbluetooth3-5.13-5.31.1 libbluetooth3-debuginfo-5.13-5.31.1

References

#1013885 #1193237

Cross- CVE-2016-9803 CVE-2019-8921

CVSS scores:

CVE-2016-9803 (NVD) : 5.3 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

CVE-2016-9803 (SUSE): 2.5 CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L

CVE-2019-8921 (NVD) : 6.5 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

CVE-2019-8921 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

SUSE Linux Enterprise Desktop 12-SP5

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE Linux Enterprise Workstation Extension 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2016-9803.html

https://www.suse.com/security/cve/CVE-2019-8921.html

https://bugzilla.suse.com/1013885

https://bugzilla.suse.com/1193237

Severity
Announcement ID: SUSE-SU-2022:3718-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.