SUSE: 2022:4398-1 moderate: go1.18 | LinuxSecurity.com

   SUSE Security Update: Security update for go1.18
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4398-1
Rating:             moderate
References:         #1193742 #1206134 #1206135 
Cross-References:   CVE-2022-41717 CVE-2022-41720
Affected Products:
                    SUSE Enterprise Storage 7.1
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Development Tools 15-SP3
                    SUSE Linux Enterprise Module for Development Tools 15-SP4
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.2
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.2
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.2
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for go1.18 fixes the following issues:

   Update to version 1.18.9, includes the following security fixes:

   - CVE-2022-41717: net/https: limit canonical header cache by bytes, not
     entries (bsc#1206135)
   - CVE-2022-41720: os, net/https: avoid escapes from os.DirFS and http.Dir
     on Windows (bsc#1206134)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-4398=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-4398=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-4398=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-4398=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.9-150000.1.40.1
      go1.18-doc-1.18.9-150000.1.40.1

   - openSUSE Leap 15.4 (aarch64 x86_64):

      go1.18-race-1.18.9-150000.1.40.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.9-150000.1.40.1
      go1.18-doc-1.18.9-150000.1.40.1

   - openSUSE Leap 15.3 (aarch64 x86_64):

      go1.18-race-1.18.9-150000.1.40.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.9-150000.1.40.1
      go1.18-doc-1.18.9-150000.1.40.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 x86_64):

      go1.18-race-1.18.9-150000.1.40.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.9-150000.1.40.1
      go1.18-doc-1.18.9-150000.1.40.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 x86_64):

      go1.18-race-1.18.9-150000.1.40.1


References:

   https://www.suse.com/security/cve/CVE-2022-41717.html
   https://www.suse.com/security/cve/CVE-2022-41720.html
   https://bugzilla.suse.com/1193742
   https://bugzilla.suse.com/1206134
   https://bugzilla.suse.com/1206135

SUSE: 2022:4398-1 moderate: go1.18

December 9, 2022
An update that solves two vulnerabilities and has one errata is now available

Summary

This update for go1.18 fixes the following issues: Update to version 1.18.9, includes the following security fixes: - CVE-2022-41717: net/https: limit canonical header cache by bytes, not entries (bsc#1206135) - CVE-2022-41720: os, net/https: avoid escapes from os.DirFS and http.Dir on Windows (bsc#1206134) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-4398=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-4398=1 - SUSE Linux Enterprise Module for Development Tools 15-SP4: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-4398=1 - SUSE Linux Enterprise Module for Development Tools 15-SP3: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-4398=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): go1.18-1.18.9-150000.1.40.1 go1.18-doc-1.18.9-150000.1.40.1 - openSUSE Leap 15.4 (aarch64 x86_64): go1.18-race-1.18.9-150000.1.40.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): go1.18-1.18.9-150000.1.40.1 go1.18-doc-1.18.9-150000.1.40.1 - openSUSE Leap 15.3 (aarch64 x86_64): go1.18-race-1.18.9-150000.1.40.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64): go1.18-1.18.9-150000.1.40.1 go1.18-doc-1.18.9-150000.1.40.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 x86_64): go1.18-race-1.18.9-150000.1.40.1 - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64): go1.18-1.18.9-150000.1.40.1 go1.18-doc-1.18.9-150000.1.40.1 - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 x86_64): go1.18-race-1.18.9-150000.1.40.1

References

#1193742 #1206134 #1206135

Cross- CVE-2022-41717 CVE-2022-41720

Affected Products:

SUSE Enterprise Storage 7.1

SUSE Linux Enterprise Desktop 15-SP3

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Development Tools 15-SP3

SUSE Linux Enterprise Module for Development Tools 15-SP4

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.2

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.2

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.2

SUSE Manager Server 4.3

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-41717.html

https://www.suse.com/security/cve/CVE-2022-41720.html

https://bugzilla.suse.com/1193742

https://bugzilla.suse.com/1206134

https://bugzilla.suse.com/1206135

Severity
Announcement ID: SUSE-SU-2022:4398-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.