SUSE: 2022:4598-1 moderate: curl | LinuxSecurity.com

   SUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4598-1
Rating:             moderate
References:         #1206309 
Cross-References:   CVE-2022-43552
CVSS scores:
                    CVE-2022-43552 (SUSE): 5.6 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Affected Products:
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for curl fixes the following issues:

   - CVE-2022-43552: HTTP Proxy deny use-after-free (bsc#1206309).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4598=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4598=1



Package List:

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      curl-debuginfo-7.60.0-11.52.1
      curl-debugsource-7.60.0-11.52.1
      libcurl-devel-7.60.0-11.52.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      curl-7.60.0-11.52.1
      curl-debuginfo-7.60.0-11.52.1
      curl-debugsource-7.60.0-11.52.1
      libcurl4-7.60.0-11.52.1
      libcurl4-debuginfo-7.60.0-11.52.1

   - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64):

      libcurl4-32bit-7.60.0-11.52.1
      libcurl4-debuginfo-32bit-7.60.0-11.52.1


References:

   https://www.suse.com/security/cve/CVE-2022-43552.html
   https://bugzilla.suse.com/1206309

SUSE: 2022:4598-1 moderate: curl

December 21, 2022
An update that fixes one vulnerability is now available

Summary

This update for curl fixes the following issues: - CVE-2022-43552: HTTP Proxy deny use-after-free (bsc#1206309). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4598=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4598=1 Package List: - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): curl-debuginfo-7.60.0-11.52.1 curl-debugsource-7.60.0-11.52.1 libcurl-devel-7.60.0-11.52.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): curl-7.60.0-11.52.1 curl-debuginfo-7.60.0-11.52.1 curl-debugsource-7.60.0-11.52.1 libcurl4-7.60.0-11.52.1 libcurl4-debuginfo-7.60.0-11.52.1 - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64): libcurl4-32bit-7.60.0-11.52.1 libcurl4-debuginfo-32bit-7.60.0-11.52.1

References

#1206309

Cross- CVE-2022-43552

CVSS scores:

CVE-2022-43552 (SUSE): 5.6 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Affected Products:

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

https://www.suse.com/security/cve/CVE-2022-43552.html

https://bugzilla.suse.com/1206309

Severity
Announcement ID: SUSE-SU-2022:4598-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.