SUSE: 2022:4594-1 moderate: supportutils | LinuxSecurity.com

   SUSE Security Update: Security update for supportutils
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4594-1
Rating:             moderate
References:         #1184689 #1188086 #1192252 #1192648 #1197428 
                    #1200330 #1202269 #1202337 #1202417 #1203818 
                    
Affected Products:
                    SUSE CaaS Platform 4.0
                    SUSE Enterprise Storage 6
                    SUSE Enterprise Storage 7
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-SP2-BCL
                    SUSE Linux Enterprise Server 15-SP2-LTSS
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server for SAP 15-SP1
                    SUSE Linux Enterprise Server for SAP 15-SP2
                    SUSE Manager Proxy 4.1
                    SUSE Manager Retail Branch Server 4.1
                    SUSE Manager Server 4.1
______________________________________________________________________________

   An update that contains security fixes can now be installed.

Description:

   This update for supportutils fixes the following issues:

   Security issues fixed:

   - Passwords correctly removed from email.txt, updates.txt and fs-iscsi.txt
     (bsc#1203818)

   Bug fixes:

   - Added lifecycle information
   - Fixed KVM virtualization detection on bare metal (bsc#1184689)
   - Added logging using journalctl (bsc#1200330)
   - Get current sar data before collecting files (bsc#1192648)
   - Collects everything in /etc/multipath/ (bsc#1192252)
   - Collects power management information in hardware.txt (bsc#1197428)
   - Checks for suseconnect-ng or SUSEConnect packages (bsc#1202337)
   - Fixed conf_files and conf_text_files so y2log is gathered (bsc#1202269)
   - Update to nvme_info and block_info (bsc#1202417)
   - Added includedir directories from /etc/sudoers (bsc#1188086)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Manager Server 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-4594=1

   - SUSE Manager Retail Branch Server 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-4594=1

   - SUSE Manager Proxy 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-4594=1

   - SUSE Linux Enterprise Server for SAP 15-SP2:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2022-4594=1

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-4594=1

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-4594=1

   - SUSE Linux Enterprise Server 15-SP2-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-4594=1

   - SUSE Linux Enterprise Server 15-SP2-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-BCL-2022-4594=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-4594=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-4594=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-4594=1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-4594=1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-4594=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-4594=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-4594=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4594=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4594=1

   - SUSE Enterprise Storage 7:

      zypper in -t patch SUSE-Storage-7-2022-4594=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2022-4594=1

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE Manager Server 4.1 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Manager Retail Branch Server 4.1 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Manager Proxy 4.1 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server for SAP 15-SP2 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server for SAP 15-SP1 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server 15-SP2-LTSS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server 15-SP2-BCL (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Enterprise Storage 7 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE Enterprise Storage 6 (noarch):

      supportutils-3.1.21-150000.5.44.1

   - SUSE CaaS Platform 4.0 (noarch):

      supportutils-3.1.21-150000.5.44.1


References:

   https://bugzilla.suse.com/1184689
   https://bugzilla.suse.com/1188086
   https://bugzilla.suse.com/1192252
   https://bugzilla.suse.com/1192648
   https://bugzilla.suse.com/1197428
   https://bugzilla.suse.com/1200330
   https://bugzilla.suse.com/1202269
   https://bugzilla.suse.com/1202337
   https://bugzilla.suse.com/1202417
   https://bugzilla.suse.com/1203818

SUSE: 2022:4594-1 moderate: supportutils

December 20, 2022
An update that contains security fixes can now be installed

Summary

This update for supportutils fixes the following issues: Security issues fixed: - Passwords correctly removed from email.txt, updates.txt and fs-iscsi.txt (bsc#1203818) Bug fixes: - Added lifecycle information - Fixed KVM virtualization detection on bare metal (bsc#1184689) - Added logging using journalctl (bsc#1200330) - Get current sar data before collecting files (bsc#1192648) - Collects everything in /etc/multipath/ (bsc#1192252) - Collects power management information in hardware.txt (bsc#1197428) - Checks for suseconnect-ng or SUSEConnect packages (bsc#1202337) - Fixed conf_files and conf_text_files so y2log is gathered (bsc#1202269) - Update to nvme_info and block_info (bsc#1202417) - Added includedir directories from /etc/sudoers (bsc#1188086) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Manager Server 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-4594=1 - SUSE Manager Retail Branch Server 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-4594=1 - SUSE Manager Proxy 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-4594=1 - SUSE Linux Enterprise Server for SAP 15-SP2: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2022-4594=1 - SUSE Linux Enterprise Server for SAP 15-SP1: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-4594=1 - SUSE Linux Enterprise Server for SAP 15: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-4594=1 - SUSE Linux Enterprise Server 15-SP2-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-4594=1 - SUSE Linux Enterprise Server 15-SP2-BCL: zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-BCL-2022-4594=1 - SUSE Linux Enterprise Server 15-SP1-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-4594=1 - SUSE Linux Enterprise Server 15-SP1-BCL: zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-4594=1 - SUSE Linux Enterprise Server 15-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-2022-4594=1 - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-4594=1 - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-4594=1 - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-4594=1 - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-4594=1 - SUSE Linux Enterprise High Performance Computing 15-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4594=1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4594=1 - SUSE Enterprise Storage 7: zypper in -t patch SUSE-Storage-7-2022-4594=1 - SUSE Enterprise Storage 6: zypper in -t patch SUSE-Storage-6-2022-4594=1 - SUSE CaaS Platform 4.0: To install this update, use the SUSE CaaS Platform 'skuba' tool. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way. Package List: - SUSE Manager Server 4.1 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Manager Retail Branch Server 4.1 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Manager Proxy 4.1 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server for SAP 15-SP2 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server for SAP 15-SP1 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server for SAP 15 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server 15-SP2-LTSS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server 15-SP2-BCL (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server 15-SP1-LTSS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server 15-SP1-BCL (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise Server 15-LTSS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Enterprise Storage 7 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE Enterprise Storage 6 (noarch): supportutils-3.1.21-150000.5.44.1 - SUSE CaaS Platform 4.0 (noarch): supportutils-3.1.21-150000.5.44.1

References

#1184689 #1188086 #1192252 #1192648 #1197428

#1200330 #1202269 #1202337 #1202417 #1203818

Affected Products:

SUSE CaaS Platform 4.0

SUSE Enterprise Storage 6

SUSE Enterprise Storage 7

SUSE Linux Enterprise High Performance Computing 15-ESPOS

SUSE Linux Enterprise High Performance Computing 15-LTSS

SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS

SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS

SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS

SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS

SUSE Linux Enterprise Server 15-LTSS

SUSE Linux Enterprise Server 15-SP1-BCL

SUSE Linux Enterprise Server 15-SP1-LTSS

SUSE Linux Enterprise Server 15-SP2-BCL

SUSE Linux Enterprise Server 15-SP2-LTSS

SUSE Linux Enterprise Server for SAP 15

SUSE Linux Enterprise Server for SAP 15-SP1

SUSE Linux Enterprise Server for SAP 15-SP2

SUSE Manager Proxy 4.1

SUSE Manager Retail Branch Server 4.1

SUSE Manager Server 4.1

https://bugzilla.suse.com/1184689

https://bugzilla.suse.com/1188086

https://bugzilla.suse.com/1192252

https://bugzilla.suse.com/1192648

https://bugzilla.suse.com/1197428

https://bugzilla.suse.com/1200330

https://bugzilla.suse.com/1202269

https://bugzilla.suse.com/1202337

https://bugzilla.suse.com/1202417

https://bugzilla.suse.com/1203818

Severity
Announcement ID: SUSE-SU-2022:4594-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.