SUSE: 2023:1610-1 suse/sles/15.5/virt-exportserver Security Update ...
SUSE Container Update Advisory: suse/sles/15.5/virt-exportserver
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2023:1610-1
Container Tags        : suse/sles/15.5/virt-exportserver:0.58.0 , suse/sles/15.5/virt-exportserver:0.58.0-150500.6.3 , suse/sles/15.5/virt-exportserver:0.58.0.1.264
Container Release     : 1.264
Severity              : important
Type                  : security
References            : 1210434 1211230 1211231 1211232 1211233 CVE-2023-28319 CVE-2023-28320
                        CVE-2023-28321 CVE-2023-28322 CVE-2023-29491 
-----------------------------------------------------------------

The container suse/sles/15.5/virt-exportserver was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2023:2111-1
Released:    Fri May  5 14:34:00 2023
Summary:     Security update for ncurses
Type:        security
Severity:    moderate
References:  1210434,CVE-2023-29491
This update for ncurses fixes the following issues:

- CVE-2023-29491: Fixed memory corruption issues when processing malformed terminfo data (bsc#1210434).

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2023:2224-1
Released:    Wed May 17 09:53:54 2023
Summary:     Security update for curl
Type:        security
Severity:    important
References:  1211230,1211231,1211232,1211233,CVE-2023-28319,CVE-2023-28320,CVE-2023-28321,CVE-2023-28322
This update for curl adds the following feature:

Update to version 8.0.1 (jsc#PED-2580)

- CVE-2023-28319: use-after-free in SSH sha256 fingerprint check (bsc#1211230).
- CVE-2023-28320: siglongjmp race condition (bsc#1211231).
- CVE-2023-28321: IDN wildcard matching (bsc#1211232).
- CVE-2023-28322: POST-after-PUT confusion (bsc#1211233).


The following package changes have been done:

- libz1-1.2.13-150500.2.3 updated
- libuuid1-2.37.4-150500.7.16 updated
- libsmartcols1-2.37.4-150500.7.16 updated
- libblkid1-2.37.4-150500.7.16 updated
- libgcrypt20-1.9.4-150500.10.19 updated
- libgcrypt20-hmac-1.9.4-150500.10.19 updated
- libfdisk1-2.37.4-150500.7.16 updated
- libncurses6-6.1-150000.5.15.1 updated
- terminfo-base-6.1-150000.5.15.1 updated
- ncurses-utils-6.1-150000.5.15.1 updated
- libopenssl1_1-1.1.1l-150500.15.4 updated
- libopenssl1_1-hmac-1.1.1l-150500.15.4 updated
- libmount1-2.37.4-150500.7.16 updated
- libcurl4-8.0.1-150400.5.23.1 updated
- sles-release-15.5-150500.43.4 updated
- util-linux-2.37.4-150500.7.16 updated
- kubevirt-virt-exportserver-0.58.0-150500.6.3 updated
- container:sles15-image-15.0.0-34.37 updated

SUSE: 2023:1610-1 suse/sles/15.5/virt-exportserver Security Update

May 24, 2023
The container suse/sles/15.5/virt-exportserver was updated

Summary

Advisory ID: SUSE-SU-2023:2111-1 Released: Fri May 5 14:34:00 2023 Summary: Security update for ncurses Type: security Severity: moderate Advisory ID: SUSE-SU-2023:2224-1 Released: Wed May 17 09:53:54 2023 Summary: Security update for curl Type: security Severity: important

References

References : 1210434 1211230 1211231 1211232 1211233 CVE-2023-28319 CVE-2023-28320

CVE-2023-28321 CVE-2023-28322 CVE-2023-29491

1210434,CVE-2023-29491

This update for ncurses fixes the following issues:

- CVE-2023-29491: Fixed memory corruption issues when processing malformed terminfo data (bsc#1210434).

1211230,1211231,1211232,1211233,CVE-2023-28319,CVE-2023-28320,CVE-2023-28321,CVE-2023-28322

This update for curl adds the following feature:

Update to version 8.0.1 (jsc#PED-2580)

- CVE-2023-28319: use-after-free in SSH sha256 fingerprint check (bsc#1211230).

- CVE-2023-28320: siglongjmp race condition (bsc#1211231).

- CVE-2023-28321: IDN wildcard matching (bsc#1211232).

- CVE-2023-28322: POST-after-PUT confusion (bsc#1211233).

The following package changes have been done:

- libz1-1.2.13-150500.2.3 updated

- libuuid1-2.37.4-150500.7.16 updated

- libsmartcols1-2.37.4-150500.7.16 updated

- libblkid1-2.37.4-150500.7.16 updated

- libgcrypt20-1.9.4-150500.10.19 updated

- libgcrypt20-hmac-1.9.4-150500.10.19 updated

- libfdisk1-2.37.4-150500.7.16 updated

- libncurses6-6.1-150000.5.15.1 updated

- terminfo-base-6.1-150000.5.15.1 updated

- ncurses-utils-6.1-150000.5.15.1 updated

- libopenssl1_1-1.1.1l-150500.15.4 updated

- libopenssl1_1-hmac-1.1.1l-150500.15.4 updated

- libmount1-2.37.4-150500.7.16 updated

- libcurl4-8.0.1-150400.5.23.1 updated

- sles-release-15.5-150500.43.4 updated

- util-linux-2.37.4-150500.7.16 updated

- kubevirt-virt-exportserver-0.58.0-150500.6.3 updated

- container:sles15-image-15.0.0-34.37 updated

Severity
Container Advisory ID : SUSE-CU-2023:1610-1
Container Tags : suse/sles/15.5/virt-exportserver:0.58.0 , suse/sles/15.5/virt-exportserver:0.58.0-150500.6.3 , suse/sles/15.5/virt-exportserver:0.58.0.1.264
Container Release : 1.264
Severity : important
Type : security

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.