# Security update for webkit2gtk3

Announcement ID: SUSE-SU-2023:4558-1  
Rating: important  
References:

  * bsc#1216778
  * bsc#1217210

  
Cross-References:

  * CVE-2022-32919
  * CVE-2022-32933
  * CVE-2022-46705
  * CVE-2022-46725
  * CVE-2023-32359
  * CVE-2023-41983
  * CVE-2023-42852

  
CVSS scores:

  * CVE-2022-46705 ( SUSE ):  4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
  * CVE-2022-46705 ( NVD ):  4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
  * CVE-2022-46725 ( SUSE ):  4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
  * CVE-2022-46725 ( NVD ):  4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
  * CVE-2023-32359 ( SUSE ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
  * CVE-2023-32359 ( NVD ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
  * CVE-2023-41983 ( SUSE ):  6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
  * CVE-2023-41983 ( NVD ):  6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
  * CVE-2023-42852 ( SUSE ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2023-42852 ( NVD ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

  
Affected Products:

  * SUSE Enterprise Storage 7.1
  * SUSE Linux Enterprise High Performance Computing 15 SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP3
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3
  * SUSE Linux Enterprise Server 15 SP2
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise Server 15 SP3
  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2
  * SUSE Linux Enterprise Server for SAP Applications 15 SP3

  
  
An update that solves seven vulnerabilities can now be installed.

## Description:

This update for webkit2gtk3 fixes the following issues:

Update to version 2.42.2 (bsc#1217210):

  * CVE-2023-41983: Processing web content may lead to a denial-of-service.
  * CVE-2023-42852: Processing web content may lead to arbitrary code execution.

Already previously fixed:

  * CVE-2022-32919: Visiting a website that frames malicious content may lead to
    UI spoofing (fixed already in 2.38.4).
  * CVE-2022-32933: A website may be able to track the websites a user visited
    in private browsing mode (fixed already in 2.38.0).
  * CVE-2022-46705: Visiting a malicious website may lead to address bar
    spoofing (fixed already in 2.38.4).
  * CVE-2022-46725: Visiting a malicious website may lead to address bar
    spoofing (fixed already in 2.38.4).
  * CVE-2023-32359: A user’s password may be read aloud by a text-to-speech
    accessibility feature (fixed already in 2.42.0).

Bug fixes:

  * Disable DMABuf renderer for NVIDIA proprietary drivers (bsc#1216778).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4558=1

  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-4558=1

  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-4558=1

  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4558=1

  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-4558=1

  * SUSE Linux Enterprise Server for SAP Applications 15 SP2  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4558=1

  * SUSE Linux Enterprise Server for SAP Applications 15 SP3  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP3-2023-4558=1

  * SUSE Enterprise Storage 7.1  
    zypper in -t patch SUSE-Storage-7.1-2023-4558=1

## Package List:

  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64
    x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (aarch64
    x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (aarch64
    x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x
    x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (aarch64 ppc64le s390x
    x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (ppc64le x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1
  * SUSE Enterprise Storage 7.1 (aarch64 x86_64)
    * libwebkit2gtk-4_0-37-2.42.2-150200.91.1
    * webkit2gtk3-debugsource-2.42.2-150200.91.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1
    * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1
    * webkit2gtk3-devel-2.42.2-150200.91.1
    * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1
  * SUSE Enterprise Storage 7.1 (noarch)
    * libwebkit2gtk3-lang-2.42.2-150200.91.1

## References:

  * https://www.suse.com/security/cve/CVE-2022-32919.html
  * https://www.suse.com/security/cve/CVE-2022-32933.html
  * https://www.suse.com/security/cve/CVE-2022-46705.html
  * https://www.suse.com/security/cve/CVE-2022-46725.html
  * https://www.suse.com/security/cve/CVE-2023-32359.html
  * https://www.suse.com/security/cve/CVE-2023-41983.html
  * https://www.suse.com/security/cve/CVE-2023-42852.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1216778
  * https://bugzilla.suse.com/show_bug.cgi?id=1217210

SUSE: 2023:4558-1 important: webkit2gtk3

November 24, 2023
* bsc#1216778 * bsc#1217210 Cross-References: * CVE-2022-32919

Summary

## This update for webkit2gtk3 fixes the following issues: Update to version 2.42.2 (bsc#1217210): * CVE-2023-41983: Processing web content may lead to a denial-of-service. * CVE-2023-42852: Processing web content may lead to arbitrary code execution. Already previously fixed: * CVE-2022-32919: Visiting a website that frames malicious content may lead to UI spoofing (fixed already in 2.38.4). * CVE-2022-32933: A website may be able to track the websites a user visited in private browsing mode (fixed already in 2.38.0). * CVE-2022-46705: Visiting a malicious website may lead to address bar spoofing (fixed already in 2.38.4). * CVE-2022-46725: Visiting a malicious website may lead to address bar spoofing (fixed already in 2.38.4). * CVE-2023-32359: A user’s password may be read aloud by a text-to-speech accessibility feature (fixed already in 2.42.0). Bug fixes: * Disable DMABuf renderer for NVIDIA proprietary drivers (bsc#1216778). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4558=1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-4558=1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-4558=1 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4558=1 * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 zypper in -t patch SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-4558=1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4558=1 * SUSE Linux Enterprise Server for SAP Applications 15 SP3 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP3-2023-4558=1 * SUSE Enterprise Storage 7.1 zypper in -t patch SUSE-Storage-7.1-2023-4558=1 ## Package List: * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64 x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (aarch64 x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (aarch64 x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1 * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (aarch64 ppc64le s390x x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (ppc64le x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1 * SUSE Enterprise Storage 7.1 (aarch64 x86_64) * libwebkit2gtk-4_0-37-2.42.2-150200.91.1 * webkit2gtk3-debugsource-2.42.2-150200.91.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.2-150200.91.1 * libjavascriptcoregtk-4_0-18-2.42.2-150200.91.1 * webkit2gtk3-devel-2.42.2-150200.91.1 * typelib-1_0-WebKit2-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-2.42.2-150200.91.1 * typelib-1_0-JavaScriptCore-4_0-2.42.2-150200.91.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.2-150200.91.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.2-150200.91.1 * SUSE Enterprise Storage 7.1 (noarch) * libwebkit2gtk3-lang-2.42.2-150200.91.1

References

* bsc#1216778

* bsc#1217210

Cross-

* CVE-2022-32919

* CVE-2022-32933

* CVE-2022-46705

* CVE-2022-46725

* CVE-2023-32359

* CVE-2023-41983

* CVE-2023-42852

CVSS scores:

* CVE-2022-46705 ( SUSE ): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

* CVE-2022-46705 ( NVD ): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

* CVE-2022-46725 ( SUSE ): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

* CVE-2022-46725 ( NVD ): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

* CVE-2023-32359 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

* CVE-2023-32359 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

* CVE-2023-41983 ( SUSE ): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

* CVE-2023-41983 ( NVD ): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

* CVE-2023-42852 ( SUSE ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2023-42852 ( NVD ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

* SUSE Enterprise Storage 7.1

* SUSE Linux Enterprise High Performance Computing 15 SP2

* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise High Performance Computing 15 SP3

* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3

* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3

* SUSE Linux Enterprise Server 15 SP2

* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise Server 15 SP3

* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3

* SUSE Linux Enterprise Server for SAP Applications 15 SP2

* SUSE Linux Enterprise Server for SAP Applications 15 SP3

An update that solves seven vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2022-32919.html

* https://www.suse.com/security/cve/CVE-2022-32933.html

* https://www.suse.com/security/cve/CVE-2022-46705.html

* https://www.suse.com/security/cve/CVE-2022-46725.html

* https://www.suse.com/security/cve/CVE-2023-32359.html

* https://www.suse.com/security/cve/CVE-2023-41983.html

* https://www.suse.com/security/cve/CVE-2023-42852.html

* https://bugzilla.suse.com/show_bug.cgi?id=1216778

* https://bugzilla.suse.com/show_bug.cgi?id=1217210

Severity
Announcement ID: SUSE-SU-2023:4558-1
Rating: important

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo