Discover Government News



# Security update for xorg-x11-server

Announcement ID: SUSE-SU-2023:4791-1  
Rating: important  
References:

  * bsc#1217765
  * bsc#1217766

  
Cross-References:

  * CVE-2023-6377
  * CVE-2023-6478

  
CVSS scores:

  * CVE-2023-6377 ( SUSE ):  8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
  * CVE-2023-6478 ( SUSE ):  6.2 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

  
Affected Products:

  * Basesystem Module 15-SP4
  * Development Tools Module 15-SP4
  * openSUSE Leap 15.4
  * SUSE Linux Enterprise Desktop 15 SP4
  * SUSE Linux Enterprise High Performance Computing 15 SP4
  * SUSE Linux Enterprise Real Time 15 SP4
  * SUSE Linux Enterprise Server 15 SP4
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4
  * SUSE Manager Proxy 4.3
  * SUSE Manager Retail Branch Server 4.3
  * SUSE Manager Server 4.3

  
  
An update that solves two vulnerabilities can now be installed.

## Description:

This update for xorg-x11-server fixes the following issues:

  * CVE-2023-6377: Fixed out-of-bounds memory write in XKB button actions
    (bsc#1217765).
  * CVE-2023-6478: Fixed out-of-bounds memory read in RRChangeOutputProperty and
    RRChangeProviderProperty (bsc#1217766).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch SUSE-2023-4791=1 openSUSE-SLE-15.4-2023-4791=1

  * Basesystem Module 15-SP4  
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2023-4791=1

  * Development Tools Module 15-SP4  
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2023-4791=1

## Package List:

  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
    * xorg-x11-server-source-1.20.3-150400.38.32.1
    * xorg-x11-server-debugsource-1.20.3-150400.38.32.1
    * xorg-x11-server-1.20.3-150400.38.32.1
    * xorg-x11-server-debuginfo-1.20.3-150400.38.32.1
    * xorg-x11-server-extra-1.20.3-150400.38.32.1
    * xorg-x11-server-sdk-1.20.3-150400.38.32.1
    * xorg-x11-server-extra-debuginfo-1.20.3-150400.38.32.1
  * Basesystem Module 15-SP4 (aarch64 ppc64le s390x x86_64)
    * xorg-x11-server-debugsource-1.20.3-150400.38.32.1
    * xorg-x11-server-1.20.3-150400.38.32.1
    * xorg-x11-server-debuginfo-1.20.3-150400.38.32.1
    * xorg-x11-server-extra-1.20.3-150400.38.32.1
    * xorg-x11-server-extra-debuginfo-1.20.3-150400.38.32.1
  * Development Tools Module 15-SP4 (aarch64 ppc64le s390x x86_64)
    * xorg-x11-server-debugsource-1.20.3-150400.38.32.1
    * xorg-x11-server-sdk-1.20.3-150400.38.32.1
    * xorg-x11-server-debuginfo-1.20.3-150400.38.32.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-6377.html
  * https://www.suse.com/security/cve/CVE-2023-6478.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1217765
  * https://bugzilla.suse.com/show_bug.cgi?id=1217766

SUSE: 2023:4791-1 important: xorg-x11-server

December 13, 2023
* bsc#1217765 * bsc#1217766 Cross-References: * CVE-2023-6377

Summary

## This update for xorg-x11-server fixes the following issues: * CVE-2023-6377: Fixed out-of-bounds memory write in XKB button actions (bsc#1217765). * CVE-2023-6478: Fixed out-of-bounds memory read in RRChangeOutputProperty and RRChangeProviderProperty (bsc#1217766). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch SUSE-2023-4791=1 openSUSE-SLE-15.4-2023-4791=1 * Basesystem Module 15-SP4 zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2023-4791=1 * Development Tools Module 15-SP4 zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2023-4791=1 ## Package List: * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586) * xorg-x11-server-source-1.20.3-150400.38.32.1 * xorg-x11-server-debugsource-1.20.3-150400.38.32.1 * xorg-x11-server-1.20.3-150400.38.32.1 * xorg-x11-server-debuginfo-1.20.3-150400.38.32.1 * xorg-x11-server-extra-1.20.3-150400.38.32.1 * xorg-x11-server-sdk-1.20.3-150400.38.32.1 * xorg-x11-server-extra-debuginfo-1.20.3-150400.38.32.1 * Basesystem Module 15-SP4 (aarch64 ppc64le s390x x86_64) * xorg-x11-server-debugsource-1.20.3-150400.38.32.1 * xorg-x11-server-1.20.3-150400.38.32.1 * xorg-x11-server-debuginfo-1.20.3-150400.38.32.1 * xorg-x11-server-extra-1.20.3-150400.38.32.1 * xorg-x11-server-extra-debuginfo-1.20.3-150400.38.32.1 * Development Tools Module 15-SP4 (aarch64 ppc64le s390x x86_64) * xorg-x11-server-debugsource-1.20.3-150400.38.32.1 * xorg-x11-server-sdk-1.20.3-150400.38.32.1 * xorg-x11-server-debuginfo-1.20.3-150400.38.32.1

References

* bsc#1217765

* bsc#1217766

Cross-

* CVE-2023-6377

* CVE-2023-6478

CVSS scores:

* CVE-2023-6377 ( SUSE ): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

* CVE-2023-6478 ( SUSE ): 6.2 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

* Basesystem Module 15-SP4

* Development Tools Module 15-SP4

* openSUSE Leap 15.4

* SUSE Linux Enterprise Desktop 15 SP4

* SUSE Linux Enterprise High Performance Computing 15 SP4

* SUSE Linux Enterprise Real Time 15 SP4

* SUSE Linux Enterprise Server 15 SP4

* SUSE Linux Enterprise Server for SAP Applications 15 SP4

* SUSE Manager Proxy 4.3

* SUSE Manager Retail Branch Server 4.3

* SUSE Manager Server 4.3

An update that solves two vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-6377.html

* https://www.suse.com/security/cve/CVE-2023-6478.html

* https://bugzilla.suse.com/show_bug.cgi?id=1217765

* https://bugzilla.suse.com/show_bug.cgi?id=1217766

Severity
Announcement ID: SUSE-SU-2023:4791-1
Rating: important

Related News