# Security update for webkit2gtk3

Announcement ID: SUSE-SU-2023:4824-1  
Rating: important  
References:

  * bsc#1217844

  
Cross-References:

  * CVE-2023-42916
  * CVE-2023-42917

  
CVSS scores:

  * CVE-2023-42916 ( SUSE ):  5.3 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
  * CVE-2023-42916 ( NVD ):  6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
  * CVE-2023-42917 ( SUSE ):  7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2023-42917 ( NVD ):  8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

  
Affected Products:

  * SUSE Enterprise Storage 7.1
  * SUSE Linux Enterprise High Performance Computing 15 SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP3
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3
  * SUSE Linux Enterprise Server 15 SP2
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise Server 15 SP3
  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2
  * SUSE Linux Enterprise Server for SAP Applications 15 SP3

  
  
An update that solves two vulnerabilities can now be installed.

## Description:

This update for webkit2gtk3 fixes the following issues:

Update to version 2.42.3 (bsc#1217844):

  * Fix flickering while playing videos with DMA-BUF sink.
  * Fix color picker being triggered in the inspector when typing "tan".
  * Do not special case the "sans" font family name.
  * Fix build failure with libxml2 version 2.12.0 due to an API change.
  * Fix several crashes and rendering issues.
  * Security fixes: CVE-2023-42916, CVE-2023-42917.

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-4824=1

  * SUSE Linux Enterprise Server for SAP Applications 15 SP2  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4824=1

  * SUSE Linux Enterprise Server for SAP Applications 15 SP3  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP3-2023-4824=1

  * SUSE Enterprise Storage 7.1  
    zypper in -t patch SUSE-Storage-7.1-2023-4824=1

  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4824=1

  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-4824=1

  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-4824=1

  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4824=1

## Package List:

  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (aarch64 ppc64le s390x
    x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (ppc64le x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1
  * SUSE Enterprise Storage 7.1 (aarch64 x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Enterprise Storage 7.1 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64
    x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (aarch64
    x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (aarch64
    x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x
    x86_64)
    * webkit2gtk3-debugsource-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1
    * webkit2gtk3-devel-2.42.3-150200.94.1
    * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1
    * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1
    * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1
    * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1
    * libwebkit2gtk-4_0-37-2.42.3-150200.94.1
    * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (noarch)
    * libwebkit2gtk3-lang-2.42.3-150200.94.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-42916.html
  * https://www.suse.com/security/cve/CVE-2023-42917.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1217844

SUSE: 2023:4824-1 important: webkit2gtk3

December 14, 2023
* bsc#1217844 Cross-References: * CVE-2023-42916 * CVE-2023-42917

Summary

## This update for webkit2gtk3 fixes the following issues: Update to version 2.42.3 (bsc#1217844): * Fix flickering while playing videos with DMA-BUF sink. * Fix color picker being triggered in the inspector when typing "tan". * Do not special case the "sans" font family name. * Fix build failure with libxml2 version 2.12.0 due to an API change. * Fix several crashes and rendering issues. * Security fixes: CVE-2023-42916, CVE-2023-42917. ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 zypper in -t patch SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-4824=1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4824=1 * SUSE Linux Enterprise Server for SAP Applications 15 SP3 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP3-2023-4824=1 * SUSE Enterprise Storage 7.1 zypper in -t patch SUSE-Storage-7.1-2023-4824=1 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4824=1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-4824=1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-4824=1 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4824=1 ## Package List: * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (aarch64 ppc64le s390x x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (ppc64le x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP3 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1 * SUSE Enterprise Storage 7.1 (aarch64 x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Enterprise Storage 7.1 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64 x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (aarch64 x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (aarch64 x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x x86_64) * webkit2gtk3-debugsource-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-debuginfo-2.42.3-150200.94.1 * webkit2gtk3-devel-2.42.3-150200.94.1 * typelib-1_0-JavaScriptCore-4_0-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-debuginfo-2.42.3-150200.94.1 * typelib-1_0-WebKit2WebExtension-4_0-2.42.3-150200.94.1 * webkit2gtk-4_0-injected-bundles-2.42.3-150200.94.1 * libjavascriptcoregtk-4_0-18-debuginfo-2.42.3-150200.94.1 * libwebkit2gtk-4_0-37-2.42.3-150200.94.1 * typelib-1_0-WebKit2-4_0-2.42.3-150200.94.1 * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (noarch) * libwebkit2gtk3-lang-2.42.3-150200.94.1

References

* bsc#1217844

Cross-

* CVE-2023-42916

* CVE-2023-42917

CVSS scores:

* CVE-2023-42916 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

* CVE-2023-42916 ( NVD ): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

* CVE-2023-42917 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2023-42917 ( NVD ): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

* SUSE Enterprise Storage 7.1

* SUSE Linux Enterprise High Performance Computing 15 SP2

* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise High Performance Computing 15 SP3

* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3

* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3

* SUSE Linux Enterprise Server 15 SP2

* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise Server 15 SP3

* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3

* SUSE Linux Enterprise Server for SAP Applications 15 SP2

* SUSE Linux Enterprise Server for SAP Applications 15 SP3

An update that solves two vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-42916.html

* https://www.suse.com/security/cve/CVE-2023-42917.html

* https://bugzilla.suse.com/show_bug.cgi?id=1217844

Severity
Announcement ID: SUSE-SU-2023:4824-1
Rating: important

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo