Discover Government News



# Security update for gstreamer-plugins-bad

Announcement ID: SUSE-SU-2024:0779-1  
Rating: important  
References:

  * bsc#1217213

  
Cross-References:

  * CVE-2023-44446

  
CVSS scores:

  * CVE-2023-44446 ( SUSE ):  8.0 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

  
Affected Products:

  * SUSE Linux Enterprise High Performance Computing 12 SP5
  * SUSE Linux Enterprise Server 12 SP5
  * SUSE Linux Enterprise Server for SAP Applications 12 SP5
  * SUSE Linux Enterprise Software Development Kit 12 SP5

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for gstreamer-plugins-bad fixes the following issues:

  * CVE-2023-44446: Fixed use-after-free remote code execution vulnerability via
    MXF file (bsc#1217213).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise Software Development Kit 12 SP5  
    zypper in -t patch SUSE-SLE-SDK-12-SP5-2024-779=1

  * SUSE Linux Enterprise High Performance Computing 12 SP5  
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-779=1

  * SUSE Linux Enterprise Server 12 SP5  
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-779=1

  * SUSE Linux Enterprise Server for SAP Applications 12 SP5  
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-779=1

## Package List:

  * SUSE Linux Enterprise Software Development Kit 12 SP5 (aarch64 ppc64le s390x
    x86_64)
    * libgstinsertbin-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-devel-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-1.8.3-18.15.1
    * libgstinsertbin-1_0-0-1.8.3-18.15.1
    * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1
  * SUSE Linux Enterprise High Performance Computing 12 SP5 (aarch64 x86_64)
    * libgstmpegts-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstadaptivedemux-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstbadvideo-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-1.8.3-18.15.1
    * libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstbadaudio-1_0-0-1.8.3-18.15.1
    * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-1.8.3-18.15.1
    * libgstphotography-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstadaptivedemux-1_0-0-1.8.3-18.15.1
    * libgstbadvideo-1_0-0-1.8.3-18.15.1
    * libgstbadbase-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstcodecparsers-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstphotography-1_0-0-1.8.3-18.15.1
    * libgstgl-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstcodecparsers-1_0-0-1.8.3-18.15.1
    * libgstbadbase-1_0-0-1.8.3-18.15.1
    * libgstbadaudio-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstgl-1_0-0-1.8.3-18.15.1
    * libgstmpegts-1_0-0-1.8.3-18.15.1
    * libgstbasecamerabinsrc-1_0-0-1.8.3-18.15.1
  * SUSE Linux Enterprise High Performance Computing 12 SP5 (noarch)
    * gstreamer-plugins-bad-lang-1.8.3-18.15.1
  * SUSE Linux Enterprise Server 12 SP5 (aarch64 ppc64le s390x x86_64)
    * libgstmpegts-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstadaptivedemux-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstbadvideo-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-1.8.3-18.15.1
    * libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstbadaudio-1_0-0-1.8.3-18.15.1
    * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-1.8.3-18.15.1
    * libgstphotography-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstadaptivedemux-1_0-0-1.8.3-18.15.1
    * libgstbadvideo-1_0-0-1.8.3-18.15.1
    * libgstbadbase-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstcodecparsers-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstphotography-1_0-0-1.8.3-18.15.1
    * libgstgl-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstcodecparsers-1_0-0-1.8.3-18.15.1
    * libgstbadbase-1_0-0-1.8.3-18.15.1
    * libgstbadaudio-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstgl-1_0-0-1.8.3-18.15.1
    * libgstmpegts-1_0-0-1.8.3-18.15.1
    * libgstbasecamerabinsrc-1_0-0-1.8.3-18.15.1
  * SUSE Linux Enterprise Server 12 SP5 (noarch)
    * gstreamer-plugins-bad-lang-1.8.3-18.15.1
  * SUSE Linux Enterprise Server for SAP Applications 12 SP5 (ppc64le x86_64)
    * libgstmpegts-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstadaptivedemux-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstbadvideo-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-1.8.3-18.15.1
    * libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstbadaudio-1_0-0-1.8.3-18.15.1
    * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1
    * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1
    * libgsturidownloader-1_0-0-1.8.3-18.15.1
    * libgstphotography-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstadaptivedemux-1_0-0-1.8.3-18.15.1
    * libgstbadvideo-1_0-0-1.8.3-18.15.1
    * libgstbadbase-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstcodecparsers-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstphotography-1_0-0-1.8.3-18.15.1
    * libgstgl-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstcodecparsers-1_0-0-1.8.3-18.15.1
    * libgstbadbase-1_0-0-1.8.3-18.15.1
    * libgstbadaudio-1_0-0-debuginfo-1.8.3-18.15.1
    * libgstgl-1_0-0-1.8.3-18.15.1
    * libgstmpegts-1_0-0-1.8.3-18.15.1
    * libgstbasecamerabinsrc-1_0-0-1.8.3-18.15.1
  * SUSE Linux Enterprise Server for SAP Applications 12 SP5 (noarch)
    * gstreamer-plugins-bad-lang-1.8.3-18.15.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-44446.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1217213

SUSE: 2024:0779-1 important: gstreamer-plugins-bad

March 6, 2024
* bsc#1217213 Cross-References: * CVE-2023-44446

Summary

## This update for gstreamer-plugins-bad fixes the following issues: * CVE-2023-44446: Fixed use-after-free remote code execution vulnerability via MXF file (bsc#1217213). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise Software Development Kit 12 SP5 zypper in -t patch SUSE-SLE-SDK-12-SP5-2024-779=1 * SUSE Linux Enterprise High Performance Computing 12 SP5 zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-779=1 * SUSE Linux Enterprise Server 12 SP5 zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-779=1 * SUSE Linux Enterprise Server for SAP Applications 12 SP5 zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-779=1 ## Package List: * SUSE Linux Enterprise Software Development Kit 12 SP5 (aarch64 ppc64le s390x x86_64) * libgstinsertbin-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-devel-1.8.3-18.15.1 * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1 * libgsturidownloader-1_0-0-1.8.3-18.15.1 * libgstinsertbin-1_0-0-1.8.3-18.15.1 * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1 * SUSE Linux Enterprise High Performance Computing 12 SP5 (aarch64 x86_64) * libgstmpegts-1_0-0-debuginfo-1.8.3-18.15.1 * libgstadaptivedemux-1_0-0-debuginfo-1.8.3-18.15.1 * libgstbadvideo-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-1.8.3-18.15.1 * libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-18.15.1 * libgstbadaudio-1_0-0-1.8.3-18.15.1 * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1 * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1 * libgsturidownloader-1_0-0-1.8.3-18.15.1 * libgstphotography-1_0-0-debuginfo-1.8.3-18.15.1 * libgstadaptivedemux-1_0-0-1.8.3-18.15.1 * libgstbadvideo-1_0-0-1.8.3-18.15.1 * libgstbadbase-1_0-0-debuginfo-1.8.3-18.15.1 * libgstcodecparsers-1_0-0-debuginfo-1.8.3-18.15.1 * libgstphotography-1_0-0-1.8.3-18.15.1 * libgstgl-1_0-0-debuginfo-1.8.3-18.15.1 * libgstcodecparsers-1_0-0-1.8.3-18.15.1 * libgstbadbase-1_0-0-1.8.3-18.15.1 * libgstbadaudio-1_0-0-debuginfo-1.8.3-18.15.1 * libgstgl-1_0-0-1.8.3-18.15.1 * libgstmpegts-1_0-0-1.8.3-18.15.1 * libgstbasecamerabinsrc-1_0-0-1.8.3-18.15.1 * SUSE Linux Enterprise High Performance Computing 12 SP5 (noarch) * gstreamer-plugins-bad-lang-1.8.3-18.15.1 * SUSE Linux Enterprise Server 12 SP5 (aarch64 ppc64le s390x x86_64) * libgstmpegts-1_0-0-debuginfo-1.8.3-18.15.1 * libgstadaptivedemux-1_0-0-debuginfo-1.8.3-18.15.1 * libgstbadvideo-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-1.8.3-18.15.1 * libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-18.15.1 * libgstbadaudio-1_0-0-1.8.3-18.15.1 * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1 * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1 * libgsturidownloader-1_0-0-1.8.3-18.15.1 * libgstphotography-1_0-0-debuginfo-1.8.3-18.15.1 * libgstadaptivedemux-1_0-0-1.8.3-18.15.1 * libgstbadvideo-1_0-0-1.8.3-18.15.1 * libgstbadbase-1_0-0-debuginfo-1.8.3-18.15.1 * libgstcodecparsers-1_0-0-debuginfo-1.8.3-18.15.1 * libgstphotography-1_0-0-1.8.3-18.15.1 * libgstgl-1_0-0-debuginfo-1.8.3-18.15.1 * libgstcodecparsers-1_0-0-1.8.3-18.15.1 * libgstbadbase-1_0-0-1.8.3-18.15.1 * libgstbadaudio-1_0-0-debuginfo-1.8.3-18.15.1 * libgstgl-1_0-0-1.8.3-18.15.1 * libgstmpegts-1_0-0-1.8.3-18.15.1 * libgstbasecamerabinsrc-1_0-0-1.8.3-18.15.1 * SUSE Linux Enterprise Server 12 SP5 (noarch) * gstreamer-plugins-bad-lang-1.8.3-18.15.1 * SUSE Linux Enterprise Server for SAP Applications 12 SP5 (ppc64le x86_64) * libgstmpegts-1_0-0-debuginfo-1.8.3-18.15.1 * libgstadaptivedemux-1_0-0-debuginfo-1.8.3-18.15.1 * libgstbadvideo-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-1.8.3-18.15.1 * libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-18.15.1 * libgstbadaudio-1_0-0-1.8.3-18.15.1 * gstreamer-plugins-bad-debuginfo-1.8.3-18.15.1 * libgsturidownloader-1_0-0-debuginfo-1.8.3-18.15.1 * gstreamer-plugins-bad-debugsource-1.8.3-18.15.1 * libgsturidownloader-1_0-0-1.8.3-18.15.1 * libgstphotography-1_0-0-debuginfo-1.8.3-18.15.1 * libgstadaptivedemux-1_0-0-1.8.3-18.15.1 * libgstbadvideo-1_0-0-1.8.3-18.15.1 * libgstbadbase-1_0-0-debuginfo-1.8.3-18.15.1 * libgstcodecparsers-1_0-0-debuginfo-1.8.3-18.15.1 * libgstphotography-1_0-0-1.8.3-18.15.1 * libgstgl-1_0-0-debuginfo-1.8.3-18.15.1 * libgstcodecparsers-1_0-0-1.8.3-18.15.1 * libgstbadbase-1_0-0-1.8.3-18.15.1 * libgstbadaudio-1_0-0-debuginfo-1.8.3-18.15.1 * libgstgl-1_0-0-1.8.3-18.15.1 * libgstmpegts-1_0-0-1.8.3-18.15.1 * libgstbasecamerabinsrc-1_0-0-1.8.3-18.15.1 * SUSE Linux Enterprise Server for SAP Applications 12 SP5 (noarch) * gstreamer-plugins-bad-lang-1.8.3-18.15.1

References

* bsc#1217213

Cross-

* CVE-2023-44446

CVSS scores:

* CVE-2023-44446 ( SUSE ): 8.0 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:

* SUSE Linux Enterprise High Performance Computing 12 SP5

* SUSE Linux Enterprise Server 12 SP5

* SUSE Linux Enterprise Server for SAP Applications 12 SP5

* SUSE Linux Enterprise Software Development Kit 12 SP5

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-44446.html

* https://bugzilla.suse.com/show_bug.cgi?id=1217213

Severity
Announcement ID: SUSE-SU-2024:0779-1
Rating: important

Related News