Discover Government News

=========================================================================Ubuntu Security Notice USN-2788-1
October 29, 2015

unzip vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.10
- Ubuntu 15.04
- Ubuntu 14.04 LTS
- Ubuntu 12.04 LTS

Summary:

unzip could be made to crash or run programs as your login if it opened a
specially crafted file.

Software Description:
- unzip: De-archiver for .zip files

Details:

Gustavo Grieco discovered that unzip incorrectly handled certain password
protected archives. If a user or automated system were tricked into
processing a specially crafted zip archive, an attacker could possibly
execute arbitrary code. (CVE-2015-7696)

Gustavo Grieco discovered that unzip incorrectly handled certain malformed
archives. If a user or automated system were tricked into processing a
specially crafted zip archive, an attacker could possibly cause unzip to
hang, resulting in a denial of service. (CVE-2015-7697)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.10:
  unzip                           6.0-17ubuntu1.1

Ubuntu 15.04:
  unzip                           6.0-13ubuntu3.1

Ubuntu 14.04 LTS:
  unzip                           6.0-9ubuntu1.4

Ubuntu 12.04 LTS:
  unzip                           6.0-4ubuntu2.4

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-2788-1
  CVE-2015-7696, CVE-2015-7697

Package Information:
  https://launchpad.net/ubuntu/+source/unzip/6.0-17ubuntu1.1
  https://launchpad.net/ubuntu/+source/unzip/6.0-13ubuntu3.1
  https://launchpad.net/ubuntu/+source/unzip/6.0-9ubuntu1.4
  https://launchpad.net/ubuntu/+source/unzip/6.0-4ubuntu2.4


Ubuntu 2788-1: unzip vulnerabilities

October 29, 2015
unzip could be made to crash or run programs as your login if it opened a specially crafted file.

Summary

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 15.10: unzip 6.0-17ubuntu1.1 Ubuntu 15.04: unzip 6.0-13ubuntu3.1 Ubuntu 14.04 LTS: unzip 6.0-9ubuntu1.4 Ubuntu 12.04 LTS: unzip 6.0-4ubuntu2.4 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-2788-1

CVE-2015-7696, CVE-2015-7697

Severity
October 29, 2015

Package Information

https://launchpad.net/ubuntu/+source/unzip/6.0-17ubuntu1.1 https://launchpad.net/ubuntu/+source/unzip/6.0-13ubuntu3.1 https://launchpad.net/ubuntu/+source/unzip/6.0-9ubuntu1.4 https://launchpad.net/ubuntu/+source/unzip/6.0-4ubuntu2.4

Related News