Discover Government News

=========================================================================Ubuntu Security Notice USN-2876-1
January 20, 2016

ecryptfs-utils vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.10
- Ubuntu 15.04
- Ubuntu 14.04 LTS
- Ubuntu 12.04 LTS

Summary:

mount.ecryptfs_private could be used to run programs as an administrator.

Software Description:
- ecryptfs-utils: eCryptfs cryptographic filesystem utilities

Details:

Jann Horn discovered that mount.ecryptfs_private would mount over certain
directories in the proc filesystem. A local attacker could use this to escalate
their privileges. (CVE-2016-1572)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.10:
  ecryptfs-utils                  108-0ubuntu1.1

Ubuntu 15.04:
  ecryptfs-utils                  107-0ubuntu1.3

Ubuntu 14.04 LTS:
  ecryptfs-utils                  104-0ubuntu1.14.04.4

Ubuntu 12.04 LTS:
  ecryptfs-utils                  96-0ubuntu3.5

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-2876-1
  CVE-2016-1572

Package Information:
  https://launchpad.net/ubuntu/+source/ecryptfs-utils/108-0ubuntu1.1
  https://launchpad.net/ubuntu/+source/ecryptfs-utils/107-0ubuntu1.3
  https://launchpad.net/ubuntu/+source/ecryptfs-utils/104-0ubuntu1.14.04.4
  https://launchpad.net/ubuntu/+source/ecryptfs-utils/96-0ubuntu3.5

Ubuntu 2876-1: eCryptfs vulnerability

January 20, 2016
mount.ecryptfs_private could be used to run programs as an administrator.

Summary

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 15.10: ecryptfs-utils 108-0ubuntu1.1 Ubuntu 15.04: ecryptfs-utils 107-0ubuntu1.3 Ubuntu 14.04 LTS: ecryptfs-utils 104-0ubuntu1.14.04.4 Ubuntu 12.04 LTS: ecryptfs-utils 96-0ubuntu3.5 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-2876-1

CVE-2016-1572

Severity
January 20, 2016

Package Information

https://launchpad.net/ubuntu/+source/ecryptfs-utils/108-0ubuntu1.1 https://launchpad.net/ubuntu/+source/ecryptfs-utils/107-0ubuntu1.3 https://launchpad.net/ubuntu/+source/ecryptfs-utils/104-0ubuntu1.14.04.4 https://launchpad.net/ubuntu/+source/ecryptfs-utils/96-0ubuntu3.5

Related News