Ubuntu 4236-1: Libgcrypt vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-4236-1
January 13, 2020

libgcrypt20 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.10
- Ubuntu 19.04
- Ubuntu 18.04 LTS

Summary:

Libgcrypt could be made to expose sensitive information.

Software Description:
- libgcrypt20: LGPL Crypto library

Details:

It was discovered that Libgcrypt was susceptible to a ECDSA timing attack.
An attacker could possibly use this attack to recover sensitive
information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.10:
  libgcrypt20                     1.8.4-5ubuntu2.1

Ubuntu 19.04:
  libgcrypt20                     1.8.4-3ubuntu1.1

Ubuntu 18.04 LTS:
  libgcrypt20                     1.8.1-4ubuntu1.2

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/4236-1
  CVE-2019-13627

Package Information:
  https://launchpad.net/ubuntu/+source/libgcrypt20/1.8.4-5ubuntu2.1
  https://launchpad.net/ubuntu/+source/libgcrypt20/1.8.4-3ubuntu1.1
  https://launchpad.net/ubuntu/+source/libgcrypt20/1.8.1-4ubuntu1.2

Ubuntu 4236-1: Libgcrypt vulnerability

January 13, 2020

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 19.10 - Ubuntu 19.04 - Ubuntu 18.04 LTS Summary: Libgcrypt could be made to expose sensitive information. Software Description: - libgcrypt20: LGPL Crypto library Details: It was discovered that Libgcrypt was susceptible to a ECDSA timing attack. An attacker could possibly use this attack to recover sensitive information.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 19.10: libgcrypt20 1.8.4-5ubuntu2.1 Ubuntu 19.04: libgcrypt20 1.8.4-3ubuntu1.1 Ubuntu 18.04 LTS: libgcrypt20 1.8.1-4ubuntu1.2 In general, a standard system update will make all the necessary changes.

References

https://usn.ubuntu.com/4236-1

CVE-2019-13627

Severity
Ubuntu Security Notice USN-4236-1

Package Information

https://launchpad.net/ubuntu/+source/libgcrypt20/1.8.4-5ubuntu2.1 https://launchpad.net/ubuntu/+source/libgcrypt20/1.8.4-3ubuntu1.1 https://launchpad.net/ubuntu/+source/libgcrypt20/1.8.1-4ubuntu1.2

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.