==========================================================================
Ubuntu Security Notice USN-4572-1
October 06, 2020

spice vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Spice could be made to crash or run programs if it received specially
crafted network traffic.

Software Description:
- spice: SPICE protocol client and server library

Details:

Frediano Ziglio discovered that Spice incorrectly handled QUIC image
decoding. A remote attacker could use this to cause Spice to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  libspice-server1                0.14.2-4ubuntu3.1

Ubuntu 18.04 LTS:
  libspice-server1                0.14.0-1ubuntu2.5

Ubuntu 16.04 LTS:
  libspice-server1                0.12.6-4ubuntu0.5

After a standard system update you need to restart qemu guests to make all
the necessary changes.

References:
  https://usn.ubuntu.com/4572-1
  CVE-2020-14355

Package Information:
  https://launchpad.net/ubuntu/+source/spice/0.14.2-4ubuntu3.1
  https://launchpad.net/ubuntu/+source/spice/0.14.0-1ubuntu2.5
  https://launchpad.net/ubuntu/+source/spice/0.12.6-4ubuntu0.5