==========================================================================
Ubuntu Security Notice USN-4589-1
October 15, 2020

containerd vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS

Summary:

containerd could be made to expose sensitive information over the
network.

Software Description:
- containerd: daemon to control containers

Details:

It was discovered that containerd could be made to expose sensitive
information when processing URLs in container image manifests. A
remote attacker could use this to trick the user and obtain the
user's registry credentials.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS:
  containerd                      1.2.6-0ubuntu1~16.04.4

After a standard system update you need to restart containerd to make
all the necessary changes.

References:
  https://usn.ubuntu.com/4589-1
  CVE-2020-15157

Package Information:
  https://launchpad.net/ubuntu/+source/containerd/1.2.6-0ubuntu1~16.04.4