==========================================================================
Ubuntu Security Notice USN-4666-1
December 09, 2020

lxml vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS
- Ubuntu 14.04 ESM
- Ubuntu 12.04 ESM

Summary:

lxml could allow cross-site scripting (XSS) attacks.

Software Description:
- lxml: pythonic binding for the libxml2 and libxslt libraries

Details:

It was discovered that lxml incorrectly handled certain HTML.
An attacker could possibly use this issue to cross-site scripting (XSS) attacks.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.10:
  python3-lxml                    4.5.2-1ubuntu0.1

Ubuntu 20.04 LTS:
  python-lxml                     4.5.0-1ubuntu0.1
  python3-lxml                    4.5.0-1ubuntu0.1

Ubuntu 18.04 LTS:
  python-lxml                     4.2.1-1ubuntu0.2
  python3-lxml                    4.2.1-1ubuntu0.2

Ubuntu 16.04 LTS:
  python-lxml                     3.5.0-1ubuntu0.2
  python3-lxml                    3.5.0-1ubuntu0.2

Ubuntu 14.04 ESM:
  python-lxml                     3.3.3-1ubuntu0.2+esm1
  python3-lxml                    3.3.3-1ubuntu0.2+esm1

Ubuntu 12.04 ESM:
  python-lxml                     2.3.2-1ubuntu0.4
  python3-lxml                    2.3.2-1ubuntu0.4

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/4666-1
  CVE-2020-27783

Package Information:
  https://launchpad.net/ubuntu/+source/lxml/4.5.2-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/lxml/4.5.0-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/lxml/4.2.1-1ubuntu0.2
  https://launchpad.net/ubuntu/+source/lxml/3.5.0-1ubuntu0.2