Ubuntu 4924-1: Dnsmasq vulnerabilities | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-4924-1
April 22, 2021

dnsmasq vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in Dnsmasq.

Software Description:
- dnsmasq: Small caching DNS proxy and DHCP/TFTP server

Details:

It was discovered that Dnsmasq incorrectly handled certain wildcard
synthesized NSEC records. A remote attacker could possibly use this issue
to prove the non-existence of hostnames that actually exist.
(CVE-2017-15107)

It was discovered that Dnsmasq incorrectly handled certain large DNS
packets. A remote attacker could possibly use this issue to cause Dnsmasq
to crash, resulting in a denial of service. (CVE-2019-14513)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS:
  dnsmasq                         2.75-1ubuntu0.16.04.10
  dnsmasq-base                    2.75-1ubuntu0.16.04.10
  dnsmasq-utils                   2.75-1ubuntu0.16.04.10

After a standard system update you need to reboot your computer to make all
the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-4924-1
  CVE-2017-15107, CVE-2019-14513

Package Information:
  https://launchpad.net/ubuntu/+source/dnsmasq/2.75-1ubuntu0.16.04.10

Ubuntu 4924-1: Dnsmasq vulnerabilities

April 22, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 LTS Summary: Several security issues were fixed in Dnsmasq. Software Description: - dnsmasq: Small caching DNS proxy and DHCP/TFTP server Details: It was discovered that Dnsmasq incorrectly handled certain wildcard synthesized NSEC records. A remote attacker could possibly use this issue to prove the non-existence of hostnames that actually exist. (CVE-2017-15107) It was discovered that Dnsmasq incorrectly handled certain large DNS packets. A remote attacker could possibly use this issue to cause Dnsmasq to crash, resulting in a denial of service. (CVE-2019-14513)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 LTS: dnsmasq 2.75-1ubuntu0.16.04.10 dnsmasq-base 2.75-1ubuntu0.16.04.10 dnsmasq-utils 2.75-1ubuntu0.16.04.10 After a standard system update you need to reboot your computer to make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-4924-1

CVE-2017-15107, CVE-2019-14513

Severity
Ubuntu Security Notice USN-4924-1

Package Information

https://launchpad.net/ubuntu/+source/dnsmasq/2.75-1ubuntu0.16.04.10

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.