Ubuntu 4996-2: OpenEXR vulnerabilities | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-4996-2
June 22, 2021

openexr vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in OpenEXR.

Software Description:
- openexr: tools for the OpenEXR image format

Details:

USN-4996-1 fixed several vulnerabilities in OpenEXR. This update provides
the corresponding update for Ubuntu 16.04 ESM.

Original advisory details:

 It was discovered that OpenEXR incorrectly handled certain malformed EXR
 image files. If a user were tricked into opening a crafted EXR image file,
 a remote attacker could cause a denial of service, or possibly execute
 arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
  libopenexr22                    2.2.0-10ubuntu2.6+esm1
  openexr                         2.2.0-10ubuntu2.6+esm1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-4996-2
  https://ubuntu.com/security/notices/USN-4996-1
  CVE-2021-20296, CVE-2021-23215, CVE-2021-26260, CVE-2021-3598,
  CVE-2021-3605

Ubuntu 4996-2: OpenEXR vulnerabilities

June 22, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM Summary: Several security issues were fixed in OpenEXR. Software Description: - openexr: tools for the OpenEXR image format Details: USN-4996-1 fixed several vulnerabilities in OpenEXR. This update provides the corresponding update for Ubuntu 16.04 ESM. Original advisory details: It was discovered that OpenEXR incorrectly handled certain malformed EXR image files. If a user were tricked into opening a crafted EXR image file, a remote attacker could cause a denial of service, or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: libopenexr22 2.2.0-10ubuntu2.6+esm1 openexr 2.2.0-10ubuntu2.6+esm1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-4996-2

https://ubuntu.com/security/notices/USN-4996-1

CVE-2021-20296, CVE-2021-23215, CVE-2021-26260, CVE-2021-3598,

CVE-2021-3605

Severity
Ubuntu Security Notice USN-4996-2

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.