Ubuntu 5197-1: Apache Log4j 2 vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5197-1
December 15, 2021

apache-log4j2 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 21.04
- Ubuntu 20.04 LTS

Summary:

Apache Log4j 2 could be made to crash if it received specially crafted input.

Software Description:
- apache-log4j2: Apache Log4j - Logging Framework for Java

Details:

It was found that the fix to address CVE-2021-44228 in Apache Log4j 2.15.0 was
incomplete in certain non-default configurations. An attacker could use this
vulnerability to cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  liblog4j2-java                  2.16.0-0.21.10.1

Ubuntu 21.04:
  liblog4j2-java                  2.16.0-0.21.04.1

Ubuntu 20.04 LTS:
  liblog4j2-java                  2.16.0-0.20.04.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5197-1
  CVE-2021-44228, CVE-2021-45046

Package Information:
  https://launchpad.net/ubuntu/+source/apache-log4j2/2.16.0-0.21.10.1
  https://launchpad.net/ubuntu/+source/apache-log4j2/2.16.0-0.21.04.1
  https://launchpad.net/ubuntu/+source/apache-log4j2/2.16.0-0.20.04.1

Ubuntu 5197-1: Apache Log4j 2 vulnerability

December 15, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 21.10 - Ubuntu 21.04 - Ubuntu 20.04 LTS Summary: Apache Log4j 2 could be made to crash if it received specially crafted input. Software Description: - apache-log4j2: Apache Log4j - Logging Framework for Java Details: It was found that the fix to address CVE-2021-44228 in Apache Log4j 2.15.0 was incomplete in certain non-default configurations. An attacker could use this vulnerability to cause a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 21.10: liblog4j2-java 2.16.0-0.21.10.1 Ubuntu 21.04: liblog4j2-java 2.16.0-0.21.04.1 Ubuntu 20.04 LTS: liblog4j2-java 2.16.0-0.20.04.1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5197-1

CVE-2021-44228, CVE-2021-45046

Severity
Ubuntu Security Notice USN-5197-1

Package Information

https://launchpad.net/ubuntu/+source/apache-log4j2/2.16.0-0.21.10.1 https://launchpad.net/ubuntu/+source/apache-log4j2/2.16.0-0.21.04.1 https://launchpad.net/ubuntu/+source/apache-log4j2/2.16.0-0.20.04.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.