Ubuntu 5198-1: HTMLDOC vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5198-1
December 16, 2021

htmldoc vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.04
- Ubuntu 20.04 LTS

Summary:

HTMLDOC could be made to crash if it received specially crafted
input.

Software Description:
- htmldoc: HTML processor that generates indexed HTML, PS, and PDF

Details:

It was discovered that HTMLDOC improperly handled malformed URIs from an 
input
html file. An attacker could use this to cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.04:
htmldoc 1.9.11-2ubuntu0.1
htmldoc-common 1.9.11-2ubuntu0.1

Ubuntu 20.04 LTS:
htmldoc 1.9.7-1ubuntu0.2
htmldoc-common 1.9.7-1ubuntu0.2

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5198-1
CVE-2021-23180

Package Information:
https://launchpad.net/ubuntu/+source/htmldoc/1.9.11-2ubuntu0.1
https://launchpad.net/ubuntu/+source/htmldoc/1.9.7-1ubuntu0.2

Ubuntu 5198-1: HTMLDOC vulnerability

December 17, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 21.04 - Ubuntu 20.04 LTS Summary: HTMLDOC could be made to crash if it received specially crafted input. Software Description: - htmldoc: HTML processor that generates indexed HTML, PS, and PDF Details: It was discovered that HTMLDOC improperly handled malformed URIs from an input html file. An attacker could use this to cause a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 21.04: htmldoc 1.9.11-2ubuntu0.1 htmldoc-common 1.9.11-2ubuntu0.1 Ubuntu 20.04 LTS: htmldoc 1.9.7-1ubuntu0.2 htmldoc-common 1.9.7-1ubuntu0.2 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5198-1

CVE-2021-23180

Severity
Ubuntu Security Notice USN-5198-1

Package Information

https://launchpad.net/ubuntu/+source/htmldoc/1.9.11-2ubuntu0.1 https://launchpad.net/ubuntu/+source/htmldoc/1.9.7-1ubuntu0.2

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.