Ubuntu 5203-1: Apache Log4j 2 vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5203-1
December 19, 2021

apache-log4j2 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.10
- Ubuntu 21.04
- Ubuntu 20.04 LTS

Summary:

Apache Log4j 2 could be made to crash if it received specially crafted
input.

Software Description:
- apache-log4j2: Apache Log4j - Logging Framework for Java

Details:

Hideki Okamoto and Guy Lederfein discovered that Apache Log4j 2 did not
protect against infinite recursion in lookup evaluation. A remote attacker
could possibly use this issue to cause Apache Log4j 2 to crash, leading to
a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.10:
  liblog4j2-java                  2.17.0-0.21.10.1

Ubuntu 21.04:
  liblog4j2-java                  2.17.0-0.21.04.1

Ubuntu 20.04 LTS:
  liblog4j2-java                  2.17.0-0.20.04.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5203-1
  CVE-2021-45105

Package Information:
  https://launchpad.net/ubuntu/+source/apache-log4j2/2.17.0-0.21.10.1
  https://launchpad.net/ubuntu/+source/apache-log4j2/2.17.0-0.21.04.1
  https://launchpad.net/ubuntu/+source/apache-log4j2/2.17.0-0.20.04.1

Ubuntu 5203-1: Apache Log4j 2 vulnerability

December 19, 2021

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 21.10 - Ubuntu 21.04 - Ubuntu 20.04 LTS Summary: Apache Log4j 2 could be made to crash if it received specially crafted input. Software Description: - apache-log4j2: Apache Log4j - Logging Framework for Java Details: Hideki Okamoto and Guy Lederfein discovered that Apache Log4j 2 did not protect against infinite recursion in lookup evaluation. A remote attacker could possibly use this issue to cause Apache Log4j 2 to crash, leading to a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 21.10: liblog4j2-java 2.17.0-0.21.10.1 Ubuntu 21.04: liblog4j2-java 2.17.0-0.21.04.1 Ubuntu 20.04 LTS: liblog4j2-java 2.17.0-0.20.04.1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5203-1

CVE-2021-45105

Severity
Ubuntu Security Notice USN-5203-1

Package Information

https://launchpad.net/ubuntu/+source/apache-log4j2/2.17.0-0.21.10.1 https://launchpad.net/ubuntu/+source/apache-log4j2/2.17.0-0.21.04.1 https://launchpad.net/ubuntu/+source/apache-log4j2/2.17.0-0.20.04.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.