Ubuntu 5548-1: libxml2 vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5548-1
August 04, 2022

libxml2 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

libxml2 could be made to execute arbitrary code if it received
a specially crafted file.

Software Description:
- libxml2: GNOME XML library

Details:

It was discovered that libxml2 incorrectly handled certain XML files.
An attacker could possibly use this issue to execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  libxml2                         2.9.10+dfsg-5ubuntu0.20.04.4
  libxml2-utils                   2.9.10+dfsg-5ubuntu0.20.04.4

Ubuntu 18.04 LTS:
  libxml2                         2.9.4+dfsg1-6.1ubuntu1.7
  libxml2-utils                   2.9.4+dfsg1-6.1ubuntu1.7

Ubuntu 16.04 ESM:
  libxml2                         2.9.3+dfsg1-1ubuntu0.7+esm3
  libxml2-utils                   2.9.3+dfsg1-1ubuntu0.7+esm3

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5548-1
  CVE-2016-3709

Package Information:
  https://launchpad.net/ubuntu/+source/libxml2/2.9.10+dfsg-5ubuntu0.20.04.4
  https://launchpad.net/ubuntu/+source/libxml2/2.9.4+dfsg1-6.1ubuntu1.7

Ubuntu 5548-1: libxml2 vulnerability

August 4, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS - Ubuntu 16.04 ESM Summary: libxml2 could be made to execute arbitrary code if it received a specially crafted file. Software Description: - libxml2: GNOME XML library Details: It was discovered that libxml2 incorrectly handled certain XML files. An attacker could possibly use this issue to execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 20.04 LTS: libxml2 2.9.10+dfsg-5ubuntu0.20.04.4 libxml2-utils 2.9.10+dfsg-5ubuntu0.20.04.4 Ubuntu 18.04 LTS: libxml2 2.9.4+dfsg1-6.1ubuntu1.7 libxml2-utils 2.9.4+dfsg1-6.1ubuntu1.7 Ubuntu 16.04 ESM: libxml2 2.9.3+dfsg1-1ubuntu0.7+esm3 libxml2-utils 2.9.3+dfsg1-1ubuntu0.7+esm3 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5548-1

CVE-2016-3709

Severity
Ubuntu Security Notice USN-5548-1

Package Information

https://launchpad.net/ubuntu/+source/libxml2/2.9.10+dfsg-5ubuntu0.20.04.4 https://launchpad.net/ubuntu/+source/libxml2/2.9.4+dfsg1-6.1ubuntu1.7

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.