Ubuntu 5608-1: DPDK vulnerability | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5608-1
September 13, 2022

dpdk vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

DPDK could be made to stop responding if it received specially crafted
network traffic.

Software Description:
- dpdk: set of libraries for fast packet processing

Details:

It was discovered that DPDK incorrectly handled certain Vhost headers. A
remote attacker could possibly use this issue to cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
  dpdk                            21.11.2-0ubuntu0.22.04.1

Ubuntu 20.04 LTS:
  dpdk                            19.11.13-0ubuntu0.20.04.1

Ubuntu 18.04 LTS:
  dpdk                            17.11.10-0ubuntu0.2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5608-1
  CVE-2022-2132

Package Information:
  https://launchpad.net/ubuntu/+source/dpdk/21.11.2-0ubuntu0.22.04.1
  https://launchpad.net/ubuntu/+source/dpdk/19.11.13-0ubuntu0.20.04.1
  https://launchpad.net/ubuntu/+source/dpdk/17.11.10-0ubuntu0.2

Ubuntu 5608-1: DPDK vulnerability

September 13, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS Summary: DPDK could be made to stop responding if it received specially crafted network traffic. Software Description: - dpdk: set of libraries for fast packet processing Details: It was discovered that DPDK incorrectly handled certain Vhost headers. A remote attacker could possibly use this issue to cause a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: dpdk 21.11.2-0ubuntu0.22.04.1 Ubuntu 20.04 LTS: dpdk 19.11.13-0ubuntu0.20.04.1 Ubuntu 18.04 LTS: dpdk 17.11.10-0ubuntu0.2 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5608-1

CVE-2022-2132

Severity
Ubuntu Security Notice USN-5608-1

Package Information

https://launchpad.net/ubuntu/+source/dpdk/21.11.2-0ubuntu0.22.04.1 https://launchpad.net/ubuntu/+source/dpdk/19.11.13-0ubuntu0.20.04.1 https://launchpad.net/ubuntu/+source/dpdk/17.11.10-0ubuntu0.2

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.