Ubuntu 5609-1: .NET 6 vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5609-1
September 13, 2022

dotnet6 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS

Summary:

.NET 6 could be made to crash if it parsed a specially crafted file.

Software Description:
- dotnet6: dotNET CLI tools and runtime

Details:

Graham Esau discovered that .NET 6 incorrectly parsed certain payloads
during model binding. An attacker could possibly use this issue to
cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
   aspnetcore-runtime-6.0          6.0.109-0ubuntu1~22.04.1
   dotnet-host                             6.0.109-0ubuntu1~22.04.1
   dotnet-hostfxr-6.0                   6.0.109-0ubuntu1~22.04.1
   dotnet-runtime-6.0                  6.0.109-0ubuntu1~22.04.1
   dotnet-sdk-6.0                        6.0.109-0ubuntu1~22.04.1
   dotnet6                                   6.0.109-0ubuntu1~22.04.1

In general, a standard system update will make all the necessary 
changes. A restart may be required after the update if any affected 
files are being used.

References:
   https://ubuntu.com/security/notices/USN-5609-1
   CVE-2022-38013

Package Information:
   https://launchpad.net/ubuntu/+source/dotnet6/6.0.109-0ubuntu1~22.04.1

Ubuntu 5609-1: .NET 6 vulnerability

September 13, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS Summary: .NET 6 could be made to crash if it parsed a specially crafted file. Software Description: - dotnet6: dotNET CLI tools and runtime Details: Graham Esau discovered that .NET 6 incorrectly parsed certain payloads during model binding. An attacker could possibly use this issue to cause a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: aspnetcore-runtime-6.0 6.0.109-0ubuntu1~22.04.1 dotnet-host 6.0.109-0ubuntu1~22.04.1 dotnet-hostfxr-6.0 6.0.109-0ubuntu1~22.04.1 dotnet-runtime-6.0 6.0.109-0ubuntu1~22.04.1 dotnet-sdk-6.0 6.0.109-0ubuntu1~22.04.1 dotnet6 6.0.109-0ubuntu1~22.04.1 In general, a standard system update will make all the necessary changes. A restart may be required after the update if any affected files are being used.

References

https://ubuntu.com/security/notices/USN-5609-1

CVE-2022-38013

Severity
Ubuntu Security Notice USN-5609-1

Package Information

https://launchpad.net/ubuntu/+source/dotnet6/6.0.109-0ubuntu1~22.04.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.