Ubuntu 5721-1: WavPack vulnerability | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5721-1
November 10, 2022

wavpack vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

WavPack could be made to crash if it opened a specially crafted
file.

Software Description:
- wavpack: audio codec (lossy and lossless) - encoder and decoder

Details:

It was discovered that WavPack was not properly performing checks
when dealing with memory. If a user were tricked into decompressing a
specially crafted WavPack Audio File, an attacker could possibly use
this issue to cause the WavPack decompressor to crash, resulting in a
denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
   libwavpack1                     4.75.2-2ubuntu0.2+esm1
   wavpack                         4.75.2-2ubuntu0.2+esm1

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5721-1
   CVE-2022-2476


Ubuntu 5721-1: WavPack vulnerability

November 10, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM Summary: WavPack could be made to crash if it opened a specially crafted file. Software Description: - wavpack: audio codec (lossy and lossless) - encoder and decoder Details: It was discovered that WavPack was not properly performing checks when dealing with memory. If a user were tricked into decompressing a specially crafted WavPack Audio File, an attacker could possibly use this issue to cause the WavPack decompressor to crash, resulting in a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM:   libwavpack1                     4.75.2-2ubuntu0.2+esm1   wavpack                         4.75.2-2ubuntu0.2+esm1 In general, a standard system update will make all the necessary changes.

References

  https://ubuntu.com/security/notices/USN-5721-1

  CVE-2022-2476

Severity
Ubuntu Security Notice USN-5721-1

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.