Ubuntu 5806-1: Ruby vulnerability | LinuxSecurity.com
==========================================================================

Ubuntu Security Notice USN-5806-1
January 17, 2023

ruby2.3 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

Ruby could allow for internet traffic to be modified if
a vulnerable application processed malicious user input.

Software Description:
- ruby2.3: Object-oriented scripting language

Details:

Hiroshi Tokumaru discovered that Ruby did not properly handle certain
user input for applications which generate HTTP responses using cgi gem.
An attacker could possibly use this issue to maliciously modify the
response a user would receive from a vulnerable application.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
   libruby2.3                      2.3.1-2~ubuntu16.04.16+esm4
   ruby2.3                         2.3.1-2~ubuntu16.04.16+esm4

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5806-1 

   CVE-2021-33621

Ubuntu 5806-1: Ruby vulnerability

January 17, 2023
Ruby could allow for internet traffic to be modified if a vulnerable application processed malicious user input.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM Summary: Ruby could allow for internet traffic to be modified if a vulnerable application processed malicious user input. Software Description: - ruby2.3: Object-oriented scripting language Details: Hiroshi Tokumaru discovered that Ruby did not properly handle certain user input for applications which generate HTTP responses using cgi gem. An attacker could possibly use this issue to maliciously modify the response a user would receive from a vulnerable application.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM:   libruby2.3                      2.3.1-2~ubuntu16.04.16+esm4   ruby2.3                         2.3.1-2~ubuntu16.04.16+esm4 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5806-1

  CVE-2021-33621

Severity

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.