Discover Government News

==========================================================================
Ubuntu Security Notice USN-6557-1
December 14, 2023

vim vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in Vim.

Software Description:
- vim: Vi IMproved - enhanced vi editor

Details:

It was discovered that Vim could be made to dereference invalid memory. An
attacker could possibly use this issue to cause a denial of service. This
issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04
LTS. (CVE-2022-1725)

It was discovered that Vim could be made to recurse infinitely. An
attacker could possibly use this issue to cause a denial of service. This
issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS,
Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2022-1771)

It was discovered that Vim could be made to write out of bounds with a put
command. An attacker could possibly use this issue to cause a denial of
service or execute arbitrary code. This issue only affected Ubuntu 22.04
LTS. (CVE-2022-1886)

It was discovered that Vim could be made to write out of bounds. An
attacker could possibly use this issue to cause a denial of service or
execute arbitrary code. This issue only affected Ubuntu 14.04 LTS, Ubuntu
18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2022-1897,
CVE-2022-2000)

It was discovered that Vim did not properly manage memory in the spell
command. An attacker could possibly use this issue to cause a denial of
service or execute arbitrary code. This issue only affected Ubuntu 22.04
LTS. (CVE-2022-2042)

It was discovered that Vim did not properly manage memory. An attacker
could possibly use this issue to cause a denial of service or execute
arbitrary code. (CVE-2023-46246, CVE-2023-48231)

It was discovered that Vim could be made to divide by zero. An attacker
could possibly use this issue to cause a denial of service. This issue
only affected Ubuntu 23.04 and Ubuntu 23.10. (CVE-2023-48232)

It was discovered that Vim contained multiple arithmetic overflows. An
attacker could possibly use these issues to cause a denial of service.
(CVE-2023-48233, CVE-2023-48234, CVE-2023-48235, CVE-2023-48236,
CVE-2023-48237)

It was discovered that Vim did not properly manage memory in the
substitute command. An attacker could possibly use this issue to cause a
denial of service or execute arbitrary code. This issue only affected
Ubuntu 22.04 LTS, Ubuntu 23.04, and Ubuntu 23.10. (CVE-2023-48706)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
   vim                             2:9.0.1672-1ubuntu2.2
   vim-athena                      2:9.0.1672-1ubuntu2.2
   vim-gtk3                        2:9.0.1672-1ubuntu2.2
   vim-nox                         2:9.0.1672-1ubuntu2.2
   vim-tiny                        2:9.0.1672-1ubuntu2.2
   xxd                             2:9.0.1672-1ubuntu2.2

Ubuntu 23.04:
   vim                             2:9.0.1000-4ubuntu3.3
   vim-athena                      2:9.0.1000-4ubuntu3.3
   vim-gtk3                        2:9.0.1000-4ubuntu3.3
   vim-nox                         2:9.0.1000-4ubuntu3.3
   vim-tiny                        2:9.0.1000-4ubuntu3.3
   xxd                             2:9.0.1000-4ubuntu3.3

Ubuntu 22.04 LTS:
   vim                             2:8.2.3995-1ubuntu2.15
   vim-athena                      2:8.2.3995-1ubuntu2.15
   vim-gtk                         2:8.2.3995-1ubuntu2.15
   vim-gtk3                        2:8.2.3995-1ubuntu2.15
   vim-nox                         2:8.2.3995-1ubuntu2.15
   vim-tiny                        2:8.2.3995-1ubuntu2.15
   xxd                             2:8.2.3995-1ubuntu2.15

Ubuntu 20.04 LTS:
   vim                             2:8.1.2269-1ubuntu5.21
   vim-athena                      2:8.1.2269-1ubuntu5.21
   vim-gtk                         2:8.1.2269-1ubuntu5.21
   vim-gtk3                        2:8.1.2269-1ubuntu5.21
   vim-nox                         2:8.1.2269-1ubuntu5.21
   vim-tiny                        2:8.1.2269-1ubuntu5.21
   xxd                             2:8.1.2269-1ubuntu5.21

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
   vim                             2:8.0.1453-1ubuntu1.13+esm7
   vim-athena                      2:8.0.1453-1ubuntu1.13+esm7
   vim-gtk                         2:8.0.1453-1ubuntu1.13+esm7
   vim-gtk3                        2:8.0.1453-1ubuntu1.13+esm7
   vim-nox                         2:8.0.1453-1ubuntu1.13+esm7
   vim-tiny                        2:8.0.1453-1ubuntu1.13+esm7
   xxd                             2:8.0.1453-1ubuntu1.13+esm7

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
   vim                             2:7.4.1689-3ubuntu1.5+esm22
   vim-athena                      2:7.4.1689-3ubuntu1.5+esm22
   vim-gtk                         2:7.4.1689-3ubuntu1.5+esm22
   vim-gtk3                        2:7.4.1689-3ubuntu1.5+esm22
   vim-nox                         2:7.4.1689-3ubuntu1.5+esm22
   vim-tiny                        2:7.4.1689-3ubuntu1.5+esm22

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
   vim                             2:7.4.052-1ubuntu3.1+esm15
   vim-athena                      2:7.4.052-1ubuntu3.1+esm15
   vim-gtk                         2:7.4.052-1ubuntu3.1+esm15
   vim-nox                         2:7.4.052-1ubuntu3.1+esm15
   vim-tiny                        2:7.4.052-1ubuntu3.1+esm15

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-6557-1
   CVE-2022-1725, CVE-2022-1771, CVE-2022-1886, CVE-2022-1897,
   CVE-2022-2000, CVE-2022-2042, CVE-2023-46246, CVE-2023-48231,
   CVE-2023-48232, CVE-2023-48233, CVE-2023-48234, CVE-2023-48235,
   CVE-2023-48236, CVE-2023-48237, CVE-2023-48706

Package Information:
   https://launchpad.net/ubuntu/+source/vim/2:9.0.1672-1ubuntu2.2
   https://launchpad.net/ubuntu/+source/vim/2:9.0.1000-4ubuntu3.3
   https://launchpad.net/ubuntu/+source/vim/2:8.2.3995-1ubuntu2.15
   https://launchpad.net/ubuntu/+source/vim/2:8.1.2269-1ubuntu5.21

Ubuntu 6557-1: Vim vulnerabilities

December 14, 2023
Several security issues were fixed in Vim.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 23.10 - Ubuntu 23.04 - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS (Available with Ubuntu Pro) - Ubuntu 16.04 LTS (Available with Ubuntu Pro) - Ubuntu 14.04 LTS (Available with Ubuntu Pro) Summary: Several security issues were fixed in Vim. Software Description: - vim: Vi IMproved - enhanced vi editor Details: It was discovered that Vim could be made to dereference invalid memory. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2022-1725) It was discovered that Vim could be made to recurse infinitely. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2022-1771) It was discovered that Vim could be made to write out of bounds with a put command. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-1886) It was discovered that Vim could be made to write out of bounds. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 14.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2022-1897, CVE-2022-2000) It was discovered that Vim did not properly manage memory in the spell command. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-2042) It was discovered that Vim did not properly manage memory. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2023-46246, CVE-2023-48231) It was discovered that Vim could be made to divide by zero. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 23.04 and Ubuntu 23.10. (CVE-2023-48232) It was discovered that Vim contained multiple arithmetic overflows. An attacker could possibly use these issues to cause a denial of service. (CVE-2023-48233, CVE-2023-48234, CVE-2023-48235, CVE-2023-48236, CVE-2023-48237) It was discovered that Vim did not properly manage memory in the substitute command. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS, Ubuntu 23.04, and Ubuntu 23.10. (CVE-2023-48706)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 23.10:   vim                             2:9.0.1672-1ubuntu2.2   vim-athena                      2:9.0.1672-1ubuntu2.2   vim-gtk3                        2:9.0.1672-1ubuntu2.2   vim-nox                         2:9.0.1672-1ubuntu2.2   vim-tiny                        2:9.0.1672-1ubuntu2.2   xxd                             2:9.0.1672-1ubuntu2.2 Ubuntu 23.04:   vim                             2:9.0.1000-4ubuntu3.3   vim-athena                      2:9.0.1000-4ubuntu3.3   vim-gtk3                        2:9.0.1000-4ubuntu3.3   vim-nox                         2:9.0.1000-4ubuntu3.3   vim-tiny                        2:9.0.1000-4ubuntu3.3   xxd                             2:9.0.1000-4ubuntu3.3 Ubuntu 22.04 LTS:   vim                             2:8.2.3995-1ubuntu2.15   vim-athena                      2:8.2.3995-1ubuntu2.15   vim-gtk                         2:8.2.3995-1ubuntu2.15   vim-gtk3                        2:8.2.3995-1ubuntu2.15   vim-nox                         2:8.2.3995-1ubuntu2.15   vim-tiny                        2:8.2.3995-1ubuntu2.15   xxd                             2:8.2.3995-1ubuntu2.15 Ubuntu 20.04 LTS:   vim                             2:8.1.2269-1ubuntu5.21   vim-athena                      2:8.1.2269-1ubuntu5.21   vim-gtk                         2:8.1.2269-1ubuntu5.21   vim-gtk3                        2:8.1.2269-1ubuntu5.21   vim-nox                         2:8.1.2269-1ubuntu5.21   vim-tiny                        2:8.1.2269-1ubuntu5.21   xxd                             2:8.1.2269-1ubuntu5.21 Ubuntu 18.04 LTS (Available with Ubuntu Pro):   vim                             2:8.0.1453-1ubuntu1.13+esm7   vim-athena                      2:8.0.1453-1ubuntu1.13+esm7   vim-gtk                         2:8.0.1453-1ubuntu1.13+esm7   vim-gtk3                        2:8.0.1453-1ubuntu1.13+esm7   vim-nox                         2:8.0.1453-1ubuntu1.13+esm7   vim-tiny                        2:8.0.1453-1ubuntu1.13+esm7   xxd                             2:8.0.1453-1ubuntu1.13+esm7 Ubuntu 16.04 LTS (Available with Ubuntu Pro):   vim                             2:7.4.1689-3ubuntu1.5+esm22   vim-athena                      2:7.4.1689-3ubuntu1.5+esm22   vim-gtk                         2:7.4.1689-3ubuntu1.5+esm22   vim-gtk3                        2:7.4.1689-3ubuntu1.5+esm22   vim-nox                         2:7.4.1689-3ubuntu1.5+esm22   vim-tiny                        2:7.4.1689-3ubuntu1.5+esm22 Ubuntu 14.04 LTS (Available with Ubuntu Pro):   vim                             2:7.4.052-1ubuntu3.1+esm15   vim-athena                      2:7.4.052-1ubuntu3.1+esm15   vim-gtk                         2:7.4.052-1ubuntu3.1+esm15   vim-nox                         2:7.4.052-1ubuntu3.1+esm15   vim-tiny                        2:7.4.052-1ubuntu3.1+esm15 In general, a standard system update will make all the necessary changes.

References

  https://ubuntu.com/security/notices/USN-6557-1

  CVE-2022-1725, CVE-2022-1771, CVE-2022-1886, CVE-2022-1897,

  CVE-2022-2000, CVE-2022-2042, CVE-2023-46246, CVE-2023-48231,

  CVE-2023-48232, CVE-2023-48233, CVE-2023-48234, CVE-2023-48235,

  CVE-2023-48236, CVE-2023-48237, CVE-2023-48706

Severity
Ubuntu Security Notice USN-6557-1

Package Information

  https://launchpad.net/ubuntu/+source/vim/2:9.0.1672-1ubuntu2.2   https://launchpad.net/ubuntu/+source/vim/2:9.0.1000-4ubuntu3.3   https://launchpad.net/ubuntu/+source/vim/2:8.2.3995-1ubuntu2.15   https://launchpad.net/ubuntu/+source/vim/2:8.1.2269-1ubuntu5.21

Related News