==========================================================================
Ubuntu Security Notice USN-6616-1
January 30, 2024

openldap vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

OpenLDAP could be made to crash if it received specially crafted input.

Software Description:
- openldap: Lightweight Directory Access Protocol

Details:

It was discovered that OpenLDAP was not properly performing bounds checks
when executing functions related to LDAP URLs. An attacker could possibly
use this issue to cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
   slapd                           2.5.16+dfsg-0ubuntu0.22.04.2

Ubuntu 20.04 LTS:
   slapd                           2.4.49+dfsg-2ubuntu1.10

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-6616-1
   CVE-2023-2953

Package Information:
   https://launchpad.net/ubuntu/+source/openldap/2.5.16+dfsg-0ubuntu0.22.04.2
   https://launchpad.net/ubuntu/+source/openldap/2.4.49+dfsg-2ubuntu1.10

Ubuntu 6616-1: OpenLDAP vulnerability

January 30, 2024
OpenLDAP could be made to crash if it received specially crafted input.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS Summary: OpenLDAP could be made to crash if it received specially crafted input. Software Description: - openldap: Lightweight Directory Access Protocol Details: It was discovered that OpenLDAP was not properly performing bounds checks when executing functions related to LDAP URLs. An attacker could possibly use this issue to cause a denial of service.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: slapd 2.5.16+dfsg-0ubuntu0.22.04.2 Ubuntu 20.04 LTS: slapd 2.4.49+dfsg-2ubuntu1.10 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-6616-1

CVE-2023-2953

Severity
Ubuntu Security Notice USN-6616-1

Package Information

https://launchpad.net/ubuntu/+source/openldap/2.5.16+dfsg-0ubuntu0.22.04.2 https://launchpad.net/ubuntu/+source/openldap/2.4.49+dfsg-2ubuntu1.10

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo