Discover Government News

==========================================================================
Ubuntu Security Notice USN-6715-1
March 27, 2024

unixodbc vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

unixODBC could be made to crash or execute arbitrary code.

Software Description:
- unixodbc: Basic ODBC tools

Details:

It was discovered that unixODBC incorrectly handled certain bytes.
An attacker could use this issue to execute arbitrary code or cause
a crash.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
  libodbc2                        2.3.12-1ubuntu0.23.10.1
  unixodbc                        2.3.12-1ubuntu0.23.10.1

Ubuntu 22.04 LTS:
  libodbc1                        2.3.9-5ubuntu0.1
  libodbc2                        2.3.9-5ubuntu0.1
  unixodbc                        2.3.9-5ubuntu0.1

Ubuntu 20.04 LTS:
  libodbc1                        2.3.6-0.1ubuntu0.1
  unixodbc                        2.3.6-0.1ubuntu0.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
  libodbc1                        2.3.4-1.1ubuntu3+esm1
  unixodbc                        2.3.4-1.1ubuntu3+esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
  libodbc1                        2.3.1-4.1ubuntu0.1~esm2
  unixodbc                        2.3.1-4.1ubuntu0.1~esm2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6715-1
  CVE-2024-1013

Package Information:
  https://launchpad.net/ubuntu/+source/unixodbc/2.3.12-1ubuntu0.23.10.1
  https://launchpad.net/ubuntu/+source/unixodbc/2.3.9-5ubuntu0.1
  https://launchpad.net/ubuntu/+source/unixodbc/2.3.6-0.1ubuntu0.1

Ubuntu 6715-1: unixODBC vulnerability

March 28, 2024
unixODBC could be made to crash or execute arbitrary code.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 23.10 - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS (Available with Ubuntu Pro) - Ubuntu 16.04 LTS (Available with Ubuntu Pro) Summary: unixODBC could be made to crash or execute arbitrary code. Software Description: - unixodbc: Basic ODBC tools Details: It was discovered that unixODBC incorrectly handled certain bytes. An attacker could use this issue to execute arbitrary code or cause a crash.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 23.10: libodbc2 2.3.12-1ubuntu0.23.10.1 unixodbc 2.3.12-1ubuntu0.23.10.1 Ubuntu 22.04 LTS: libodbc1 2.3.9-5ubuntu0.1 libodbc2 2.3.9-5ubuntu0.1 unixodbc 2.3.9-5ubuntu0.1 Ubuntu 20.04 LTS: libodbc1 2.3.6-0.1ubuntu0.1 unixodbc 2.3.6-0.1ubuntu0.1 Ubuntu 18.04 LTS (Available with Ubuntu Pro): libodbc1 2.3.4-1.1ubuntu3+esm1 unixodbc 2.3.4-1.1ubuntu3+esm1 Ubuntu 16.04 LTS (Available with Ubuntu Pro): libodbc1 2.3.1-4.1ubuntu0.1~esm2 unixodbc 2.3.1-4.1ubuntu0.1~esm2 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-6715-1

CVE-2024-1013

Severity
Ubuntu Security Notice USN-6715-1

Package Information

https://launchpad.net/ubuntu/+source/unixodbc/2.3.12-1ubuntu0.23.10.1 https://launchpad.net/ubuntu/+source/unixodbc/2.3.9-5ubuntu0.1 https://launchpad.net/ubuntu/+source/unixodbc/2.3.6-0.1ubuntu0.1

Related News