ArchLinux: 201910-13: pacman: arbitrary command execution

    Date 23 Oct 2019
    696
    Posted By LinuxSecurity Advisories
    The package pacman before version 5.2.0-1 is vulnerable to arbitrary command execution.
    Arch Linux Security Advisory ASA-201910-13
    ==========================================
    
    Severity: High
    Date    : 2019-10-23
    CVE-ID  : CVE-2019-18182 CVE-2019-18183
    Package : pacman
    Type    : arbitrary command execution
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1049
    
    Summary
    =======
    
    The package pacman before version 5.2.0-1 is vulnerable to arbitrary
    command execution.
    
    Resolution
    ==========
    
    Upgrade to 5.2.0-1.
    
    # pacman -Syu "pacman>=5.2.0-1"
    
    The problems have been fixed upstream in version 5.2.0.
    
    Workaround
    ==========
    
    For CVE-2019-18182:
        Ensure `XferCommand` is commented out in `/etc/pacman.conf`
    
    For CVE-2019-18183:
        Ensure `UseDelta` is commented out in `/etc/pacman.conf`
    
    Description
    ===========
    
    - CVE-2019-18182 (arbitrary command execution)
    
    pacman before 5.2 is vulnerable to arbitrary command injection in
    src/pacman/conf.c in the download_with_xfercommand() function. This can
    be exploited when unsigned databases are used. To exploit the
    vulnerability, the user must enable a non-default XferCommand and
    retrieve an attacker-controlled crafted database and package.
    
    - CVE-2019-18183 (arbitrary command execution)
    
    pacman before 5.2 is vulnerable to arbitrary command injection in
    lib/libalpm/sync.c in the apply_deltas() function. This can be
    exploited when unsigned databases are used. To exploit the
    vulnerability, the user must enable the non-default delta feature and
    retrieve an attacker-controlled crafted database and delta file.
    
    Impact
    ======
    
    A remote attacker is able to execute arbitrary commands on the host
    with a specially crafted database and a package or delta file.
    
    References
    ==========
    
    https://git.archlinux.org/pacman.git/tree/src/pacman/conf.c?h=v5.1.3#n263
    https://git.archlinux.org/pacman.git/commit/?id=808a4f15ce82d2ed7eeb06de73d0f313620558ee
    https://git.archlinux.org/pacman.git/tree/lib/libalpm/sync.c?h=v5.1.3#n767
    https://git.archlinux.org/pacman.git/commit/?id=c0e9be7973be6c81b22fde91516fb8991e7bb07b
    https://security.archlinux.org/CVE-2019-18182
    https://security.archlinux.org/CVE-2019-18183
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"2","type":"x","order":"1","pct":40,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"2","type":"x","order":"2","pct":40,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":20,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.