ArchLinux: 201910-14: php: arbitrary code execution

    Date 28 Oct 2019
    793
    Posted By LinuxSecurity Advisories
    The package php before version 7.3.11-1 is vulnerable to arbitrary code execution.
    Arch Linux Security Advisory ASA-201910-14
    ==========================================
    
    Severity: Critical
    Date    : 2019-10-25
    CVE-ID  : CVE-2019-11043
    Package : php
    Type    : arbitrary code execution
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1052
    
    Summary
    =======
    
    The package php before version 7.3.11-1 is vulnerable to arbitrary code
    execution.
    
    Resolution
    ==========
    
    Upgrade to 7.3.11-1.
    
    # pacman -Syu "php>=7.3.11-1"
    
    The problem has been fixed upstream in version 7.3.11.
    
    Workaround
    ==========
    
    If nginx and php-fpm share the same filesystem, one can first check the
    script actually exists, so the malicious request will never make it to
    php-fpm (it is usually done using something like `try_files $uri
    =404`). Or there may be cgi.fix_pathinfo=0 which will also prevent
    exploitation.
    
    Description
    ===========
    
    A buffer underflow issue has been found in the php-fpm component of php
    before 7.3.11, 7.2.24 and 7.1.33, leading to remote code execution in
    certain nginx + php-fpm configurations. This vulnerability can be
    exploited if the fastcgi_split_path_info directive contains a regexp
    that can be broken by an attacker by supplying %0a in the path info
    which results in the fastcgi_param PATH_INFO being empty.
    
    Impact
    ======
    
    A remote attacker is able to execute arbitrary code on the affected
    host by supplying %0a in the path info if php-fpm is used with a
    vulnerable nginx configuration.
    
    References
    ==========
    
    https://bugs.php.net/bug.php?id=78599
    https://git.php.net/?p=php-src.git;a=commitdiff;h=19e17d3807e6cc0b1ba9443ec5facbd33a61f8fe
    https://github.com/neex/phuip-fpizdam
    https://security.archlinux.org/CVE-2019-11043
    
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"2","type":"x","order":"1","pct":40,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"2","type":"x","order":"2","pct":40,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":20,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.